.NODE

Step 2: Basic Router Setup

Step 2 Basic Router Setup

As soon as you have the equipment on hand, the configuration of the real system can start. You can do this either by copying and pasting the staging configuration you built in the preceding section or by working through the following sections to set up the basic router and then the Cisco CME and Cisco UE parameters. Even if you use the staging configuration, it is still recommended that you scan the steps in this chapter. This will help you make sure that the parameters in the staged configuration are, in fact, the values you want for your real system configuration. It also helps you make any adjustments along the way to tailor the system for your use.

Installing Hardware and Software

Cisco routers and Cisco UE ship from the factory preinstalled with the hardware and software you ordered. Unless you have to upgrade the software, there is no need to do an installation when you unpack your equipment. If you have to make changes from what was ordered, or if you're reusing older equipment, power down the router, insert the hardware components, and power the router back up. Refer to Cisco.com for instructions for all types of hardware.

Follow the software installation instructions for Cisco CME and Cisco UE provided in Chapter 13. Ensure that you have an IP Voice or greater image running on your router. You should install the releases of Cisco CME and Cisco UE that have the feature complement you're interested in. Install at least Cisco CME 3.2 (12.3.11T) or Cisco UE release 2.0 to get the features discussed in this chapter.

Configuring Router IP Addressing

Connect to your router's console port, and enter an IP address for the Ethernet interface so that you can connect the router to your network:

interface FastEthernet0/0
 ip address 10.1.235.1 255.255.0.0

Also, set your router's host name to a descriptive string. For Site A, the name is cme-3725:

hostname cme-3725

 

Setting the Router Clock

Ensure that the clock is set correctly on your router, for example:

cme-3725#clock set 10:00:00 19 Aug 2004

You might also set the router clock using Network Time Protocol (NTP). The details are given in the section "Configuring NTP."

Setting Up the LAN Switch

You can use either an external LAN switch or an internal EtherSwitch housed inside the router chassis. You should define virtual LAN (VLAN) for both voice and data traffic.

External LAN Switch

For an external LAN switch, to enable separate VLANs for voice and data on a single router port, configure a trunk between the Cisco CME router and the LAN switch. The Cisco Catalyst 3550 and 3560 support autodetection of the VLAN type for IP phones (voice VLAN) and PCs (data VLAN). VLAN configuration varies between LAN switch types. Consult the appropriate documentation for the LAN switch model you are using.

Internal EtherSwitch

You can use several internal EtherSwitch network modules on a Cisco CME router, such as the NM-16ESW-PWR. If you need only one voice VLAN, the simplest configuration is to use the default VLAN 1 for all the IP phones connected to the same EtherSwitch, as shown in Example 15-1. The configuration in Example 15-1 shows an internal EtherSwitch module, but the actual Site A configuration in the full configurations being built in this chapter uses an external LAN switch.

Example 15-1. Internal EtherSwitch Module Configuration

Router#show running-config
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool ipphone
 network 192.168.1.0 255.255.255.0
 option 150 ip 192.168.1.1
 default-router 192.168.1.251
 dns-server 171.70.168.183
!
ip dhcp-server 192.168.1.1
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
interface FastEthernet4/0
 no ip address
!
interface FastEthernet4/1
 no ip address

interface FastEthernet4/2
 no ip address

 interface FastEthernet4/3
 no ip address

 interface FastEthernet4/4
 no ip address
!output omitted for brevity

 

Connecting Phones

Connect your IP phones to the LAN switch, and verify that they are powered. Confirm that there is connectivity between the router and the LAN switch.

Connecting the TFTP Server

Confirm that your TFTP server can be reached across the network by doing a ping from the router to the server's IP address.

Downloading and Extracting Cisco CME Files

Download the Cisco CME GUI files from http://www.cisco.com/cgi-bin/tablebuild.pl/ip-iostsp, and extract them into the router Flash memory. This process is described in Chapter 13 in the section "GUI File Installation."

Step 3 Initial Cisco CME System Setup

Part I: Cisco IP Communications Express Overview

Introducing Cisco IPC Express

Building a Cisco IPC Express Network

Cisco IPC Express Architecture Overview

Part II: Feature Operation and Applications

Cisco IP Phone Options

Cisco CME Call Processing Features

Cisco CME PSTN Connectivity Options

Connecting Multiple Cisco CMEs with VoIP

Integrating Cisco CME with Cisco CallManager

Cisco IPC Express Automated Attendant Options

Cisco IPC Express Integrated Voice Mail

Cisco CME External Voice Mail Options

Additional External Applications with Cisco CME

Part III: Administration and Management

Cisco IPC Express General Administration and Initial System Setup

Configuring and Managing Cisco IPC Express Systems

Cisco IPC Express System Configuration Example

Part IV: Maintenance and Troubleshooting

Troubleshooting Basic Cisco IPC Express Features

Troubleshooting Advanced Cisco CME Features

Troubleshooting Cisco CME Network Integration

Troubleshooting Cisco UE System Features

Troubleshooting Cisco UE Automated Attendant

Troubleshooting Cisco UE Integrated Voice Mail Features

Part V: Appendixes

Appendix A. Cisco IPC Express Features, Releases, and Ordering Information

Appendix B. Sample Cisco UE AA Scripts

Appendix C. Cisco Unity Express Database Schema

Index

show all menu





Cisco IP Communications Express(c) CallManager Express with Cisco Unity Express
Cisco IP Communications Express: CallManager Express with Cisco Unity Express
ISBN: 158705180X
EAN: 2147483647
Year: 2006
Pages: 236
Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net