Case Study-Inter-AS Implementing Route-Reflector and BGP Confederation in Provider Networks

Figure 7-37 shows an Inter-AS network topology in which SP1 and SP2 are providing MPLS VPN services to geographically dispersed Customer A and Customer B sites.

Figure 7-37. Inter-AS Providers Implementing RR and BGP Confederation

Provider 1 uses the RR method to reduce iBGP mesh while Provider 2 uses BGP confederation to minimize the number of BGP sessions. ASBR2-AS1 in the provider network uses the Inter-AS redistribute connected option to distribute the next-hop to devices in Provider Network 1, while ASBR2-AS2 uses the Inter-AS next-hop-self method to distribute next-hop information to devices in Provider Network 2. Example 7-28 shows the ASBR, PE router, and RR configurations. Refer to Example 7-3 and Example 7-4 for CE configurations.

Example 7-28. ASBR and RR Configurations

hostname ASBR2-AS1

!

ip cef

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.10.10.102 255.255.255.255

!

interface Ethernet0/0

 ip address 10.10.10.5 255.255.255.252

 mpls ip

!

interface Ethernet1/0

 ip address 10.10.10.10 255.255.255.252

 mpls ip

!

interface Serial2/0

 ip address 10.40.40.1 255.255.255.252

 mpls bgp forwarding

!

router ospf 1

 redistribute connected subnets route-map adv-conn

 network 10.10.10.0 0.0.0.255 area 0

!

router bgp 1

 no bgp default ipv4-unicast

 no bgp default route-target filter

 neighbor 10.10.10.100 remote-as 1

 neighbor 10.10.10.100 update-source Loopback0

 neighbor 10.40.40.2 remote-as 2

 !

 address-family vpnv4

 neighbor 10.10.10.100 activate

 neighbor 10.10.10.100 send-community extended

 neighbor 10.40.40.2 activate

 neighbor 10.40.40.2 send-community extended

 exit-address-family

!

access-list 10 permit 10.40.40.2

!

route-map adv-conn permit 10

 match ip address 10

__________________________________________________________________________

hostname ASBR2-AS2

!

ip cef

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.20.20.102 255.255.255.255

!

interface Ethernet0/0

 ip address 10.20.20.5 255.255.255.252

 mpls ip

!

interface Ethernet1/0

 ip address 10.20.20.10 255.255.255.252

 mpls ip

!

interface Serial2/0

 ip address 10.40.40.2 255.255.255.252

 mpls bgp forwarding

!

router ospf 2

 network 10.20.20.0 0.0.0.255 area 0

!

router bgp 102

 no bgp default ipv4-unicast

 no bgp default route-target filter

 bgp confederation identifier 2

 bgp confederation peers 100 101

 neighbor 10.20.20.100 remote-as 100

 neighbor 10.20.20.100 ebgp-multihop 2

 neighbor 10.20.20.100 update-source Loopback0

 neighbor 10.20.20.101 remote-as 101

 neighbor 10.20.20.101 ebgp-multihop 2

 neighbor 10.20.20.101 update-source Loopback0

 neighbor 10.40.40.1 remote-as 1

 !

 address-family vpnv4

 neighbor 10.20.20.100 activate

 neighbor 10.20.20.100 send-community extended

 neighbor 10.20.20.100 next-hop-self

 neighbor 10.20.20.101 activate

 neighbor 10.20.20.101 send-community extended

 neighbor 10.20.20.101 next-hop-self

 neighbor 10.40.40.1 activate

 neighbor 10.40.40.1 send-community extended

 exit-address-family

__________________________________________________________________________

hostname PE1-AS1

!

ip cef

!

ip vrf Cust_A

 rd 1:100

 route-target export 1:100

 route-target import 2:100

!

ip vrf Cust_B

 rd 1:101

 route-target export 1:101

route-target import 2:101

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.10.10.101 255.255.255.255

!

interface Ethernet0/0

 ip address 10.10.10.1 255.255.255.252

 mpls ip

!

interface Ethernet1/0

 ip address 10.10.10.9 255.255.255.252

 mpls ip

!

interface Serial2/0

 description connected to Cust_A CE1-A

 ip vrf forwarding Cust_A

 ip address 172.16.1.1 255.255.255.252

!

interface Serial3/0

 description connected to Cust_B CE1-B

 ip vrf forwarding Cust_B

 ip address 192.168.1.1 255.255.255.252

!

router ospf 1

 network 10.10.10.0 0.0.0.255 area 0

!

router bgp 1

 no bgp default ipv4-unicast

 neighbor 10.10.10.100 remote-as 1

 neighbor 10.10.10.100 update-source Loopback0

 !

 address-family vpnv4

 neighbor 10.10.10.100 activate

 neighbor 10.10.10.100 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf Cust_B

 neighbor 192.168.1.2 remote-as 65001

 neighbor 192.168.1.2 activate

 neighbor 192.168.1.2 as-override

 no auto-summary

 no synchronization

 exit-address-family

 !

 address-family ipv4 vrf Cust_A

 neighbor 172.16.1.2 remote-as 65001

 neighbor 172.16.1.2 activate

 no auto-summary

 no synchronization

 exit-address-family

__________________________________________________________________________

hostname PE1-AS2

!

ip cef

!

ip vrf Cust_A

 rd 2:100

 route-target export 2:100

 route-target import 1:100

!

ip vrf Cust_B

 rd 2:101

 route-target export 2:101

 route-target import 1:101

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.20.20.101 255.255.255.255

!

interface Ethernet0/0

 ip address 10.20.20.1 255.255.255.252

 mpls ip

!

interface Ethernet1/0

 ip address 10.20.20.9 255.255.255.252

 mpls ip

!

interface Serial2/0

 description connected to Cust_A CE2-A

 ip vrf forwarding Cust_A

 ip address 172.16.2.1 255.255.255.252

!

interface Serial3/0

 description connected to Cust_B CE2-B

 ip vrf forwarding Cust_B

 ip address 192.168.2.1 255.255.255.252

!

router ospf 2

 network 10.20.20.0 0.0.0.255 area 0

!

router bgp 101

 no bgp default ipv4-unicast

 bgp confederation identifier 2

 bgp confederation peers 100 102

 neighbor 10.20.20.100 remote-as 100

 neighbor 10.20.20.100 ebgp-multihop 2

 neighbor 10.20.20.100 update-source Loopback0

 neighbor 10.20.20.102 remote-as 102

 neighbor 10.20.20.102 ebgp-multihop 2

 neighbor 10.20.20.102 update-source Loopback0

 !

 address-family vpnv4

 neighbor 10.20.20.100 activate

 neighbor 10.20.20.100 send-community extended

 neighbor 10.20.20.100 next-hop-self

 neighbor 10.20.20.102 activate

 neighbor 10.20.20.102 send-community extended

 neighbor 10.20.20.102 next-hop-self

 exit-address-family

 !

 address-family ipv4 vrf Cust_B

 neighbor 192.168.2.2 remote-as 65001

 neighbor 192.168.2.2 activate

 neighbor 192.168.2.2 as-override

 no auto-summary

 no synchronization

 exit-address-family

 !

 address-family ipv4 vrf Cust_A

 neighbor 172.16.2.2 remote-as 65002

 neighbor 172.16.2.2 activate

 no auto-summary

 no synchronization

 exit-address-family

_________________________________________________________________________

hostname P1-AS1-RR

!

ip cef

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.10.10.100 255.255.255.255

!

interface Ethernet0/0

 ip address 10.10.10.2 255.255.255.252

 mpls ip

!

interface Ethernet1/0

 ip address 10.10.10.6 255.255.255.252

 mpls ip

!

router ospf 1

 network 10.10.10.0 0.0.0.255 area 0

!

router bgp 1

 no bgp default ipv4-unicast

 neighbor 10.10.10.101 remote-as 1

 neighbor 10.10.10.101 update-source Loopback0

 neighbor 10.10.10.102 remote-as 1

 !

 address-family vpnv4

 neighbor 10.10.10.101 activate

 neighbor 10.10.10.101 send-community extended

 neighbor 10.10.10.101 route-reflector-client

 neighbor 10.10.10.101 next-hop-self

 neighbor 10.10.10.102 activate

 neighbor 10.10.10.102 send-community extended

 neighbor 10.10.10.102 route-reflector-client

 neighbor 10.10.10.102 next-hop-self

 exit-address-family

__________________________________________________________________________

hostname P1-AS2

!

ip cef

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.20.20.100 255.255.255.255

!

interface Ethernet0/0

 ip address 10.20.20.2 255.255.255.252

 mpls ip

!

interface Ethernet1/0

 ip address 10.20.20.6 255.255.255.252

 mpls ip

!

router ospf 2

 network 10.20.20.0 0.0.0.255 area 0

!

router bgp 100

 no bgp default ipv4-unicast

 bgp confederation identifier 2

 bgp confederation peers 101 102

 neighbor 10.20.20.101 remote-as 101

 neighbor 10.20.20.101 ebgp-multihop 2

 neighbor 10.20.20.101 update-source Loopback0

 neighbor 10.20.20.102 remote-as 102

 neighbor 10.20.20.102 ebgp-multihop 2

 neighbor 10.20.20.102 update-source Loopback0

 !

 address-family vpnv4

 neighbor 10.20.20.101 activate

 neighbor 10.20.20.101 send-community extended

 neighbor 10.20.20.101 next-hop-self

 neighbor 10.20.20.102 activate

 neighbor 10.20.20.102 send-community extended

 neighbor 10.20.20.102 next-hop-self

 exit-address-family

Example 7-29 shows that CE1-A and CE1-B see local and remote routes for VPN-A and VPN-B networks.

Example 7-29. Verifying End-to-End Connectivity

CE1-A#show ip bgp



 Network Next Hop Metric LocPrf Weight Path

*> 172.16.10.0/24 0.0.0.0 0 32768 i

*> 172.16.20.0/24 172.16.1.1 0 1 2 65002 i

__________________________________________________________________________

CE1-B#show ip bgp



 Network Next Hop Metric LocPrf Weight Path

*> 192.168.10.0 0.0.0.0 0 32768 i

*> 192.168.20.0 192.168.1.1 0 1 2 1 i

Example 7-30 shows the result of the ping operation.

Example 7-30. Verify End-to-End Connectivity

CE1-A#ping 172.16.20.1 source 172.16.10.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.10.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms

__________________________________________________________________________

CE1-B#ping 192.168.20.1 source 192.168.10.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:

Packet sent with a source address of 192.168.10.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/64 ms


MPLS Overview

Basic MPLS Configuration

Basic MPLS VPN Overview and Configuration

PE-CE Routing Protocol-Static and RIP

PE-CE Routing Protocol-OSPF and EIGRP

Implementing BGP in MPLS VPNs

Inter-Provider VPNs

Carrier Supporting Carriers

MPLS Traffic Engineering

Implementing VPNs with Layer 2 Tunneling Protocol Version 3

Any Transport over MPLS (AToM)

Virtual Private LAN Service (VPLS)

Implementing Quality of Service in MPLS Networks

MPLS Features and Case Studies

show all menu



MPLS Configuration on Cisco IOS Software
MPLS Configuration on Cisco IOS Software
ISBN: 1587051990
EAN: 2147483647
Year: 2006
Pages: 130
Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net