Hierarchical VPLS-Distributed PE Architecture

Command Reference



Router(config)#l2 vfi vfi-name manual

Enables the L2 VFI manual configuration mode.

Router(config-vfi)#vpn id oui:vpn-index

Configures a VPN ID for a VPLS domain. The emulated VCs bound to this L2 VRF use this VPN ID for signaling.

Router(config-vfi)#neighbor remote-router-id encapsulation mpls

Specifies the remote peering router ID and the tunnel encapsulation type or the pseudo-wire property to be used to set up the emulated VC.

Router(config-vfi)#xconnect vfi vfi name

Specifies the L2 VFI that you are binding.


Disconnects all emulated VCs previously established under the L2VFI and prevents the establishment of new attachment circuits.

Router(config)#mpls label protocol {ldp | tdp}

Specifies the default label distribution protocol for a platform.

Router(config)#mpls ldp logging neighbor-changes (optional)

Determines logging neighbor changes.

Router(config)#mpls ldp discovery {hello | targeted-hello} {holdtime | interval} seconds

Configures the interval between transmission of LDP (TDP) discovery hello messages or the hold time for a LDP transport connection.

Router(config)#mpls ldp router-id loopback0 force

Assigns the loopback as the source of TDP/LDP messages.

Router(config)#mpls ip

Enables label switching of IPv4 packets on an interface.

Router(config-if)#mls qos trust [cos | dscp | ip-precedence]

Sets the trusted state of an interface to specify that the ToS bits in the incoming packets contain a DSCP value.


Modifies the switching characteristics of the Layer 2-switched interface.

Router(config-if)#switchport trunk encapsulation dot1q

Sets the switch port encapsulation format to 802.1Q. Modifies the switching characteristics of the Layer 2-switched interface.

Router(config-if)#switchport mode trunk switchport trunk allowed vlan

Sets the interface to a trunking VLAN Layer 2 interface. Sets the list of allowed VLANs.

Router(config-if)#switchport access vlan vlan-id

Sets the VLAN when the interface is in access mode.

Router(config-if)#switchport mode [access| trunk| dot1q-tunnel]

Sets the interface as an 802.1Q tunnel port.

Router(config-if)#l2protocol-tunnel [cdp | stp | vtp]

Enables protocol tunneling on an interface.

MPLS Overview

Basic MPLS Configuration

Basic MPLS VPN Overview and Configuration

PE-CE Routing Protocol-Static and RIP

PE-CE Routing Protocol-OSPF and EIGRP

Implementing BGP in MPLS VPNs

Inter-Provider VPNs

Carrier Supporting Carriers

MPLS Traffic Engineering

Implementing VPNs with Layer 2 Tunneling Protocol Version 3

Any Transport over MPLS (AToM)

Virtual Private LAN Service (VPLS)

Implementing Quality of Service in MPLS Networks

MPLS Features and Case Studies

show all menu

MPLS Configuration on Cisco IOS Software
MPLS Configuration on Cisco IOS Software
ISBN: 1587051990
EAN: 2147483647
Year: 2006
Pages: 130
Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net