RIPv1 PE-CE Routing Configuration and Verification

Note

RIPv1 is not recommended for MPLS VPN networks and is demonstrated here only for learning purposes.

The topology to demonstrate RIPv1 PE-CE routing is shown in Figure 4-7.

Figure 4-7. Provider Implementing RIPv1 PE-CE Routing

CE1-A is running RIPv1 routing protocol. Because CE1-A is sending RIPv1 routes, the interface on PE1-AS1 connected to CE1-A is configured to receive and send RIPv1 routes. IP addressing for the CE networks adheres to classful addressing. RIPv2 PE-CE routing configuration is still used on PE2-AS1 because the MP-iBGP session between PE routers transports only RIPv2 routes. Example 4-26 shows the necessary steps to configure PE1-AS1 interface connected to CE1-A to send and receive RIPv1 routes.

Example 4-26. PE1-AS1 RIPv1 PE-CE Configuration

PE1-AS1(config)#interface FastEthernet0/0

PE1-AS1(config-if)# ip vrf forwarding VRF-RIP

PE1-AS1(config-if)# ip address 172.16.1.1 255.255.255.0

PE1-AS1(config-if)#ip rip send version 1

PE1-AS1(config-if)#ip rip receive version 1

PE1-AS1#show ip protocols vrf VRF-RIP

Routing Protocol is "rip"

 Sending updates every 30 seconds, next due in 5 seconds

 Invalid after 180 seconds, hold down 180, flushed after 240

 Outgoing update filter list for all interfaces is not set

 Incoming update filter list for all interfaces is not set

 Redistributing: rip, bgp 1

 Default version control: send version 2, receive version 2

 Interface Send Recv Triggered RIP Key-chain

 FastEthernet0/0 1 1

 Maximum path: 4

 Routing for Networks:

 172.16.0.0

 Routing Information Sources:

 Gateway Distance Last Update

 172.16.1.2 120 00:00:14

 Distance: (default is 120)

 

RIPv1 PE-CE Routing – PE1-AS1 and CE1-A Final Configuration

Configuration for PE2-AS1, P1-AS1, P2-AS2, and CE2-A remains the same as what was shown in the "RIPv2 PE-CE Routing – Provider Edge PE1-AS1 and PE2-AS1 Configuration" section. Example 4-27 shows the PE1-AS1 and CE1-A final configuration.

Example 4-27. CE1-A and PE1-AS1 Configuration – RIPv1 PE-CE

hostname CE1-A

!

ip cef

!

interface Loopback0

 ip address 172.16.10.1 255.255.255.0

!

interface FastEthernet0/0

 ip address 172.16.1.2 255.255.255.0

!

router rip

 network 172.16.0.0

 no auto-summary

__________________________________________________________________________

hostname PE1-AS1

!

ip cef

!

ip vrf VRF-RIP

 rd 1:100

 route-target export 1:100

 route-target import 1:100

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.10.10.101 255.255.255.255

!

interface FastEthernet0/0

 ip vrf forwarding VRF-RIP

 ip address 172.16.1.1 255.255.255.0

 ip rip send version 1

 ip rip receive version 1

!

interface ATM2/0

 no ip address

 no atm ilmi-keepalive

!

interface ATM2/0.1 mpls

 description Connection to A1

 ip address 10.10.10.1 255.255.255.252

 mpls label protocol ldp

 tag-switching ip

!

router ospf 1

network 10.0.0.0 0.255.255.255 area 0

!

router rip

 version 2

 !

 address-family ipv4 vrf VRF-RIP

 version 2 redistribute bgp 1 metric transparent

 network 172.16.0.0

 no auto-summary

 exit-address-family

!

router bgp 1

 no synchronization

 neighbor 10.10.10.102 remote-as 1

 neighbor 10.10.10.102 update-source Loopback0

 no auto-summary

 !

 address-family vpnv4

 neighbor 10.10.10.102 activate

 neighbor 10.10.10.102 send-community extended

 no auto-summary

 exit-address-family

 !

 address-family ipv4 vrf VRF-RIP

 redistribute rip

 no auto-summary

 no synchronization

 exit-address-family

 

Verification of RIPv1 PE-CE Routing

The steps to verify RIPv1 PE-CE routing are as follows:

Step 1.

Verify VRF routing table on PE1-AS1 and PE2-AS1 – Check the VRF routing table to see if routes to the CE networks are configured properly and remote routes from PE routers are received in the VRF.

Example 4-28 shows that PE1-AS1 has received routes from the PE2-AS1 router for the 172.16.20.0/24 network and has also received 172.16.10.0 network from CE1-A.
 

Example 4-28. Verification of VRF Routes on PE1-AS1 and PE2-AS1

PE1-AS1#show ip route vrf VRF-RIP



 172.16.0.0/24 is subnetted, 4 subnets

B 172.16.20.0 [200/1] via 10.10.10.102, 00:08:53

R 172.16.10.0 [120/1] via 172.16.1.2, 00:00:04, FastEthernet0/0

C 172.16.1.0 is directly connected, FastEthernet0/0

B 172.16.2.0 [200/0] via 10.10.10.102, 00:06:07

______________________________________________________________________

PE2-AS1#show ip route vrf VRF-RIP



 172.16.0.0/24 is subnetted, 4 subnets

R 172.16.20.0 [120/1] via 172.16.2.2, 00:00:12, Ethernet1/0

B 172.16.10.0 [200/1] via 10.10.10.101, 00:08:23

B 172.16.1.0 [200/0] via 10.10.10.101, 00:13:38

C 172.16.2.0 is directly connected, Ethernet1/0
 

Step 2.

Verify RIP routes on CE routers CE1-A and CE2-A – Check the BGP VPNv4 routing table to see if routes are received properly. Example 4-29 shows that PE1-AS1 and PE2-AS1 routers see the routes from 172.16.20.0/24 and 172.16.10.0/24 in their RIP routing table.
 

Example 4-29. Verify Routes on CE1-A and CE2-A

CE2-A#show ip route



 172.16.0.0/24 is subnetted, 4 subnets

C 172.16.20.0 is directly connected, Loopback0

R 172.16.10.0 [120/2] via 172.16.2.1, 00:00:04, Ethernet0/0

R 172.16.1.0 [120/1] via 172.16.2.1, 00:00:04, Ethernet0/0

C 172.16.2.0 is directly connected, Ethernet0/0

CE1-A#show ip route



 172.16.0.0/24 is subnetted, 4 subnets

R 172.16.20.0 [120/2] via 172.16.1.1, 00:00:21, FastEthernet0/0

C 172.16.10.0 is directly connected, Loopback0

C 172.16.1.0 is directly connected, FastEthernet0/0

R 172.16.2.0 [120/1] via 172.16.1.1, 00:00:21, FastEthernet0/0
 

Step 3.

Verify end-to-end connectivity using ping – Verify end-to-end connectivity between the CE1-A and CE2-A by issuing a ping from CE1-A to network 172.16.20.0/24 on CE2-A and vice versa. Example 4-30 shows that the ping has been successful.
 

Example 4-30. Verify Reachability via Ping

CE1-A#ping 172.16.20.1 source 172.16.10.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.10.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

_____________________________________________________________________

CE2-A#ping 172.16.10.1 source 172.16.20.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.20.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

MPLS Overview

Basic MPLS Configuration

Basic MPLS VPN Overview and Configuration

PE-CE Routing Protocol-Static and RIP

PE-CE Routing Protocol-OSPF and EIGRP

Implementing BGP in MPLS VPNs

Inter-Provider VPNs

Carrier Supporting Carriers

MPLS Traffic Engineering

Implementing VPNs with Layer 2 Tunneling Protocol Version 3

Any Transport over MPLS (AToM)

Virtual Private LAN Service (VPLS)

Implementing Quality of Service in MPLS Networks

MPLS Features and Case Studies



MPLS Configuration on Cisco IOS Software
MPLS Configuration on Cisco IOS Software
ISBN: 1587051990
EAN: 2147483647
Year: 2006
Pages: 130

Flylib.com © 2008-2020.
If you may any questions please contact us: flylib@qtcs.net