DSL

Digital Subscriber Line (DSL) has become one of the standard home and business broadband connection methods (the other method, cable, is described in the next section). To enable DSL you need to have a DSL connection to your home or office from an ISP that is servicing your area. This assumes, of course, that DSL is available in your area. Since DSL is distance restricted, if you are a certain distancewhich varies by the type of DSL service and the providerfrom the nearest telco switch, you can't get a DSL line. If you are outside the service area, check periodically with providers because the technology is improving and more areas are able to get DSL connections.

Most ISPs provide DSL modems has part of their service. If you happen to get a Cisco router, it's mostly likely going to have a built-in DSL modem such as an 800 series. Other options include the 1700, 2600, and 3600 series with an ADSL WIC card installed.

In our sample configurations, we use Network Address Translation (NAT) and Point-To-Point Protocol over Ethernet (PPPoE). Chapter 13 covers NAT configurations in great detail. I am including NAT here because it's such an important part of a DSL (or cable) Internet connection. Most DSL providers use PPPoE, which provides authentication, encryption, and compression. Running PPPoE on our router eliminates the need for running PPPoE on all our network clients. (For example, if you did not have a router and only had a PC and a DSL modem, you would have to run PPPoE software directly on the single PC.) By putting PPPoE on the router, the router handles all the authentication and networking to the ISP. Our local PCs require no extra software or network configuration, just basic networking configurations.

6.3.1. Configuring Our DSL Client Router

The configurations of a DSL connection differ depending on the router type and the way that your provider implements the connection. For example, some providers use bridging rather than a dialer method. In the example we are using, our provider has given us a PVC of 1/100. For more information on what a PVC is, see the ATM section earlier in this chapter.

To configure the router, we enable Virtual Private Dialup Network (VPDN) and configure the virtual dialer interface, and the ATM interface itself. VPDN configures the router so that PPPoE requires "dial-in" in order to connect. Why is PPPoE configured as dial-in? Because it's the same PPP protocol that's used for authentication in dial-up connections, in this case running over Ethernet (which is the "oE" in PPPoE). The virtual dialer interface handles the IP address of the connection, the PPP authentication, and outside NAT information. Configuring the ATM interface simply entails applying the PVC value given to you by your ISP.

!
hostname ournetworkrouter
!
! Enable VPDN
vpdn enable
no vpdn logging
!
! VPDN group pppoe requires "dialin". These commands configure
! a VPDN group called "pppoe" that is used to establish the PPPoE sesions
vpdn-group pppoe
 ! this command means that our router is the PPPoE client
 ! that is requesting to establish a PPPoE session
 request-dialin
 protocol pppoe
!
! Create a "virtual" interface that handles the "dialing" to the
! ISP's DSL line. This virtual interface is used on the ATM0 interface
interface Dialer1
 ip address negotiated
 ! if you have a static IP address, replace the negoatiated line above
 ! with the provided IP address.
 encapsulation ppp
 ! Adjust Mtu because 1492 + PPPoE headers = 1500
 ip mtu 1492
 ip nat outside
 dialer pool 1
 ppp authentication pap callin
 ! Our ISP gave us the username of bob1 and password of notsecure
 ppp pap sent-username bob1 password notsecure
!
interface FastEthernet0
 description Our local network interface
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
!
! Our ISP gave us a PVC of 1/100. Depending on your ISP,
! you might get a different PVC
interface ATM0
 description our DSL interface
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 1/100
 protocol pppoe
 ! Tie this interface to the virtual Dialer Interface
 pppoe-client dial-pool-number 1
!
! Configure NAT to use access-list 1 as the "source" traffic
! to perform NAT on
ip nat inside source list 1 interface Dialer1 overload
!
! Our default route is the virtual dialer interface
ip route 0.0.0.0 0.0.0.0 dialer1
!
! Used in the ip nat command
access-list 1 permit 10.10.1.0 0.0.0.255

If your ISP says to use CHAP for authentication, replace the PPP PAP commands with these:

 ppp authentication chap callin
 ppp chap hostname 
 ppp chap password 

 

6.3.2. Troubleshooting a DSL Connection

Troubleshooting DSL involves looking at several different things: the PPP layer (layer 4), the Ethernet layer (layer 3), the ATM layer (layer 2), and finally, the DSL physical layer (layer 1).

After checking your local Ethernet connections by pinging your local devices from your router and vice versa, you can begin looking at your PPP layer with debug vpdn pppoe-events.

If the PPPoE layer is being established, which you will be able to see from the debug output, try to look at the VPDN sessions with the show vpdn command:

# show vpdn session all

session id: 1
local MAC address: 0001.aacc.b57a, remote MAC address: 0001.bbed.abb0
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/100
 16499 packets sent, 203455 received, 163424 bytes sent, 2032934 received

In this output, we can see the packets sent and received, which shows that we are making a connection to our DSL link.

After we've verified that information, we check our local network. For example, is our local routing working? Is our default route set to the correct address? Are our network devices set with the correct default route (our router local interface IP)? Is NAT working correctly?

Getting Started

IOS Images and Configuration Files

Basic Router Configuration

Line Commands

Interface Commands

Networking Technologies

Access Lists

IP Routing Topics

Interior Routing Protocols

Border Gateway Protocol

Quality of Service

Dial-on-Demand Routing

Specialized Networking Topics

Switches and VLANs

Router Security

Troubleshooting and Logging

Quick Reference

Appendix A Network Basics

Index





Cisco IOS in a Nutshell
Cisco IOS in a Nutshell (In a Nutshell (OReilly))
ISBN: 0596008694
EAN: 2147483647
Year: 2006
Pages: 1031
Authors: James Boney
Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net