Serial Interfaces

Serial interfaces are interfaces that connect to a device like a CSU/DSU, which in turn connects to a leased line to complete a point-to-point connection.

5.8.1. Serial Encapsulation

The three primary encapsulation types for a serial interface are PPP, HDLC, and Frame Relay. Other encapsulation types include X.25, SMDS, and ATM DXI. To see which encapsulation is being used on a given interface, use the show interface command. Here are brief descriptions of the different encapsulation types:

 

PPP

Point-to-Point Protocol (PPP) encapsulation is specified in RFC 1331 and 1332 (and many others). Echo requests are used as keepalives; use no keepalives to disable this feature. PPP is popular and supported by all router vendors. If you are creating a serial link with two different types of routers, you will need to use PPP for the two routers to communicate.

 

HDLC

HDLC encapsulation provides synchronous frames and error detection without windowing or retransmission. HDLC is the default encapsulation method for a serial interface but is not supported by all vendors. If you build a serial link with a Cisco router at one end and another type of router at the other end, you might have to use PPP.

 

Frame Relay

In Frame Relay, your packets are handled by a switched network that provides virtual circuits between you and the sites with which you communicate. The switched network is largely invisible to you; it's managed by your Frame Relay provider. Note that Frame Relay really is an encapsulation type, not an interface type; there's no such thing as a "Frame Relay communications line." Frame Relay communication takes place over some other medium, typically a T1 line. See Chapter 6 for information on Frame Relay.

5.8.2. Serial T1 Connection

Here's a simple configuration for a T1 connection . PPP is used as the encapsulation method. The router at the other end of the connection would have the same configuration, differing only in its IP address.

interface Serial1
 description T1 to site xyz
 ip address 10.10.1.1 255.255.255.0
 encapsulation ppp

 

5.8.3. T1 Configuration on a 2524 with a CSU/DSU Card

Routers such as the 2524 allow CSU/DSU cards to be inserted into them. These cards eliminate the need for an external CSU/DSU. The service-module command is used for configuring these modules. In the following example, the service-module command specifies that we have purchased a full T1 from our provider and that we want to use all 24 of the T1's timeslots for this interface:

! configuration for a 2524 with a CSU/DSU card
interface Serial0
 description Alternet Link
 no ip address
 encapsulation frame-relay ietf
 bandwidth 1536
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 ip unnumbered Ethernet0
 ip access-group 127 in
 bandwidth 1536
 frame-relay interface-dlci 500 ietf

After configuring the service module, we specify Frame Relay encapsulation. We next configure a subinterface of serial0 for use as a Frame Relay connection. Chapter 6 covers Frame Relay configuration in more detail.

5.8.4. Channelized T1

Some routers have Multi-Channel Interface Processor (MIP) cards . These cards allow a single controller to handle more than one T1 connection by dividing the controller and a single T1 circuit into separate channels. Each of these channels supports a related serial interface. The next example shows a configuration in which a MIP card is in slot 2, port 1 of the router, which we divide into channel 1 and channel 2. We create the two channel groups by assigning some of the T1 connection's time slots to each group. (Note that not all of the time slots are used, which allows us to create more channel groups later if we want.) After that, we configure the serial interfaces for each of the channels at serial slot 2, port 1.

Notice the use of the colon after the serial command (serial 2/1:2). The number after the colon refers to the channel group number, not to be confused with a subinterface. (A subinterface is a period followed by a number, e.g., serial 1.1.)

! Configure Control Slot 2, Port 1
!
controller t1 2/1
 framing esf
 line code b8zs
 !
 ! Define the first channel group for this MIP card
 ! Use only 2 timeslots (1-2). Allow the speed to default to 56K
 channel-group 1 timeslots 1,2
 !
 ! Define the second channel group for this MIP card
 ! The default speed is 56K, but we want to set it to 64K
 channel-group 2 timeslots 5,7,12-15,20 speed 64
!
! Now configure the interface for channel group 1, which is serial 2/1:1
interface serial 2/1:1
 ip address 10.10.1.4 255.255.255.0
 encapsulation hdlc
!
! Now configure the interface for channel group 2, which is serial 2/1:2
interface serial 2/1:2
 ip address 10.10.2.4 255.255.255.0
 encapsulation hdlc


Getting Started

IOS Images and Configuration Files

Basic Router Configuration

Line Commands

Interface Commands

Networking Technologies

Access Lists

IP Routing Topics

Interior Routing Protocols

Border Gateway Protocol

Quality of Service

Dial-on-Demand Routing

Specialized Networking Topics

Switches and VLANs

Router Security

Troubleshooting and Logging

Quick Reference

Appendix A Network Basics

Index



Cisco IOS in a Nutshell
Cisco IOS in a Nutshell (In a Nutshell (OReilly))
ISBN: 0596008694
EAN: 2147483647
Year: 2006
Pages: 1031
Authors: James Boney

Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net