Cable

Cable is becoming an increasingly popular broadband medium. Its main limitation is that you are effectively sharing the network (on the other side of your router) with everyone in your neighborhood, which is normally unnoticeable because most ISPs place bandwidth restrictions on your cable modem. These restrictions keep one person in the neighborhood from using up all the bandwidth. However, if you ever notice that cable speeds seem to decline at about three in the afternoon and then pick back up later in the evening, it's not your imagination.

In this example, we are going to provide the same sort of scenario as we did with the DSL sections, which is a standard connection using NAT. The router provides some of the cable modem settings automatically during power-up. These commands, like cable-modem channel and cable-modem mac-timer, used to be available for user configuration. However, since IOS 12.1(2)T, these commands are strictly for DOCSIS use.[*] In other words, they appear in the IOS configuration but you are unable to change them because they are automatic settings that the router learns from your provider.

[*] The Data Over Cable Interface Specification is the standard for communication between routers and cable modems. It is designed to be self-configuring.

We enabled routing on this cable modem by issuing the command no cable-modem compliant bridge, which allows us to use routing instead of the default bridging.

! Our local network interface
interface ethernet0
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
!
! Our cable modem interface
interface cable-modem0
 ! Some older cable modems might report an actual IP address here
 ! instead of "negotiated"
 ip address negotiated
 ip nat outside
 ! ISP Provided settings.
 cable-modem downstream saved channel 555000000 42 1
 cable-modem mac-timer t2 80000
 ! Put our cable-modem into routing mode instead of bridging mode
 no cable-modem compliant bridge
!
! apply our nat access-list to the cable-modem0 interface
ip nat inside source list 1 interface cable-modem0 overload
!
ip routing
ip classless
!
! Default route
ip route 0.0.0.0 0.0.0.0 172.32.30.1
!
access-list 1 permit 10.10.1.0 0.0.0.255


Getting Started

IOS Images and Configuration Files

Basic Router Configuration

Line Commands

Interface Commands

Networking Technologies

Access Lists

IP Routing Topics

Interior Routing Protocols

Border Gateway Protocol

Quality of Service

Dial-on-Demand Routing

Specialized Networking Topics

Switches and VLANs

Router Security

Troubleshooting and Logging

Quick Reference

Appendix A Network Basics

Index



Cisco IOS in a Nutshell
Cisco IOS in a Nutshell (In a Nutshell (OReilly))
ISBN: 0596008694
EAN: 2147483647
Year: 2006
Pages: 1031
Authors: James Boney

Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net