Snapshot DDR

In all the previous dial-up examples, we used static routes to define the routing tables for dial-up connections. On small networks, static routes are easily managed, but on larger networks they can quickly get out of hand. However, running a routing protocol in the presence of DDR is a problem because normal routing protocols would keep DDR links up forever with their constant route updates. In some situations this might be acceptable, but it begs the question of why you're using DDR in the first place.

Snapshot routing was designed to allow the use of routing protocols across DDR connections without keeping the line active constantly. As the name implies, snapshot routing means that the routing protocols are allowed to take a "snapshot" of the network's state at specified intervals rather than sending and receiving constant updates. Therefore, dial-up links come up only at a configurable interval, which saves the headache of static route management and keeps the dial-up link's usage to a minimum. Snapshot routing is compatible with RIP (IP and IPX), EIGRP, IGRP, RTMP (AppleTalk), and RTP (Vines), all of which are distance-vector protocols.

Configuring a link for snapshot routing requires one end to be a snapshot server and the other end to be a snapshot client. In this example, Office 1 has the local network 10.10.0.0 and serves as the snapshot server; Office 2 has the local network 10.11.0.0 and is the snapshot client. There are two dialer maps at each site: one for the normal traffic (map this address to this phone number) and another for the snapshot routing protocol.

Here's the configuration for Office 1:

 hostname office1
 !
 interface ethernet0
 ip address 10.10.1.1 255.255.0.0
 !
 ! Set the ISDN switch type
 isdn switch-type basic-ni1
 !
 interface BRI0
 ! Don't need an IP address because we are using the dialer interface
 no ip address
 encapsulation ppp
 dialer rotary-group 0
 ! Our local SPIDs for our ISDN lines
 isdn spid1 014105551212111 5551212
 isdn spid2 014105551213111 5551213
 !
 ! Configure the dialer interface
 interface dialer 0
 ip unnumbered ethernet0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map snapshot 1 name office2 speed 56
 ! Map the IPs to the phone numbers at office2
 ! There are two maps, one for each ISDN channel
 ! Broadcast is required here because we are doing routing
 dialer map ip 10.11.1.1 name office2 speed 56 broadcast 14105551312
 dialer map ip 10.11.1.1 name office2 speed 56 broadcast 14105551313
 dialer-group 1
 ! Enable snapshot server, updates every 30 minutes
 snapshot-server 30
 ! Disable CDP for this interface
 no cdp enable
 ! PPP CHAP authentication
 ppp authentication chap
 ! Enable multilink for the PPP (2 channels)
 ppp multilink
 !
 username office1 password letmein
 !
 dialer-list 1 protocol ip permit
 !
 ! Enable RIP
 router rip
 network 10.0.0.0
 version 2
 no validate-update source

Here's the configuration for Office 2:

 hostname office2
 !
 interface ethernet0
 ip address 10.11.1.1 255.255.0.0
 !
 ! Set the ISDN switch type
 isdn switch-type basic-ni1
 !
 interface BRI0
 ! Don't need an IP address because we are using the dialer interface
 no ip address
 encapsulation ppp
 dialer rotary-group 0
 ! Our local SPIDs for our ISDN lines
 isdn spid1 014105551312111 5551312
 isdn spid2 014105551313111 5551313
 !
 ! Configure the dialer interface
 interface dialer 0
 ip unnumbered ethernet0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map snapshot 1 name office1 speed 56
 ! Map the IPs to the phone numbers at office1
 ! Broadcast is required here because we are doing routing
 dialer map ip 10.10.1.1 name office1 speed 56 broadcast 14105551212
 dialer map ip 10.10.1.1 name office1 speed 56 broadcast 14105551213
 dialer-group 1
 ! Enable snapshot client, updates every 30 minutes
 snapshot client 30 600 suppress-statechange-update dialer
 ! Disable CDP for this interface
 no cdp enable
 ! PPP CHAP authentication
 ppp authentication chap
 ! Enable multilink for the PPP (2 channels)
 ppp multilink
 !
 username office2 password letmein
 !
 dialer-list 1 protocol ip permit
 !
 ! Enable RIP
 router rip
 network 10.0.0.0
 version 2

In this configuration, Office 2 is the snapshot client. Office 2 can exchange routing information whenever the BRI interfaces come up. If the snapshot timeout expires (the timeout is set to 30 minutes), the router is allowed to bring the BRI interface up to exchange routing information even if there is no "interesting" traffic.

12.5.1. Useful show Commands

Here are some show commands that are useful for monitoring DDR on your router.

12.5.1.1. show dialer

This command can be very verbose. It provides detailed information about all your DDR interfaces; to limit the output, you can specify the name of a particular dialer interface.

 Router1#show dialer
 Dialer0 - dialer type = DIALER PROFILE
 Idle timer (120 secs), Fast idle timer (20 secs)
 Wait for carrier (30 secs), Re-enable (15 secs)
 Dialer state is data link layer up

 Dial String Successes Failures Last called Last status
 5552323 0 1 00:00:33 failed

 BRI0 - dialer type = ISDN

 Dial String Successes Failures Last called Last status
 0 incoming call(s) have been screened.
 0 incoming call(s) rejected for callback.

 BRI0:1 - dialer type = ISDN
 Idle timer (180 secs), Fast idle timer (20 secs)
 Wait for carrier (30 secs), Re-enable (15 secs)
 Dialer state is data link layer up
 Dial reason: ip (s=192.168.1.1, d=10.1.1.2)
 Interface bound to profile Dialer0
 Time until disconnect 148 secs
 Current call connected 00:00:33
 Connected to 5552323 (Router2)

 BRI0:2 - dialer type = ISDN
 Idle timer (120 secs), Fast idle timer (20 secs)
 Wait for carrier (30 secs), Re-enable (15 secs)
 Dialer state is idle

The output shows that this router has a Dialer0 interface and a BRI0 interface. Table 12-2 describes a few of the more confusing fields in this output.

Table 12-2. Description for values from show dialer

Field

Meaning

Timers (Idle/Fast idle/Wait/Re-enable)

The time, in seconds, for each of the timers. If you don't set any timers in the configuration, these fields reflect the default values.

Dial string

The dial string (essentially, the phone number) of any logged calls.

Successes/Failures/Last called/Last status

The number of successful calls; the number of failed calls; the time of the last call; the status of the last call.

Screened/Rejected

The number of incoming calls that have been screened, and the number of calls that have been rejected by the screening process. A dialer profile can be set up to screen incoming calls and handle them in different ways. The most typical way to handle a screened call is to use caller ID callback. If the callback fails, the call is rejected.

Dialer state

data link layer up means that the call connected properly. Any other message means there is a problem with the call.

Dial reason

The source (S) and destination (D) IP addresses for the packet that caused the link to come up.

 

12.5.1.2. show dialer map

This command lists all the dialer maps that are defined:

 Router1#show dialer map
 Static dialer map ip 10.1.1.1 name office2 on Dialer1
 Static dialer map ip 10.1.1.2 name office3 on Dialer1

 

12.5.1.3. show isdn active

This command is limited to ISDN interfaces. It provides some valuable information about active ISDN calls:

 Router1#show isdn active
 ----------------------------------------------------------------------------
 ISDN ACTIVE CALLS
 ----------------------------------------------------------------------------
 History table has a maximum of 100 entries.
 History table data is retained for a maximum of 15 Minutes.
 ----------------------------------------------------------------------------
 Call Calling or Called Remote Seconds Seconds Seconds Recorded Charges
 Type Phone number Node Name Used Left Idle Units/Currency
 ----------------------------------------------------------------------------
 Out 5552323 Router2 88 105 5 0
 ----------------------------------------------------------------------------

 

12.5.1.4. show snapshot

This command displays information about snapshot routing:

 Router#show snapshot bri0

 Bri0 is up, line protocol is up, snapshot up
 Options: dialer support
 Length of each activation period: 3 minutes
 Period between activations: 30 minutes
 Retry period on connect failure: 5
 For dialer address 0
 Current queue: active, remaining active time: 1 minutes
 Updates received this cycle: ip
 For dialer address 1
 Current queue: client quiet, time until next activation: 27 minutes

Everything in this output should be straightforward except for the dialer address. The dialer address number refers to the rotary group number. Therefore, in this example, we're seeing snapshot information for rotary groups 0 and 1.

Getting Started

IOS Images and Configuration Files

Basic Router Configuration

Line Commands

Interface Commands

Networking Technologies

Access Lists

IP Routing Topics

Interior Routing Protocols

Border Gateway Protocol

Quality of Service

Dial-on-Demand Routing

Specialized Networking Topics

Switches and VLANs

Router Security

Troubleshooting and Logging

Quick Reference

Appendix A Network Basics

Index



Cisco IOS in a Nutshell
Cisco IOS in a Nutshell (In a Nutshell (OReilly))
ISBN: 0596008694
EAN: 2147483647
Year: 2006
Pages: 1031
Authors: James Boney

Flylib.com © 2008-2020.
If you may any questions please contact us: flylib@qtcs.net