Ethernet, Fast Ethernet, and Gigabit Ethernet Interfaces

Give an Ethernet, Fast Ethernet, or Gigabit Ethernet interface an IP address, and it's ready to go. It's a good idea to give the interface a description, but that's not required. Also, as with all interfaces, don't forget the no shutdown command. For Fast Ethernet interfaces , you can also specify the interface speed and whether it's operating at full or half duplex:

interface Ethernet0
 description Internal Office Network
 ip address 10.10.1.1 255.255.255.248
 no shutdown
!
interface FastEthernet1
 description Fast Network for fileservers
 ip address 10.10.1.17 255.255.255.248
 ! Set the speed to 100 (which is the default)
 speed 100
 ! Set the duplex to full
 duplex full
 no shutdown
!
interface gigabitethernet 0/0
 description our new gigabit ethernet network
 ip address 10.10.5.1 255.255.255.0
 duplex full
 no shutdown


Getting Started

IOS Images and Configuration Files

Basic Router Configuration

Line Commands

Interface Commands

Networking Technologies

Access Lists

IP Routing Topics

Interior Routing Protocols

Border Gateway Protocol

Quality of Service

Dial-on-Demand Routing

Specialized Networking Topics

Switches and VLANs

Router Security

Troubleshooting and Logging

Quick Reference

Appendix A Network Basics

Index

show all menu





Cisco IOS in a Nutshell
Cisco IOS in a Nutshell (In a Nutshell (OReilly))
ISBN: 0596008694
EAN: 2147483647
Year: 2006
Pages: 1031
Authors: James Boney
Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net