ISDN Interfaces

ISDN is a standard for sending digital data over telephone lines. An ISDN link can carry two different kinds of information: the data itself, and control information for the ISDN circuit. Data channels are called B ("bearer") channels and carry either 56 or 64 kilobits/second; the control channels are called D ("data") channels.

ISDN is packaged in two different ways. BRI (Basic Rate Interface) is commonly used over residential phone lines. It provides two B channels plus a D channel, for a maximum B-channel capacity of 128 kbps. PRI (Primary Rate Interface) is more like a T1 connectionin fact, it's really just a repackaged T1 connection. PRI provides 23 B channels and 1 D channel, with a maximum rate of 1.544 Mbps in the U.S. In Europe, on E1 lines you get 30 B channels, for 2.048 Mbps.

BRI is a reasonably common technology for providing home or small-office connectivity. Although it's being displaced by technologies like ADSL and cable modems, there are many places where those technologies are unavailable. ISDN reaches almost anywhere. Let's look briefly at what you need to understand to configure a BRI connection:

  • Because ISDN connections are dial-up connections, they rely on DDR (dial-on-demand routing) . DDR is discussed in Chapter 12, but we'll look at a simple example in this section.
  • It shouldn't be a surprise that PPP is almost always used as an encapsulation protocol for ISDN links . HDLC is also possible, but it's supported only by Cisco equipment. Using PPP guarantees compatibility with other vendors. We will use PPP in all our examples.
  • An ISDN configuration requires you to know the type of switch in the telephone office at the other end of your phone line. Table 5-3 shows some basic switch types, but you should consult with your provider about which ISDN switch type it is using.

    Table 5-3. Some possible ISDN switch types

    Keyword

    Switch type

    basic-5ess

    AT&T 5ess BRI

    basic-dms-100

    Nortel BRI

    basic-ni

    National BRI

    primary-ni

    AT&T National PRI

    primary-5ess

    AT&T 5ess PRI

     

    If you change the switch type, reboot the router to be sure that the new switch type is used.

  • With most ISDN connections, you receive some number of Service Profile Identifiers (SPIDs), which are essentially phone numbers with a few extra digits. One SPID is assigned to each B channel. Therefore, you normally receive two SPIDs for a BRI line. There are some exceptions: for some AT&T point-to-point services you receive only one SPID, and with some 5ESS connections you don't always need a SPID (this is especially true for connections outside the U.S.). With PRI connections, you never receive a SPID.
  • Finally, you can configure an ISDN connection to use one B channel, both B channels, or as many channels as are needed given the bandwidth requirements. The latter option is a good way to reduce the cost of your ISDN link, since most carriers charge on a per-minute basis. However, this type of configuration relies on more advanced methods of dial-on-demand routing. (See Chapter 12 for more information.) In this chapter, we'll stick with a single B channel. You can also configure the B channels to carry 56 kbps or 64 kbps.

5.7.1. A Simple ISDN Configuration

Following are configurations for two routers connected by a dial-up ISDN connection. The connection is activated only on demand; Router 1 dials Router 2 when it has traffic for Router 2's networks, and vice versa. The local network for Router 1 is 192.168.9.0; the local network for Router 2 is 192.168.10.0. The subnet 10.10.1.0 is used for the connection between the two routers. This example uses only one B channel for the ISDN connection, so only one SPID is used for each router.

The configuration for Router 1 looks like this:

hostname router1
!
! Define the switch type for the ISDN provider
isdn switch-type basic-dms100
!
! Set up the user for the CHAP authentication
! The username is the hostname of the remote system and MUST match exactly
! Passwords must also be the same on both ends of the connection
username router2 password letmein
!
! Configure the ISDN line (interface bri0)
interface BRI0
 ip address 10.10.1.10 255.255.255.0
 encapsulation ppp
 ! Configure the bandwidth for routing metric caluclations
 bandwidth 56
 ! Set the Dialer commands
 ! Define the map for the remote site
 dialer map ip 10.10.1.11 name router2 speed 56 broadcast 14105551234
 dialer hold-queue 5
 dialer load-threshold 100
 dialer-group 1
 dialer idle-timeout 300
 !
 ! SPID numbers are provided by your ISDN service provider
 isdn spid1 505555123401 5554321
 !
 ! PPP should authenticate with the CHAP protocol
 ppp authentication chap
 !
 ! Since we used a dialer group of 1 in the BRI configuration,
 ! we need to define the access list (see Chapter 7) to specify
 ! what traffic should cause our ISDN line to activate
 dialer-list 1 list 101
!
! Our access list 101 is going to deny BROADC* TRAFFIC
! (Not actually deny, but makes broadcast traffic "uninteresting")
! Everything else is permitted
access-list 101 deny ip any 255.255.255.255 0.0.0.0
access-list 101 permit ip any any
!
! Important! Create a static route to the other side of the ISDN link.
ip route 192.168.10.0 255.255.255.0 10.10.1.11

Here is the configuration for Router 2. It's similar to Router 1, but without the comments.

hostname router2
!
isdn switch-type basic-dms100
!
username router1 password letmein
!
interface BRI0
 ip address 10.10.1.11 255.255.255.0
 encapsulation ppp
 bandwidth 56
 dialer map ip 10.10.1.10 name router1 speed 56 broadcast 15055551234
 dialer hold-queue 5
 dialer load-threshold 100
 dialer-group 1
 dialer idle-timeout 300
 !
 isdn spid1 410555123401 5551234
 !
 ppp authentication chap
 !
 dialer-list 1 list 101
!
access-list 101 deny ip any 255.255.255.255 0.0.0.0
access-list 101 permit ip any any
!
ip route 192.168.9.0 255.255.255.0 10.10.1.10


Getting Started

IOS Images and Configuration Files

Basic Router Configuration

Line Commands

Interface Commands

Networking Technologies

Access Lists

IP Routing Topics

Interior Routing Protocols

Border Gateway Protocol

Quality of Service

Dial-on-Demand Routing

Specialized Networking Topics

Switches and VLANs

Router Security

Troubleshooting and Logging

Quick Reference

Appendix A Network Basics

Index



Cisco IOS in a Nutshell
Cisco IOS in a Nutshell (In a Nutshell (OReilly))
ISBN: 0596008694
EAN: 2147483647
Year: 2006
Pages: 1031
Authors: James Boney

Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net