.NODE

Using an Async Modem on the AUX Port

Problem

You want to connect a standard asynchronous modem to the router's AUX port and use it for dial backup.

Solution

Many Cisco routers include an AUX port that is a low-speed asynchronous serial interface that can connect to a standard modem and support PPP:

Router1#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)#interface Async65
Router2(config-if)#encapsulation ppp
Router2(config-if)#dialer in-band
Router2(config-if)#dialer pool-member 1
Router2(config-if)#ppp authentication chap
Router2(config-if)#async default routing
Router2(config-if)#exit
Router2(config)#interface Dialer1
Router2(config-if)#ip address 10.1.99.56 255.255.255.0
Router2(config-if)#encapsulation ppp
Router2(config-if)#dialer remote-name dialhost
Router2(config-if)#dialer pool 1
Router2(config-if)#dialer idle-timeout 300
Router2(config-if)#dialer string 95551212
Router2(config-if)#dialer-group 1
Router2(config-if)#ppp authentication chap
Router2(config-if)#exit
Router2(config)#line aux 0
Router2(config-line)#modem inout
Router2(config-line)#transport input all
Router2(config-line)#no exec
Router2(config-line)#speed 115200
Router2(config-line)#exit
Router2(config)#username dialhost password dialpassword
Router2(config)#ip route 0.0.0.0 0.0.0.0 10.1.99.1 180
Router2(config)#dialer-list 1 protocol ip list 101
Router2(config)#access-list 101 deny eigrp any any
Router2(config)#access-list 101 permit ip any any
Router2(config)#router eigrp 55
Router2(config-router)#network 10.0.0.0
Router2(config-router)#exit
Router2(config)#end
Router2#

 

Discussion

Much of this configuration is similar to the ISDN configuration shown in Recipe 13.2. It uses a dialer interface in exactly the same way. But here, because there is only one async modem in this example, we can't benefit from PPP multilink.

The first part of this configuration example sets up the AUX port to run PPP and associates it with a dialer pool:

Router2(config)#interface Async65
Router2(config-if)#encapsulation ppp
Router2(config-if)#dialer in-band
Router2(config-if)#dialer pool-member 1
Router2(config-if)#ppp authentication chap
Router2(config-if)#async default routing

The only thing here that hasn't appeared in a previous example is the async default routing command. This command allows the async interface to support a routing protocol such as EIGRP. By default, routing protocols are disabled on async interfaces, so you need to enable it.

The number of this particular interface, Async65, wasn't selected at random. The router automatically assigns a line number to every interface that can be used for terminal access (including VTY lines, AUX lines, and Console lines), and it varies from router to router, depending on the hardware configuration. So we used the show line command to see which line number corresponded to the AUX port on this router:

Router1#show line
 Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
 0 CTY - - - - - 0 0 0/0 -
 65 AUX 9600/9600 - - - - - 0 0 0/0 -
* 66 VTY - - - - - 10 0 0/0 -
* 67 VTY - - - - - 19 0 0/0 -
 68 VTY - - - - - 3 0 0/0 -
 69 VTY - - - - - 0 0 0/0 -
 70 VTY - - - - - 0 0 0/0 -
 71 VTY - - - - - 0 0 0/0 -
 72 VTY - - - - - 0 0 0/0 -
 73 VTY - - - - - 0 0 0/0 -
 74 VTY - - - - - 0 0 0/0 -
 75 VTY - - - - - 0 0 0/0 -

Line(s) not in async mode -or- with no hardware support: 
1-64
 
Router1#

As you can see, the AUX port is on line 65 on this router. It's important to do this before you attempt any of the rest of the configuration, so you know what to configure.

When you use the AUX port for dial backup, you also need to configure the terminal line information for this physical port:

Router2(config)#line aux 0
Router2(config-line)#modem inout
Router2(config-line)#transport input none
Router2(config-line)#no exec
Router2(config-line)#speed 115200

The first command here is modem inout, which configures the router to allow access to the modem, as well as allowing the modem access to the router. Then we added the command transport input none. By default, the router will act as a terminal server and allow you to connect through protocols like telnet to the AUX port. In this case, though, we want the router to reserve this port for routed traffic, so we disable all remote terminal access to the interface.

The no exec command is extremely important when using async dial, and almost universally ignored in Cisco references. By default, the router will start an EXEC session on your AUX port. So if you plug a terminal into this port, you will get a login prompt. Unfortunately, your modem doesn't know what to do with a login prompt. At best, it will just ignore it, so disabling the EXEC session is simply good form. But, at worst, we have seen problems where the modem attempts to respond to the login prompt, the EXEC session interprets this as a bad login attempt, and puts up a new prompt, to which the modem again attempts to respond. The result can be high CPU utilization and, more importantly, this activity will prevent the router from dialing. We strongly recommend disabling the EXEC session on any async dial ports, as we have done here.

And the last command in this section sets the line speed. It's important to remember that this is the speed between the router and the modem. The actual dial session will have a much lower net speed, likely less than 56 Kbps. However, it's a good idea to make the line speed as fast as the modem can support. This will ensure that you get the best possible speed. Note that the default speed here is only 9.6 Kbps. So, if you don't increase this value, you will not be able to get the full advantage of the compression capabilities of modern modems.

See Also

Recipe 13.1; Recipe 13.2

Router Configuration and File Management

Router Management

User Access and Privilege Levels

TACACS+

IP Routing

RIP

EIGRP

OSPF

BGP

Frame Relay

Handling Queuing and Congestion

Tunnels and VPNs

Dial Backup

NTP and Time

DLSw

Router Interfaces and Media

Simple Network Management Protocol

Logging

Access-Lists

DHCP

NAT

First Hop Redundancy Protocols

IP Multicast

IP Mobility

IPv6

MPLS

Security

Appendix 1. External Software Packages

Appendix 2. IP Precedence, TOS, and DSCP Classifications

Index

show all menu





Cisco IOS Cookbook
Cisco IOS Cookbook (Cookbooks (OReilly))
ISBN: 0596527225
EAN: 2147483647
Year: 2004
Pages: 505
Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net