.NODE

Route Tagging

Problem

You want to tag specific routes to prevent routing loops while mutually redistributing routes between two routing protocols.

Solution

This example shows how to tag external routes in EIGRP:

Router1#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#ip route 0.0.0.0 0.0.0.0 172.25.1.1
Router1(config)#access-list 7 permit 0.0.0.0
Router1(config)#route-map TAGGING permit 10
Router1(config-route-map)#match ip address 7
Router1(config-route-map)#set tag 5
Router1(config-route-map)#exit
Router1(config)#router eigrp 55
Router1(config-router)#redistribute static route-map TAGGING
Router1(config-router)#exit
Router1(config)#end
Router1#

In this case, the external routes are static, but the same technique applies to routes learned through other routing protocols.

Discussion

You can only tag routes that EIGRP has learned from another routing protocol. As we saw when talking about route tags with RIP, EIGRP does not use these tags directly; it only distributes them. You would use these tags at network boundaries when redistributing routes into another routing process.

For instance, if our EIGRP network were being used as a transit network between two other routing protocols, we could tag routes learned from the first external network. We could then redistribute only the first network's routes into the second external network. Similarly, we could redistribute only the second network's routes into the first network. In this way, we could ensure that the external networks use only the EIGRP network for transit, and prevent them from reaching anything internal.

As we discussed in Chapter 6, RIP Version 2 supports 16-bit tags, which gives it a range from 0 to 65,535. EIGRP and OSPF use 32-bit tags for a range from 0 to 4,294,967,295. These tags are purely internal, of course, so there is no interoperability problem. It is unlikely that you will need 4 billion tags, but this expanded range can be useful because you can map the 32-bit tags to IP addresses as a mnemonic for the external network information:

Router1#show ip eigrp topology 0.0.0.0
IP-EIGRP (AS 55): Topology entry for 0.0.0.0/0
 State is Passive, Query origin flag is 1, 1 Successor(s), FD is 28160
 Routing Descriptor Blocks:
 0.0.0.0, from Rstatic, Send flag is 0x0
 Composite metric is (28160/0), Route is External
 Vector metric:
 Minimum bandwidth is 100000 Kbit
 Total delay is 100 microseconds
 Reliability is 255/255
 Load is 1/255
 Minimum MTU is 1500
 Hop count is 0
 External data:
 Originating router is 172.25.25.1 (this system)
 AS number of route is 0
 External protocol is Static, external metric is 0
 Administrator tag is 5 (0x00000005)
 Exterior flag is set
 0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0
 Composite metric is (28160/0), Route is Internal
 Vector metric:
 Minimum bandwidth is 100000 Kbit
 Total delay is 100 microseconds
 Reliability is 255/255
 Load is 1/255
 Minimum MTU is 1500
 Hop count is 0
 Exterior flag is set
Router1#

The following is a simple example in which we redistribute from EIGRP into OSPF only those routes that have a route tag value of 5. Presumably, this tag was set at another network boundary:

Router1#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#route-map TAGOUT permit 10
Router1(config-route-map)#match tag 5
Router1(config-route-map)#route-map TAGOUT deny 20
Router1(config-route-map)#exit
Router1(config)#router ospf 11
Router1(config-router)#redistribute eigrp 55 route-map TAGOUT 
Router1(config-router)#exit
Router1(config)#end
Router1#

 

See Also

Chapter 6

Router Configuration and File Management

Router Management

User Access and Privilege Levels

TACACS+

IP Routing

RIP

EIGRP

OSPF

BGP

Frame Relay

Handling Queuing and Congestion

Tunnels and VPNs

Dial Backup

NTP and Time

DLSw

Router Interfaces and Media

Simple Network Management Protocol

Logging

Access-Lists

DHCP

NAT

First Hop Redundancy Protocols

IP Multicast

IP Mobility

IPv6

MPLS

Security

Appendix 1. External Software Packages

Appendix 2. IP Precedence, TOS, and DSCP Classifications

Index

show all menu





Cisco IOS Cookbook
Cisco IOS Cookbook (Cookbooks (OReilly))
ISBN: 0596527225
EAN: 2147483647
Year: 2004
Pages: 505
Similar book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net