Frame-Mode MPLS Configuration and Verification

In frame mode, MPLS uses a 32-bit label that is inserted between the Layer 2 and Layer 3 headers. Layer 2 encapsulations like HDLC, PPP, Frame Relay, and Ethernet are frame-based except for ATM, which can operate either in frame mode or cell mode.

Basic Frame-Mode MPLS Overview, Configuration, and Verification

Figure 2-1 shows a frame-based MPLS provider network providing MPLS services to sites belonging to Customer A. The frame-based provider's network consists of routers R1, R2, R3, and R4. R1 and R4 function as Edge Label Switch Routers (LSRs) while R2 and R3 serve as LSRs.

Figure 2-1. Frame-Mode MPLS Provider Network

Figure 2-2 illustrates the configuration flowchart to implement frame-mode MPLS on the provider network shown in Figure 2-1. The configuration flowchart assumes that IP addresses are preconfigured where required.

Figure 2-2. Frame-Mode MPLS Configuration Flowchart

 

Basic Frame-Mode MPLS Configuration Steps

The steps to configure frame-mode MPLS are based on the configuration flowchart outlined in Figure 2-2. Ensure that IP addresses are configured prior to following these steps:

Step 1.

Enable CEF – CEF is an essential component for label switching and is responsible for imposition and disposition of labels in an MPLS network. Configure CEF globally on routers R1, R2, R3, and R4 by issuing the ip cef [distributed] command. Ensure that CEF is not disabled on the interface. If disabled, enable CEF on the interface by issuing ip route-cache cef in interface mode. Use the distributed keyword in the global configuration mode for Cisco platform capable of distributed CEF switching. Example 2-1 highlights the configuration to enable CEF on R2. Similarly enable CEF on R1, R3, and R4.
 

Example 2-1. Enable CEF

R2(config)#ip cef distributed

R2(config)#do show running-config interface s0/0 | include cef

 no ip route-cache cef

R2(config)#interface s0/0

R2(config-if)#ip route-cache cef
 

Step 2.

Configure IGP routing protocol – Configure the IGP routing protocol; in this case, OSPF. Enable the interfaces on R1, R2, R3, and R4 that are part of the provider network in OSPF using network ip-address wild-card-mask area area-id command under the OSPF routing process. Example 2-2 highlights the OSPF configuration on R2. Similarly configure OSPF on R1, R3, and R4.
 

Example 2-2. Configure IGP Routing Protocol on R2

R2(config)#router ospf 100

R2(config)#network 10.10.10.0 0.0.0.255 area 0

Enabling the label distribution protocol is an optional step. TDP is deprecated, and by default, LDP is the label distribution protocol. The command mpls label protocol {ldp | tdp} is configured only if LDP is not the default label distribution protocol or if you are reverting from LDP to TDP protocol or vice versa. The command can be configured in the global as well as in the interface configuration mode. The interface configuration command will, however, override the global configuration.
 

Step 3.

Assign LDP router ID – LDP uses the highest IP address on a loopback interface as the LDP router ID. If there is no loopback address defined, the highest IP address on the router becomes the LDP router ID. To force an interface to be an LDP router ID, mpls ldp router-id interface-type number command can be used. The loopback interface address is recommended because it always remains up. Configure the loopback 0 interface on the R2 router to be the LDP router ID as shown in Example 2-3. Repeat the configuration on R1, R3, and R4, assigning the local loopback interface as LDP router-id.
 

Example 2-3. Assign LDP Router ID

R2(config)#mpls ldp router-id loopback 0
 

Step 4.

Enable IPv4 MPLS or label forwarding on the interface – Example 2-4 demonstrates the step to enable MPLS forwarding on the interface.
 

Example 2-4. Enable MPLS Forwarding

R2(config)#interface serial 0/0

R2(config-if)#mpls ip

R2(config)#interface serial 0/1

R2(config-if)#mpls ip
 

Verification of Basic Frame-Mode MPLS Operation

The steps to verify the frame-mode MPLS operation are as follows. All verification steps were performed on Router R2. Outputs of the commands have been truncated for brevity, and only pertinent lines are depicted:

Step 1.

Example 2-5 verifies whether CEF is globally enabled or disabled on the router by issuing the show ip cef command. As shown in Example 2-5, CEF is disabled on R2. Example 2-5 shows if CEF is enabled on the router interfaces.
 

Example 2-5. CEF Verification

R2#show ip cef

%CEF not running

Prefix Next Hop Interface

_____________________________________________________________________

R2#show cef interface serial 0/0

Serial0/0 is up (if_number 5)

(Output truncated)

 IP CEF switching enabled

 IP CEF Fast switching turbo vector

(Output Truncated)

_____________________________________________________________________

R2#show cef interface serial 0/1

Serial0/1 is up (if_number 6)

(Output Truncated)

 IP CEF switching enabled

 IP CEF Fast switching turbo vector
 

Step 2.

Verify MPLS forwarding is enabled on the interfaces by issuing the show mpls interfaces command. Example 2-6 shows that MPLS is enabled on the serial interfaces. The IP column depicts Yes if IP label switching is enabled on the interface. The Tunnel column is Yes if LSP tunnel labeling (discussed later in Chapter 9, "MPLS Traffic Engineering") is enabled on the interface, and the Operational column is Yes if packets are labeled on the interface.
 

Example 2-6. MPLS Forwarding Verification

R2#show mpls interfaces

Interface IP Tunnel Operational

Serial0/0 Yes (ldp) No Yes

Serial0/1 Yes (ldp) No Yes
 

Step 3.

Verify the status of the Label Distribution Protocol (LDP) discovery process by issuing show mpls ldp discovery. This command displays neighbor discovery information for LDP and shows the interfaces over which the LDP discovery process is running. Example 2-7 shows that R2 has discovered two LDP neighbors, 10.10.10.101 (R1) and 10.10.10.103 (R3). The xmit/recv field indicates that the interface is transmitting and receiving LDP discovery Hello packets.
 

Example 2-7. LDP Discovery Verification

R2#show mpls ldp discovery

 Local LDP Identifier:

 10.10.10.102:0

 Discovery Sources:

 Interfaces:

 Serial0/0 (ldp): xmit/recv

 LDP Id: 10.10.10.101:0

 Serial0/1 (ldp): xmit/recv

 LDP Id: 10.10.10.103:0
 

Step 4.

Issue show mpls ldp neighbor to verify the status of the LDP neighbor sessions. Example 2-8 shows that the LDP session between R2 and R1 (10.10.10.101), as well as between R2 and R3 (10.10.10.103), is operational. Downstream indicates that the downstream method of label distribution is being used for this LDP session in which the LSR advertises all of its locally assigned (incoming) labels to its LDP peer (subject to any configured access list restrictions).
 

Example 2-8. LDP Neighbor Verification

R2#show mpls ldp neighbor

 Peer LDP Ident: 10.10.10.101:0; Local LDP Ident 10.10.10.102:0

 TCP connection: 10.10.10.101.646 - 10.10.10.102.11012

 State: Oper; PIEs sent/rcvd: 26611/26601; Downstream

 Up time: 2w2d

 LDP discovery sources:

 Serial0/0, Src IP addr: 10.10.10.1

 Addresses bound to peer LDP Ident:

 10.10.10.101 10.10.10.1

 Peer LDP Ident: 10.10.10.103:0; Local LDP Ident 10.10.10.102:0

 TCP connection: 10.10.10.103.11002 - 10.10.10.102.646

 State: Oper; Msgs sent/rcvd: 2374/2374; Downstream

 Up time: 1d10h

 LDP discovery sources:

 Serial0/1, Src IP addr: 10.10.10.6

 Addresses bound to peer LDP Ident:

 10.10.10.6 10.10.10.103 10.10.10.9
 

Control and Data Plane Forwarding in Basic Frame-Mode MPLS

Figure 2-3 shows the control and data plane forwarding operation in frame-mode MPLS.

Figure 2-3. Frame-Mode MPLS Control and Data Plane Operation

 

Control Plane Operation in Basic Frame-Mode MPLS

Figure 2-3 shows the control plane operation for prefix 10.10.10.101/32 from R1 to R4. The following steps are performed in the label propagation process for prefix 10.10.10.101/32:

Step 1.

Example 2-9 shows that R1 sends an implicit null or the POP label to R2. A value of 3 represents the implicit-null label. R1 propagates the implicit-null label to its penultimate Router R2, which performs the POP function in the data forwarding from R4 to 10.10.10.101/32. If R1 propagates an explicit-null label, the upstream LSR R2 does not POP the label but assigns a label value of 0 and sends a labeled packet to R2.
 

Example 2-9. MPLS Label Bindings on R1

R1#show mpls ldp bindings



 tib entry: 10.10.10.101/32, rev 4

 local binding: tag: imp-null

 remote binding: tsr: 10.10.10.102:0, tag: 16
 

Step 2.

Example 2-10 shows R2 assigning an LSP label 16 to 10.10.10.101/32. This label value is propagated to R3. This label value is imposed by R3 in the data forwarding path (for example, a packet originating from R4 to prefix 10.10.10.101/32 on R1).
 

Example 2-10. Label Allocation and Distribution Verification on R2

R2#show mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 10.10.10.101/32 0 Se0/0 point2point

17 Pop tag 10.10.10.8/30 0 Se1/0 point2point

18 Pop tag 10.10.10.103/32 0 Se1/0 point2point

19 19 10.10.10.104/32 0 Se1/0 point2point
 

Step 3.

Example 2-11 shows that on R3, prefix 10.10.10.101/32 has been assigned a local label of 17 and an outgoing label of 16. The outgoing label is received from the Router R2. The local label of 17 has been propagated during label distribution to Router R4. Label 17 is used by R4 in the data forwarding path for data destined to prefix 10.10.10.101/32 located on R1 from R4.
 

Example 2-11. Label Allocation and Distribution Verification on R3

R3#show mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 10.10.10.0/30 0 Se0/0 point2point

17 16 10.10.10.101/32 0 Se0/0 point2point

18 Pop tag 10.10.10.102/32 0 Se0/0 point2point

19 Pop tag 10.10.10.104/32 0 Se1/0 point2point
 

Data Forwarding Operation in Basic Frame-Mode MPLS

The following steps are performed in the data forwarding path from R4 to prefix 10.10.10.101/32:

1.

As shown in Figure 2-3, R4 imposes label 17 on the data packet originating from R4 destined to 10.10.10.101/32.
 

2.

R3 does an LFIB lookup and swaps label 17 for 16 and forwards that data packet to R2.
 

3.

R2 receives the data packet from R3, does a penultimate hop pop function, removes label 16, and forwards the data packet to R1.
 

Final Device Configurations for Basic Frame-Mode MPLS

The pertinent configurations for the devices in the frame-mode MPLS domain are shown in Examples 2-12 through Example 2-15.

Example 2-12. R1 Configuration

hostname R1

!

ip cef

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.10.10.101 255.255.255.255

!

interface Serial1/0

 description Connection to R2

 ip address 10.10.10.1 255.255.255.252

 mpls ip

!

router ospf 100

 network 10.10.10.0 0.0.0.255 area 0

 

Example 2-13. R2 Configuration

hostname R2

!

ip cef

!

mpls ldp router-id Loopback0

!

interface Loopback0

 ip address 10.10.10.102 255.255.255.255

!

interface Serial0/0

 description Connection to R1

 ip address 10.10.10.2 255.255.255.252

mpls label protocol ldp

mpls ip

!

interface Serial0/1

 description Connection to R3

 ip address 10.10.10.5 255.255.255.252

mpls label protocol ldp

mpls ip

!

router ospf 100

 network 10.10.10.0 0.0.0.255 area 0

 

Example 2-14. R3 Configuration

hostname R3

!

ip cef

!

mpls label protocol ldp

!

interface Loopback0

 ip address 10.10.10.103 255.255.255.255

!

interface Serial0/0

 description connection to R4

 ip address 10.10.10.9 255.255.255.252

 mpls ip

!

interface Serial0/1

 description connection to R2

 ip address 10.10.10.6 255.255.255.252

mpls ip

!

router ospf 100

 network 10.10.10.0 0.0.0.255 area 0

 

Example 2-15. R4 Configuration

hostname R4

!

ip cef

!

mpls label protocol ldp

!

interface Loopback0

 ip address 10.10.10.104 255.255.255.255

!

interface Serial1/0

 Description connection to R3

 ip address 10.10.10.10 255.255.255.252

 mpls ip

!

router ospf 100

network 10.10.10.0 0.0.0.255 area 0

 

Frame-Mode MPLS over RFC 2684 Routed PVC

Frame-mode MPLS can be implemented over RFC 2684 (previously RFC 1483) routed PVCs. When using PVCs, RFC 2684 specifies the following methods of encapsulation to carry traffic over ATM AAL5:

  • VC multiplexing – A virtual circuit-based multiplexing method in which each VC carries one protocol. The user, therefore, defines one PVC per protocol.
  • LLC/SNAP encapsulation – This method multiplexes multiple protocols over a single ATM virtual circuit.

Figure 2-4 shows the network topology for RFC 2684 routed.

Figure 2-4. Topology: Frame-Mode MPLS Over RFC 2684 Routed PVCs

Figure 2-5 illustrates the flowchart to configure frame-mode MPLS on the provider network devices shown in Figure 2-4. The configuration flowchart assumes that IP addresses are pre-configured where needed.

Figure 2-5. Frame-Mode MPLS Configuration Flowchart

Figure 2-6 shows the flowchart for configuring the ATM PVC route on the LS1010 ATM switch.

Figure 2-6. Configuration Flowchart for LS1010 ATM Switch

 

Configuration Steps for Frame-Mode MPLS Over RFC 2684 Routed PVC

The steps to configure RFC 2684 bridged encapsulation over MPLS on R1 and R2 are as follows. Ensure that IP addresses are preconfigured on R1 and R2, as illustrated in Figure 2-4:

Step 1.

Follow the steps shown in the "Basic Frame-Mode MPLS Configuration Steps" section. These steps are the same for frame-mode MPLS over RFC 2684 routed PVC. Follow those steps to configure frame-mode MPLS on R1 and R2:
 

Step 1. – Enable CEF
 

Step 2. – Enable IGP routing protocol
 

Step 3. – Assign LDP router ID
 

Step 2.

Enable IPv4 MPLS or label forwarding on the interface – Configure the ATM PVCs 2/200 on each of the appropriate subinterfaces on R1 and R2. The encapsulation used on the PVC is ATM aal5snap. Example 2-16 highlights the steps to configure ATM PVC.
 

Example 2-16. Configure PVCs on R1 and R2

R1(config)#interface ATM2/0.2 point-to-point

R1(config-subif)# pvc 2/200

R1(config-if-atm-vc)# encapsulation aal5snap

R1(config-if-atm-vc)# mpls ip

_____________________________________________________________________

R2(config)#interface ATM2/0.2 point-to-point

R2(config-subif)#pvc 2/200

R2(config-if-atm-vc)#encapsulation aal5snap

R2(config-if-atm-vc)# mpls ip
 

Configuration of the LS1010 ATM Switch

Configure the core ATM switches A1 and A2 to perform VC mapping from one interface to another. The PVC is a permanent logical connection that you must configure manually, from source to destination, through the ATM network. After it is configured, the ATM network maintains the connection at all times. The configuration of an ingress PVC/interface mapped to an egress PVC/interface needs to be performed only on one of the ingress or egress interfaces. Therefore, on ATM switch A1, the configuration is performed on interface ATM1/0/1 mapping PVC 2/200 to interface ATM1/0/0 PVC 2/200. The same process is repeated on ATM switch A2, shown in Example 2-17.

Example 2-17. Configure PVC Mapping on A1 and A2

A1(config-if)#interface ATM1/0/1

A1(config-if)# description Connection to A2

A1(config-if)# atm pvc 2 200 interface ATM1/0/0 2 200

_____________________________________________________________________

A2(config-if)#interface ATM1/0/1

A2(config-if)# description connection to A1

A2(config-if)# atm pvc 2 200 interface ATM1/0/0 2 200

 

Verification Steps for Frame-Mode MPLS Over RFC 2684 Routed PVC

The steps to verify frame-mode MPLS over RFC 2684 (previously RFC 1483) routed PVC are as follows:

Step 1.

Verify the operation of MPLS over RFC 2684 by performing a view of the MPLS forwarding information base (LFIB), as shown in Example 2-18.
 

Example 2-18. Verification of LFIB

R1#show mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

36 Pop tag 10.10.10.104/32 0 AT2/0.2 point2point

37 Pop tag 10.10.20.128/30 0 AT2/0.2 point2point

R1#

_____________________________________________________________________

R2#show mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 10.10.10.101/32 0 AT2/0.2 point2point

18 Pop tag 10.10.20.192/30 0 AT2/0.2 point2point
 

Step 2.

As shown in Example 2-19, verify connectivity by issuing pings.
 

Example 2-19. Verify Connectivity

R1#ping 10.10.10.104

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.101, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

R4#

R2#ping 10.10.10.101

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.101, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

R4#
 

Final Device Configuration for Frame-Mode MPLS Over RFC 2684 Routed PVC

The final device configuration for R1, A1, A2, and R2 is shown in Example 2-20 through Example 2-23.

Example 2-20. Configuration of R1

hostname R1

!

ip cef

!

interface Loopback0

 ip address 10.10.10.101 255.255.255.255

!

interface Ethernet0

 ip address 10.10.20.193 255.255.255.252

!

interface ATM2/0

 no ip address

!

interface ATM2/0.2 point-to-point

 description connection to A1

 ip address 10.10.20.1 255.255.255.252

 mpls ip

 pvc 2/200

 encapsulation aal5snap

 !

router ospf 100

 network 10.10.0.0 0.0.0.255 area 0

 

Example 2-21. A1 Configuration

hostname A1

!

interface ATM1/0/0

 description connection to R1

!

interface ATM1/0/1

 description connection to A2

atm pvc 2 200 interface ATM1/0/0 2 200

!

 

Example 2-22. A2 Configuration

hostname A2

!

interface ATM1/0/0

 description connection to R2

!

interface ATM1/0/1

 description connection to A1

atm pvc 2 200 interface ATM1/0/0 2 200

!

 

Example 2-23. R2 Configuration

hostname R2

!

ip cef

!

interface Loopback0

 ip address 10.10.10.104 255.255.255.255

!

interface Ethernet0

 ip address 10.10.20.129 255.255.255.252

!

interface ATM2/0

!

interface ATM2/0.2 point-to-point

 description connection to A2

 ip address 10.10.20.2 255.255.255.252

mpls ip

 pvc 2/200

 encapsulation aal5snap

!

router ospf 100

 log-adjacency-changes

 network 10.10.0.0 0.0.255.255 area 0






MPLS Configuration on Cisco IOS Software
MPLS Configuration on Cisco IOS Software
ISBN: 1587051990
EAN: 2147483647
Year: 2006
Pages: 130
Simiral book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net