Implementing AToM for Like to Like Circuits

AToM supports the following Layer 2 technologies over MPLS:

  • Ethernet
  • 802.1Q VLAN
  • ATM AAL5 frames
  • ATM cells
  • Frame Relay
  • PPP
  • HDLC

In this section, you will configure AToM for the following like to like circuits:

  • ATM over MPLS

    - AAL5 over MPLS

    - ATM Cell Relay over MPLS

  • Ethernet over MPLS

    - Router-based port mode

    - Router-based VLAN mode

    - Switch-based port mode

    - Switch-based VLAN mode

    - Switch-based Dot1q tunnel mode

  • PPP over MPLS
  • HDLC over MPLS
  • Frame Relay over MPLS

ATM over MPLS

In ATM over MPLS, two modes of encapsulation are supported to transport ATM cells over MPLS:

  • AAL5 over MPLS
  • ATM Cell Relay over MPLS

AAL5 over MPLS

In AAL5 over MPLS operation, the entire AAL5 frame is encapsulated and label switched across the MPLS backbone. The ingress PE router is required to reassemble all AAL5 CPCS-SDUs from the incoming VC and transport each CPCS-SDU as a single packet. The AAL5 trailer is not encapsulated and, therefore, not transported across the MPLS backbone. The use of the control word is required although its use is optional. The PE router can choose whether to use the control word. If the router chooses not to use it, it must set the flags in the control word to 0. The egress PE router must also follow similar procedure and must set the ATM control bits to 0 if it chooses to ignore the control word. The EFCI and CLP bits are carried across the network in the control word. The PE routers can change the EFCI and CLP bits from 0 to 1, during encapsulation and decapsulation. The AAL5 CPCS SDU is prepended with the header shown in Figure 11-10.

Figure 11-10. Control Word

Figure 11-11 shows a provider network providing AAL5 service to CE1-A and CE2-A. These customer devices exchange ATM cells on a permanent virtual circuit (PVC) with the PE Router PE1 and PE2.

Figure 11-11. AAL5 over MPLS

When the ATM cells on the PVC from CE1-A arrive on PE1's interface, PE1 reassembles the cells into AAL5 CPCS-SDU. These AAL5 CPCS-SDUs are encapsulated and forwarded across the MPLS backbone to the PE2 router. The encapsulation may contain a control word incorporating the EFCI and CLP bits and VPI/VCI information. PE2 decapsulates the packet and reproduces the AAL5 CPCS-DSU as a sequence of ATM cells to be transmitted on the PVC to CE-A2. Similar functions take place in the other direction from PE2 to PE1.

PE and Provider Router Configuration

The first step prior to provisioning Layer 2 VPN services is to ensure that the provider network is enabled for MPLS. Figure 11-12 shows the configuration for the PE Routers PE1 and PE2, and provider core Router P1 for MPLS forwarding. These basic configurations apply to all configuration scenarios in this chapter.

Figure 11-12. PE and Provider Router Configuration

 

Configuration Flowchart for AAL5 over MPLS

Figure 11-13 shows the flowchart to configure AAL5 over MPLS.

Figure 11-13. Configuration Flowchart for AAL5 over MPLS

 

Configuring AAL5 over MPLS

The steps to configure AAL5 over MPLS for the network topology shown in Figure 11-11 are

Step 1.

Configure ATM PVCs – In this step, you configure the ATM PVC on the ATM interface by defining the VPI and VCI value and defining the ATM encapsulation type. The command pvc {vpi/vci} l2transport assigns a VPI and VCI and enters the PVC configuration mode. The l2transport keyword indicates that the PVC is a switched PVC instead of a terminated PVC. AAL5 can be configured on only PVCs and cannot be configured on main interfaces. When defining the encapsulation type, ensure that the encapsulation type is the same on the PE and the CE routers connected to each other. See Example 11-1.
 

Example 11-1. Enable Transport of AAL5 Cells over MPLS on PE Routers

PE1(config)#interface ATM3/0.100 point-to-point

PE1(config-subif)# pvc 1/100 l2transport

PE1(cfg-if-atm-l2trans-pvc)# encapsulation aal5snap

________________________________________________________________

PE2(config)#interface ATM3/0.100 point-to-point

PE2(config-subif)# pvc 1/100 l2transport

PE2(cfg-if-atm-l2trans-pvc)# encapsulation aal5snap
 

Step 2.

Configure AToM VC to transport L2 packets – Example 11-2 shows the creation of an AToM VC to enable transportation of the AAL5 cells over MPLS. As illustrated in Example 11-2, VC ID 100 is used. The xconnect command is used under the PVC configuration for the ATM interface.
 

Example 11-2. Configure AToM VC to Transport Layer 2 Packet

PE1(cfg-if-atm-l2trans-pvc)#xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(cfg-if-atm-l2trans-pvc)#xconnect 10.10.10.101 100 encapsulation mpls
 

AAL5 over MPLS Configuration

Figure 11-14 shows the final relevant configuration for AAL5 over MPLS. Refer to Figure 11-12 for provider network configuration.

Figure 11-14. AAL5 over MPLS Configuration

 

Verification of AAL5 over MPLS

Step 1.

Verify AToM VC is operational – Example 11-3 depicts the output of show mpls l2transport vc on PE1. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone.
 

Example 11-3. Verify if AToM VC Is Up

PE1#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

AT3/0.100 ATM AAL5 1/100 10.10.10.102 100 UP
 

Step 2.

Verify control plane and data forwarding operation – Figure 11-15 shows the control and data plane operation in AAL5 over MPLS.
 

Figure 11-15. Control and Data Plane Operation for AAL5 over MPLS Service

 

The steps to verify control plane operations are

Step 1.

PE1 assigns VC label 16 to the attachment circuit connected to CE1-A, as shown in Example 11-4. PE1 propagates VC label 16 to PE2. To ensure that PE2 has reachability to PE1, PE1, as part of its IGP label operation, sends an implicit-null to P1 to instruct P1 to pop the IGP label in the data forwarding path from CE2-A to CE1-A.
 

Example 11-4. LFIB on PE1

PE1#show mpls forwarding-table

Local Outgoing Prefix Bytes Label Outgoing Next Hop

Label Label or VC or Tunnel Id Switched interface

16 No Label l2ckt(100) 540 none point2point

17 Pop Label 10.10.10.4/30 0 Gi6/0 10.10.10.2

18 Pop Label 10.10.10.100/32 0 Gi6/0 10.10.10.2

19 17 10.10.10.102/32 0 Gi6/0 10.10.10.2
 

Step 2.

P1 assigns a local IGP or tunnel label of 16 to PE1 (10.10.10.101/32) and propagates the same to PE2. See Example 11-5.
 

Example 11-5. LFIB on P1

P1#show mpls forwarding-table

Local Outgoing Prefix Bytes Label Outgoing Next Hop

Label Label or VC or Tunnel Id Switched interface

16 Pop Label 10.10.10.101/32 92682 Gi3/0 10.10.10.1

17 Pop Label 10.10.10.102/32 92772 Gi4/0 10.10.10.5
 

In the data forwarding path from CE2-A to CE1-A,

Step 1.

CE2-A sends data in the form of ATM cells to PE2.
 

Step 2.

PE2 receives the ATM cells and reassembles the cells to form an AAL5 SDU in a single packet over the MPLS network. As shown in Example 11-6, it appends the VC label 16 and the tunnel (IGP) label 16 to the packet and sends it to P1.
 

Step 3.

P1 receives the AAl5 SDU and pops the tunnel label as part of penultimate hop popping function and sends the data packet to PE1.
 

Example 11-6. Verify MPLS and VC Label

PE2#show mpls l2transport vc 100 detail

Local interface: AT3/0.100 up, line protocol up, ATM AAL5 1/100 up

 Destination address: 10.10.10.101, VC ID: 100, VC status: up

 Output interface: Gi6/0, imposed label stack {16 16}

 Preferred path: not configured

 Default path: active

 Tunnel label: 16, next hop 10.10.10.6

 Create time: 00:26:08, last status change time: 00:26:04

 Signaling protocol: LDP, peer 10.10.10.101:0 up

 MPLS VC labels: local 16, remote 16

 Group ID: local 0, remote 0

 MTU: local 4470, remote 4470

 Remote interface description:

 Sequencing: receive disabled, send disabled

 VC statistics:

 packet totals: receive 5, send 5

 byte totals: receive 540, send 670

 packet drops: receive 0, send 0
 

Step 4.

PE1 receives the packet from P1 and finds the VC label 16 associated with the AC connected to CE1-A. PE1 removes the VC-label 16 and forwards the data packet to CE1-A.
 

ATM Cell Relay over MPLS

In ATM Cell Relay over MPLS, there is no concept of ATM adaptation layers, and, therefore, the raw ATM cells are transported individually without invoking the Segmentation and Reassembly (SAR) process. As a result, raw ATM cells are received on the PE interface and are not reassembled into AAL frames at the PE device. The raw ATM cells may be encapsulated with a control word. The usage of the control word is optional. The control word includes the EFCI and CLP bits, and these are copied at the PE router from the ATM header into the control word. Figure 11-16 shows an MPLS provider providing Cell Relay over MPLS services to CE1-A and CE2-A.

Figure 11-16. ATM Cell Relay over MPLS Service

CE1-A and CE2-A exchange raw ATM cells over the MPLS backbone. PE1 receives the ATM cells from CE1-A and encapsulates the cell into an MPLS packet to be transported to PE2. Assuming the use of CONTROL WORD, the MPLS packet at the PE Router PE1 copies the EFCI and CLP information and appends the tunnel LSP label and VC label that was received from the remote PE Router PE2, indicating the outgoing interface on the remote PE Router PE2. At PE2, the raw cells are derived and forwarded to CE2-A.

Configuration Flowchart for ATM Cell over MPLS

Figure 11-17 shows the flowchart for configuring ATM Cell Relay over MPLS.

Figure 11-17. ATM Cell Relay over MPLS service

 

Configuring ATM Cell over MPLS

The steps to configure ATM cell relay services over MPLS are

Step 1.

Configure ATM PVCs – This step is similar to that shown in the section on AAL5 over MPLS. In this case, the encapsulation type is aal0. In Cell Relay over MPLS, the PE-CE encapsulation can differ; however, the ATM encapsulation on the CE routers on both ends should be the same. See Example 11-7.
 

Example 11-7. Enable Transport of AAL5 Cells over MPLS on PE Routers

PE1(config)#interface ATM3/0.100 point-to-point

PE1(config-subif)# pvc 1/100 l2transport

PE1(cfg-if-atm-l2trans-pvc)# encapsulation aal0

__________________________________________________________________________

PE2(config)#interface ATM3/0.100 point-to-point

PE2(config-subif)# pvc 1/100 l2transport

PE2(cfg-if-atm-l2trans-pvc)# encapsulation aal0
 

Step 2.

Configure AToM VC to transport L2 packets – In this step, you configure the AToM VC to enable transportation of the ATM cells over MPLS. This step is the same as shown in Example 11-2.
 

ATM Cell Relay over MPLS Configuration

Figure 11-18 shows the final relevant configuration for ATM Cell Relay over MPLS.

Figure 11-18. ATM Cell Relay over MPLS Configuration

 

Verification of ATM Cell Relay over MPLS

Step 1.

Ensure that AToM VC is functional – Example 11-8 shows the output of show mpls l2transport vc. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone.
 

Example 11-8. Verify if AToM VC Is Functional

PE1#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

AT3/0.100 ATM VCC CELL 1/100 10.10.10.102 100 UP
 

Step 2.

Verify MPLS transport bindings – Example 11-9 shows the maximum number of concatenated cells, which means the maximum total number of packed cells that the egress PE router can process in a single AToM packet. In other words, it involves concatenating multiple cells into a single AToM packet. The value of the maximum number of concatenated cells value defaults to 1, which means that by default only one ATM cell is packed in an AToM packet. Another detail to note from the output is that the AToM pseudo wire is functional irrespective of the MTU used. In other words, MTU value is not applied when ATM cells are transported over MPLS.
 

Example 11-9. Verify MPLS Transport Bindings

PE1#show mpls l2transport binding

 Destination Address: 10.10.10.102, VC ID: 100

 Local Label: 20

 Cbit: 1, VC Type: ATM VCC CELL, GroupID: 7

 MTU: n/a, Interface Desc: n/a

 Max Concatenated ATM Cells: 1

 VCCV Capabilities: None

 Remote Label: 20

 Cbit: 1, VC Type: ATM VCC CELL, GroupID: 7

 MTU: n/a, Interface Desc: n/a

 Max Concatenated ATM Cells: 1

 VCCV Capabilities: None
 

OAM in ATM AAL5 and ATM Cell Relay over MPLS

Operations, Administration, and Maintenance (OAM) provides VC/VP integrity, fault, and performance management. The system supports F4 and F5 ATM OAM fault management, loopback, and continuity check (CC) cells. These cells perform fault detection and notification, loopback testing, and link integrity. ATM uses F4 and F5 cell flows as follows:

  • F4 is used in VPs and inside each virtual path; the F4 OAM flow carries operation and maintenance information related to the virtual path. Cells belonging to this OAM flow have a VPI value of the VP and a Virtual Circuit Identifier (VCI) value of 3 (segment OAM) or 4 (multisegment OAM) respectively.
  • F5 is used in VCs and is responsible for OAM information on the virtual circuit level. Cells belonging to this OAM flow are marked with the VPI/VCI value of the VC they are responsible for as well as the Payload Type (PT) value of either 100 (segment OAM) or 101 (end-to-end OAM). When encapsulating ATM over MPLS (either AAL5 over MPLS or Cell Relay over MPLS), these OAM flows need to be transported across an MPLS backbone for proper operation.

OAM support is implemented in AAL5 over MPLS and Cell Relay over MPLS. The OAM cells are always encapsulated in a single label-switched packet during transport across an MPLS backbone.

In Cell Relay over MPLS, the F5 OAM flow is passed through transparently. The cells belonging to this OAM flow are distinguished by a specific VCI value, so no additional action is needed. Cells belonging to the F5 OAM flow carry the same VPI/VCI value as other user cells, but are distinguished by a specific PT value. During label imposition, the PT value is copied into the control word, maintaining end-to-end OAM flow. The copying of PT values in the control word is automatic and needs no specific configuration.

In AAL5 over MPLS operation, the entire AAL5 frame is label-encapsulated and switched across the MPLS backbone. It is not possible to forward the OAM cells across the MPLS backbone because forwarding individual cells (OAM cells in this case) is not supported when AAL5 frames (SDUs) are reassembled and forwarded in a single MPLS packet. However, it is possible to generate the OAM cells between local loopbacks.

To enable OAM cell emulation on AAL5 over MPLS, use the oam-ac emulation-enable command in the ATM VC configuration mode on both PE routers. To disable OAM cell emulation, use the no form of this command on both routers.

In case the AToM device does not support NNI signaling, the segment F4-OAM flow needs to be disabled to ensure proper operation. This inhibits the creation of F4 OAM VPs with the no-f4-oam keyword.

Ethernet over MPLS

In Ethernet over MPLS environment, Ethernet frames are exchanged between customer sites using the SP backbone as the medium of transport. Ethernet over MPLS is implemented in two different modes:

  • Port mode
  • VLAN mode

Forthcoming subsections will show you configuration and verification of EoMPLS on routers and switches.

Router-Based Ethernet over MPLS – Port Mode

In port mode, the entire Ethernet frame without the preamble or FCS is transported as a single AToM packet. The use of the control word is optional. If the control word is not used, the flag bits are set to zero when the packet is MPLS encapsulated and ignored when it is decapsulated on the receiving side. Ethernet frames with hardware level CRC errors, framing errors, and runt packets that arrive at the PE router are discarded. In port mode, the interface uses VC type 5 or 0x0005. Figure 11-19 shows an MPLS provider network that provides a Layer 2 Ethernet port-to-port connection for Customer A sites CE1-A and CE2-A.

Figure 11-19. Ethernet over MPLS – Port Mode

As shown in Figure 11-19, CE1-A and CE2-A exchange Ethernet frames over the provider backbone. PE2 receives the Ethernet frame from CE2-A and encapsulates that frame into an MPLS packet. This frame is then forwarded across the provider backbone to PE1. PE1 removes the MPLS headers and reproduces the Ethernet frame and forwards it to the CE1-A.

Configuration Flowchart for Router-Based Ethernet over MPLS – Port Mode

The configuration flowchart for Ethernet over MPLS in port mode is shown in Figure 11-20.

Figure 11-20. Configuration Flowchart for Ethernet over MPLS – Port Mode

 

Configuring Router-Based Ethernet over MPLS – Port Mode

The step to configure port mode Ethernet over MPLS is illustrated in Example 11-10 in which the xconnect statement is defined under the Ethernet interface to enable transportation of Ethernet frames from end CE devices over the MPLS network.

Example 11-10. Enable Transport of Ethernet over MPLS on PE Router

PE1(config)#interface FastEthernet5/0

PE1(config-if)#xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)#interface FastEthernet5/0

PE2(config-if)#xconnect 10.10.10.101 100 encapsulation mpls

 

Device Configuration for Router-Based Ethernet over MPLS – Port Mode

The final relevant configuration for Ethernet over MPLS in port mode is shown in Figure 11-21.

Figure 11-21. Configuration for Ethernet over MPLS – Port Mode

 

Verification of Ethernet over MPLS – Port Mode

Verify if AToM VC is functional. Example 11-11 shows the output of show mpls l2transport vc where the VC between the PE routers is up and running.

Example 11-11. Enable Transport of Ethernet over MPLS on PE Router

PE1#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Fa5/0 Ethernet 10.10.10.102 100 UP

 

Control Plane and Data Plane – Ethernet over MPLS (Port Mode)

Figure 11-22 shows the control and data plane operation for Ethernet over MPLS in port mode configuration.

Figure 11-22. Control and Data Plane EoMPLS – Port Mode

As shown in Figure 11-22, during the control plane operation, PE1 allocates VC label 16 for the AC connected to CE1-A. This VC label is propagated via the MPLS network to PE2, which uses this VC label 16 in the data forwarding for the packet originating from CE2-A destined to CE1-A. The tunnel label or IGP label 16, which is assigned by P1 for PE1 loopback 10.10.10.101, guides the packet from PE2 to PE1 for a data packet originating from CE2-A to CE1-A.

Router-Based Ethernet over MPLS – VLAN Mode

In the VLAN mode, PE devices do not filter any frames based on the MAC addresses. In other words, there is no support for MAC layer address learning and filtering. In EoMPLS, the Spanning-Tree Protocol is not used, and BPDUs are propagated transparently but not processed.

Figure 11-23 shows an MPLS provider network where PE devices PE1 and PE2 are connected to CE devices CE1-A and CE2-A. The interface encapsulation between the CE and the PE routers supports VLANs. Different subinterfaces in the PE routers connect different VLANs. The PE1 interface connected to CE1-A is configured as a VLAN subinterface. This VLAN subinterface is used for AToM forwarding.

Figure 11-23. Ethernet over MPLS – VLAN Mode

In Figure 11-23, PE1 and PE2 are configured for EoMPLS to propagate VLAN 100 across the backbone. PE1 and PE2 have loopback interfaces with IP address 10.10.10.101 and 10.10.10.102, respectively. These two addresses are used as LDP peer IDs. The subinterface fas5/0.100 is configured for VLAN 100 on both PE1 and PE2. This subinterface is configured for EoMPLS. The Ethernet frames are MPLS-encapsulated and forwarded to the PE router with IP address 10.10.10.101, which is PE1. The VC identifier, value 100, associates the connection with the other end. It is required that both endpoints use the same VC identifier value. There is no requirement that the VLAN identifier should be the same at both the ends. The most important detail is the VC identifier. The value 100 is used on both PE1 and PE2. From the end-user perspective, the EoMPLS service appears as an extension of their Ethernet segment (or in this case, a VLAN). There is no awareness of the MPLS backbone to the end-user routers. The backbone devices in the provider network are also oblivious to end-user activities. As shown in the example network in Figure 11-23, the Ethernet frame arrives on the PE2's VLAN subinterface; it is encapsulated into MPLS and forwarded across the backbone to PE1. PE1 decapsulates the packet and reproduces the Ethernet frame on the outgoing VLAN subinterface.

Configuration Flowchart for Router-Based Ethernet over MPLS – VLAN Mode

Figure 11-24 shows the configuration flowchart relevant to configuring Ethernet over MPLS in VLAN mode.

Figure 11-24. Configuration Flowchart for Ethernet over MPLS – VLAN Mode

 

Configuring Ethernet over MPLS – VLAN Mode

Example 11-12 depicts the configuration of Ethernet over MPLS in VLAN mode in which interface fas5/0.100 is configured for VLAN 100. The xconnect statement is defined under the Ethernet subinterface to enable transportation of Ethernet frames from end CE devices over MPLS network.

Example 11-12. Enable Transport of Ethernet over MPLS on PE Router

PE1(config)#interface FastEthernet5/0.100

PE1(config-subif)# encapsulation dot1Q 100

PE1(config-subif)# no cdp enable

PE1(config-subif)# xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)#interface FastEthernet5/0.100

PE2(config-subif)# encapsulation dot1Q 100

PE2(config-subif)# no cdp enable

PE2(config-subif)# xconnect 10.10.10.101 100 encapsulation mpls

 

Device Configuration for Router-Based Ethernet over MPLS – VLAN Mode

Figure 11-25 shows the relevant configuration for Ethernet over MPLS in VLAN mode.

Figure 11-25. Configuration for Ethernet over MPLS – VLAN Mode

 

Verification of Ethernet over MPLS – VLAN Mode

Step 1.

Verify if AToM VC is operational – Example 11-13 shows the output of show mpls l2transport vc. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone.
 

Example 11-13. Transport of Ethernet over MPLS on PE Router

PE1#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Fa5/0.100 Eth VLAN 100 10.10.10.102 100 UP
 

Step 2.

Verify MPLS and VC label – Example 11-14 shows the directed LDP peer is 10.10.10.101 for PE2. The example also shows the output of show mpls l2transport vc-id detail. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone. The VC ID is 100 and tunnel label is 16. This tunnel label is derived from LDP. The VC label on PE1 for outgoing interface on PE2 connected to CE2-A is 16, and PE1 allocates VC label 20 for the interface connected to CE1-A.
 

Example 11-14. Verify VC Label and Tunnel Label

PE2#show mpls l2transport vc 100 detail

Local interface: Fa5/0.100 up, line protocol up, Eth VLAN 100 up

 Destination address: 10.10.10.101, VC ID: 100, VC status: up

 Output interface: Gi6/0, imposed label stack {16 16}

 Preferred path: not configured

 Default path: active

 Tunnel label: 16, next hop 10.10.10.6

 Create time: 00:13:42, last status change time: 00:10:32

 Signaling protocol: LDP, peer 10.10.10.101:0 up

 MPLS VC labels: local 20, remote 16

 Group ID: local 0, remote 0

 MTU: local 1500, remote 1500

 Remote interface description:

 Sequencing: receive disabled, send disabled

 VC statistics:

 packet totals: receive 20, send 10

 byte totals: receive 4802, send 1382

 packet drops: receive 0, send 0
 

Figure 11-26 shows the data plane forwarding operation for an MPLS-enabled provider network providing Ethernet over MPLS using the VLAN mode.

Figure 11-26. Data Plane Operation – Ethernet over MPLS: VLAN Mode

 

Router-Based EoMPLS – VLAN Rewrite

Figure 11-27 depicts the configurations for the individual devices if the VLANs connected at each of the customer sites are not equal. Therefore, in this scenario, CE1-A is connected to PE1 using VLAN 100, and CE2-A is connected to PE2 using VLAN 200. As mentioned earlier, the VLAN mapping does not have to be consistent across sites to implement router-based Ethernet over MPLS VLAN mode.

Figure 11-27. Ethernet over MPLS – VLAN Mode: VLAN Rewrite

 

Switch-Based Ethernet over MPLS – Port Mode

Figure 11-28 shows an MPLS-enabled, switch-based provider network providing Ethernet port mode services to CE1-A and CE2-A. PE1 and PE2 are Supervisor 2 (Catalyst 6500 series) based switches running Cisco IOS (native).

Figure 11-28. Switch-Based Ethernet over MPLS – Port Mode

 

Configuration Flowchart for Ethernet over MPLS – Port, Dot1Q, and Tunnel Mode

Figure 11-29 shows the configuration flowchart relevant to configuring Ethernet over MPLS in Port mode.

Figure 11-29. Configuration Flowchart for Ethernet over MPLS – VLAN Mode

 

Backbone Configuration for PE1 and PE2

Example 11-15 outlines the basic configuration on the PE Routers PE1 and PE2 used for the switch-based AToM implementations.

Example 11-15. Backbone Configuration for PE1 and PE2

hostname PE1

!

mpls label protocol ldp

mpls ldp discovery targeted-hello accept

mpls ldp router-id Loopback0 force

!

interface Loopback0

 ip address 10.10.10.101 255.255.255.255

!

interface GE-WAN3/1

description connected to PE2

 ip address 10.10.10.1 255.255.255.252

 negotiation auto

 mpls ip

 mls qos trust dscp

!

router ospf 1

 network 10.0.0.0 0.255.255.255 area 0

__________________________________________________________________________

hostname PE2

!

mpls label protocol ldp

mpls ldp discovery targeted-hello accept

mpls ldp router-id Loopback0 force

!

interface Loopback0

 ip address 10.10.10.102 255.255.255.255

!

interface GE-WAN3/1

description connected to PE1

 ip address 10.10.10.2 255.255.255.252

 negotiation auto

 mpls ip

 mls qos trust dscp

!

router ospf 1

 network 10.0.0.0 0.255.255.255 area 0

 

Configuring Ethernet over MPLS – Port Mode

Example 11-16 depicts the configuration of switch-based Ethernet over MPLS in port mode where interface fas4/1 on PE1 is configured as an access port connected to CE1-A. The xconnect statement is defined under the VLAN interface to enable transportation of Ethernet frames from end CE devices over MPLS network.

Example 11-16. Enable Transport of Ethernet over MPLS on PE Router

PE1(config)#vlan 100

PE1(config-vlan)#state active

PE1(config-vlan)#exit

PE1(config)#interface fastEthernet 4/1

PE1(config-if)#switchport

PE1(config-if)#switchport access vlan 100

PE1(config-if)#switchport mode access

PE1(config-if)#exit

PE1(config)#interface vlan 100

PE1(config-if)#xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)#vlan 100

PE2(config-vlan)#state active

PE2(config-vlan)#exit

PE2(config)#interface fastEthernet 4/1

PE2(config-if)#switchport

PE2(config-if)#switchport access vlan 100

PE2(config-if)#switchport mode access

PE2(config-if)#exit

PE2(config)#interface vlan 100

PE2(config-if)#xconnect 10.10.10.101 100 encapsulation mpls

 

Switch-Based Ethernet over MPLS – Port Mode Configuration

Figure 11-30 shows the relevant configuration for Ethernet over MPLS in VLAN mode.

Figure 11-30. Configuration for Ethernet over MPLS – Port Mode

 

Verification of Ethernet over MPLS – Port Mode

Step 1.

Verify that AToM VC is up – Example 11-17 illustrates the output of show mpls l2transport vc. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone.
 

Example 11-17. Transport of Ethernet over MPLS on PE Router

PE1#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Vl100 Eth VLAN 100 10.10.10.102 100 UP

__________________________________________________________________________

PE2#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Vl100 Eth VLAN 100 10.10.10.101 100 UP
 

Step 2.

Verify connectivity – Example 11-18 shows the verification of connectivity between the CE routers.
 

Example 11-18. Verify Connectivity

CE1-A#ping 172.16.1.2 source 172.16.1.1



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

Switch-Based Ethernet over MPLS – VLAN Mode

Figure 11-31 shows an MPLS-enabled, switch-based provider network providing Ethernet port mode services to CE1-A and CE2-A. PE1 and PE2 are Supervisor 2-based switches running Cisco IOS.

Figure 11-31. Switch-Based Ethernet over MPLS – VLAN Mode

 

Configuration Flowchart for Ethernet over MPLS – VLAN Mode

Figure 11-32 shows the configuration flowchart relevant to configuring Ethernet over MPLS in VLAN mode.

Figure 11-32. Configuration Flowchart for Ethernet over MPLS – VLAN Mode

 

Configuring Ethernet over MPLS – VLAN Mode

Example 11-19 shows the steps to configure Ethernet over MPLS in VLAN mode. The xconnect statement is defined under the VLAN interface to enable transportation of Ethernet VLAN frames from end CE devices over the MPLS network.

Example 11-19. Enable Transport of Ethernet over MPLS on PE Router

PE1(config)#vlan 100

PE1(config-vlan)#state active

PE1(config-vlan)#exit

PE1(config)#interface fastEthernet 4/1

PE1(config-if)#switchport

PE1(config-if)# switchport trunk encapsulation dot1q

PE1(config-if)# switchport trunk allowed vlan 100

PE1(config-if)# switchport mode trunk

PE1(config-if)#exit

PE1(config)#interface vlan 100

PE1(config-if)#xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)#vlan 100

PE2(config-vlan)#state active

PE2(config-vlan)#exit

PE1(config)#interface fastEthernet 4/1

PE1(config-if)#switchport

PE1(config-if)# switchport trunk encapsulation dot1q

PE1(config-if)# switchport trunk allowed vlan 100

PE1(config-if)# switchport mode trunk

PE2(config-if)#exit

PE2(config)#interface vlan 100

PE2(config-if)#xconnect 10.10.10.101 100 encapsulation mpls

 

Final Configurations for Switch-Based Ethernet over MPLS – VLAN Mode

Figure 11-33 shows the relevant configuration for Ethernet over MPLS in VLAN mode.

Figure 11-33. Configuration for Ethernet over MPLS – VLAN Mode

 

Verification of Ethernet over MPLS – VLAN Mode

Step 1.

Verify that AToM VC is up – Example 11-20 shows the output of show mpls l2transport vc. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone.
 

Example 11-20. Transport of Ethernet over MPLS on PE Router

PE1#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Vl100 Eth VLAN 100 10.10.10.102 100 UP

__________________________________________________________________________

PE2#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Vl100 Eth VLAN 100 10.10.10.101 100 UP
 

Step 2.

Verify connectivity – Example 11-21 illustrates the verification for connectivity between the CE routers.
 

Example 11-21. Verify Connectivity

CE1-A#ping 172.16.1.2 source 172.16.1.1



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

Switch-Based Ethernet over MPLS – dot1q Tunnel Mode

Figure 11-34 shows an MPLS-enabled, switch-based provider network providing Ethernet port mode services to CE1-A and CE2-A. PE1 and PE2 are Supervisor 2 based switches running Cisco IOS.

Figure 11-34. Switch-Based Ethernet over MPLS – Port Mode

 

Configuration Flowchart for Ethernet over MPLS – dot1Q Mode

Figure 11-35 shows the configuration flowchart relevant to configuring Ethernet over MPLS in VLAN mode.

Figure 11-35. Configuration Flowchart for Ethernet over MPLS – VLAN Mode

 

Configuring Ethernet over MPLS – dot1q Mode

Example 11-22 shows the steps to configure Ethernet over MPLS in dot1q mode. Example 11-23 shows the configuration steps on CE switch CE-Sw1 and CE-Sw2.

Example 11-22. Enable Transport of Ethernet over MPLS on PE Router

PE1(config)#vlan 10

PE1(config-vlan)#state active

PE1(config-vlan)#exit

PE1(config)#interface FastEthernet4/12

PE1(config-if)#switchport

PE1(config-if)# switchport access vlan 10

PE1(config-if)# switchport trunk encapsulation dot1q

PE1(config-if)# switchport trunk allowed vlan 100,200

PE1(config-if)# switchport mode dot1q-tunnel

PE1(config-if)#exit

PE1(config)#interface vlan 10

PE1(config-if)#xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)#vlan 10

PE2(config-vlan)#state active

PE2(config-vlan)#exit

PE2(config)#int fastEthernet 4/12

PE2(config-if)#switchport

PE2(config-if)# switchport trunk encapsulation dot1q

PE2(config-if)# switchport trunk allowed vlan 100,200

PE2(config-if)# switchport mode dot1q-tunnel

PE2(config-if)#exit

PE2(config)#interface vlan 10

PE2(config-if)#xconnect 10.10.10.101 100 encapsulation mpls

 

Example 11-23. Configuration Steps on CE Switch CE-Sw1 and CE-Sw2

CE-SW1(config)#vlan 100

CE-SW1(config-vlan)#state active

CE-SW1(config)#vlan 200

CE-SW1(config-vlan)#state active

CE-SW1(config-vlan)#exit

CE-SW1(config-if)#interface FastEthernet0/1

CE-SW1(config-if)# switchport access vlan 100

CE-SW1(config-if)# switchport mode access

CE-SW1(config-if)#interface FastEthernet0/2

CE-SW1(config-if)# switchport access vlan 200

CE-SW1(config-if)# switchport mode access

CE-SW1(config-if)#interface FastEthernet0/12

CE-SW1(config-if)# switchport trunk encapsulation dot1q

CE-SW1(config-if)# switchport trunk allowed vlan 100,200

CE-SW1(config-if)# switchport mode trunk

__________________________________________________________________________

CE-SW2(config)#vlan 100

CE-SW2(config-vlan)#state active

CE-SW2(config)#vlan 200

CE-SW2(config-vlan)#state active

CE-SW2(config-vlan)#exit

CE-SW2(config-if)#interface FastEthernet0/1

CE-SW2(config-if)# switchport access vlan 100

CE-SW2(config-if)# switchport mode access

CE-SW2(config-if)#interface FastEthernet0/2

CE-SW2(config-if)# switchport access vlan 200

CE-SW2(config-if)# switchport mode access

CE-SW2(config-if)#interface FastEthernet0/12

CE-SW2(config-if)# switchport trunk encapsulation dot1q

CE-SW2(config-if)# switchport trunk allowed vlan 100,200

CE-SW2(config-if)# switchport mode trunk

 

Switch-Based Ethernet over MPLS – Dot1q Tunnel Mode

Figure 11-36 shows the relevant configuration for switch based Ethernet over MPLS in Dot1q Tunnel mode.

Figure 11-36. Configuration for Ethernet over MPLS – VLAN Mode

 

Verification of Ethernet over MPLS – VLAN Mode

Step 1.

Verify that AToM VC is up – Example 11-24 shows the output of show mpls l2transport vc. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone.
 

Example 11-24. Transport of Ethernet over MPLS on PE Router

PE1#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Vl10 Eth VLAN 10 10.10.10.102 100 UP

__________________________________________________________________________

PE2#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Vl10 Eth VLAN 10 10.10.10.101 100 UP
 

Step 2.

Verify connectivity – Example 11-25 shows the steps to verify connectivity between the CE routers.
 

Example 11-25. Verify VC Label and Tunnel Label

CE1-A#ping 172.16.1.2 source 172.16.1.1



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

__________________________________________________________________________

CE1-B#ping 192.168.1.2 source 192.168.1.1



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

Packet sent with a source address of 192.168.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

PPP over MPLS

PPP mode provides point-to-point transport of PPP-encapsulated traffic. The PPP PDU is transported in its entirety, including the protocol field, but excluding any media-specific framing information, such as HDLC address and control fields or FCS. The sequencing control word is optional, and its usage is signaled during the VC label binding distribution.

The protocol field is transmitted intact, regardless of the two PPP peers negotiated Protocol Field Compression (PFC).

The HDLC address and control fields, if present in the PPP header, are always removed from the PPP PDU received from ingress interface by the ingress PE router. Even if the two peering CE routers might have negotiated Address and Control Field Compression (ACFC), the egress PE router has no way of identifying this unless it sniffs the PPP LCP negotiation, which is not part of the end-to-end PPP peering model. Therefore, the egress PE router always adds HDLC address and control fields back to the PPP PDU before sending it out to the egress interface, if the CE-PE link uses HDLC-like framing. This is perfectly legitimate because a PPP implementation must prepare to receive PPP PDU with uncompressed address and control field at all times regardless of ACFC. For CE-PE links that do not use HDLC-like framing, such as PPPoE, PPPoATM, and PPPoFR, there is no need to add the address and control fields at the egress PE.

Figure 11-37 shows a detail level of MPLS labels being used in PPP over MPLS.

Figure 11-37. Data Plane Operation in PPP over MPLS

The following steps outline the data plane operation of PPP over MPLS:

Step 1.

When the device driver of the ingress interface on ingress PE (PE1) receives PPP packets at the interrupt level, it classifies the packets based on the protocol field in the PPP header and interface configuration.
 

Step 2.

At the ingress PE (PE1), a two-level label stack is precalculated for each VC where the top label is the tunnel label and the bottom label is the VC label. The address and control fields in the PPP header are removed if present, and the protocol field is uncompressed if compressed. To switch received PPP packets into the VC, the label stack and the MAC string of the outgoing MPLS interface are prepended to the packets.
 

Step 3.

While labeled PPP packets traverse the MPLS backbone via standard label switching, the tunnel label may be swapped or popped. If the penultimate LSR on the LSP from the ingress (PE1) to egress PE (PE2) supports label popping, the egress PE binds an implicit-null label to its host route FEC and advertises this label binding to the penultimate LSR. This causes the penultimate LSR to pop the tunnel label when switching the packets to the egress PE (PE2). With penultimate hop popping, the packet arrives at the egress PE with only the VC label. PE2 pops the VC label and determines the egress interface based on the VC label.
 

Step 4.

The egress PE router, PE2, adds the address and control fields back to the PPP PDU before it is switched to the egress interface to the CE device CE2-A.
 

Configuration Flowchart for PPP over MPLS

Figure 11-38 shows the configuration steps relevant to configuring PPP over MPLS.

Figure 11-38. Configuration Flowchart for PPP over MPLS

 

Configuring PPP over MPLS

The step to configure PPP over MPLS for the topology shown in Figure 11-37 is to first define PPP encapsulation and configure the VCID on each of the PE routers' interface connected to the CE routers, so that the directed LDP session can be formed to enable transportation of PPP packets from end CE devices over MPLS. See Example 11-26.

Example 11-26. Enable PPP over MPLS on PE Routers

PE1(config)# interface Serial2/1

PE1(config-if)#encapsulation ppp

PE1(config-if)# xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)# interface Serial2/1

PE2(config-if)#encapsulation ppp

PE2(config-if)# xconnect 10.10.10.102 100 encapsulation mpls

 

Device Configuration for PPP over MPLS

Figure 11-39 shows the relevant device configuration for PPP over MPLS. PE1 and PE2 are PE routers in the MPLS provider network.

Figure 11-39. MPLS-Enabled Network Providing PPP over MPLS

 

Verification of PPP over MPLS

Step 1.

Verify directed LDP session – This step verifies that the AToM VC is functional to transport PPP over MPLS. See Example 11-27.
 

Example 11-27. Verify AToM VC Is Operational

PE1#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Se2/1 PPP 10.10.10.102 100 UP
 

Step 2.

Verify Layer 2 transport label bindings – In this step, you verify the local and remote label bindings. As shown in Example 11-28, the VC type is PPP, the control word is set and local, and remote MTU is 1500.
 

Example 11-28. Verify Label Bindings

PE2#show mpls l2transport binding

 Destination Address: 10.10.10.101, VC ID: 100

 Local Label: 20

 Cbit: 1, VC Type: PPP, GroupID: 0

 MTU: 1500, Interface Desc: connected to CE2-A

 VCCV Capabilities: None

 Remote Label: 16

 Cbit: 1, VC Type: PPP, GroupID: 0

 MTU: 1500, Interface Desc: connected to CE1-A

 VCCV Capabilities: None
 

MTUs need to match; otherwise, the circuit will not come up, as shown in Example 11-29.

Example 11-29. L2 Transport Down in Case of MTU Mismatch

PE2#show mpls l2transport binding

 Destination Address: 10.10.10.101, VC ID: 100

 Local Label: 16

 Cbit: 1, VC Type: PPP, GroupID: 0

 MTU: 512, Interface Desc: connected to CE2-A

 VCCV Capabilities: None

 Remote Label: 16

 Cbit: 1, VC Type: PPP, GroupID: 0

 MTU: 1500, Interface Desc: connected to CE1-A

 VCCV Capabilities: None

PE2#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Se2/1 PPP 10.10.10.101 100 DOWN

 

Data Plane Forwarding for PPP over MPLS

Figure 11-40 shows the data forwarding operation that takes place for traffic originating from CE2-A to CE1-A.

Figure 11-40. Data Forwarding for PPP over MPLS

 

HDLC over MPLS

HDLC mode provides port-to-port transport of HDLC-encapsulated traffic. The HDLC PDU is transported in its entirety, including the HDLC address, control, and protocol fields, but excluding HDLC flags and the FCS. Bit/byte stuffing is undone. The control word is optional and when the control word is used, then the flag bits in the control word are set to 0 when transmitted and ignored on receipt. In Cisco implementation of HDLC over MPLS, the C bit is set by default. Figure 11-41 shows the control word when HDLC is used for transporting over MPLS.

Figure 11-41. Control Word – HDLC over MPLS

The process of encapsulating the HDLC PDU is shown in Figure 11-42.

Figure 11-42. Data Plane – HDLC over MPLS

The data plane operation process when CE2-A sends an HDLC packet to CE1-A is explained in the following steps:

Step 1.

CE2-A sends an HDLC packet to PE2.
 

Step 2.

PE2 receives the HDLC packet and removes the flag and FCS fields from the packet. The remnants of the HDLC packet are used as L2 PDU, and the VC label and IGP label are appended to the packet. The modified packet is then sent to P1-AS1.
 

Step 3.

P1 performs PHP function on the packet and removes the IGP label or LSP tunnel label and forwards the packet to PE1.
 

Step 4.

PE1 does a lookup on the VC label and appends the HDLC PDU with HDLC flags and FCS fields prior to forwarding it to CE1-A.
 

Configuration Flowchart for HDLC over MPLS

Figure 11-43 shows the configuration flowchart relevant to configuring HDLC over MPLS.

Figure 11-43. Configuration Steps for HDLC over MPLS

 

Configuring HDLC over MPLS

The objective for the L2 transport provider is to provide transparent L2 services to customer sites. Figure 11-44 shows an MPLS-enabled service provider network providing L2 transport service to Customer A sites, CE1-A and CE2-A.

Figure 11-44. Network Providing HDLC over MPLS Service

To configure HDLC over MPLS, enable transport of HDLC over MPLS. In this step, the HDLC encapsulation is defined and the VCID configured on each of the PE routers' interface connected to the CE routers, so that the directed LDP session can be formed to enable transportation of PPP packets from end CE devices over MPLS. See Example 11-30.

Example 11-30. Enable HDLC over MPLS on PE Routers

PE1(config)# interface Serial2/1

PE1(config-if)#encapsulation hdlc

PE1(config-if)# xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)# interface Serial2/1

PE2(config-if)#encapsulation hdlc

PE2(config-if)# xconnect 10.10.10.101 100 encapsulation mpls

 

Verify HDLC over MPLS

To verify HDLC over MPLS, follow these steps:

Step 1.

Verify directed LDP session – In this step, you verify if the AToM VC is functional to transport PPP over MPLS. See Example 11-31.
 

Example 11-31. Verification of ATOM VC

PE1#show mpls l2transport vc



Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Se2/1 HDLC 10.10.10.102 100 UP
 

Step 2.

Verify Layer 2 transport label bindings – In this step, the local and remote label bindings are verified. As shown in Example 11-32, the VC type is PPP, the control word is set and local, and remote MTU is 1500.
 

Example 11-32. Verification of Layer 2 Transport Label Bindings

PE1#show mpls l2transport binding

 Destination Address: 10.10.10.102, VC ID: 100

 Local Label: 16

 Cbit: 1, VC Type: HDLC, GroupID: 0

 MTU: 1500, Interface Desc: connected to CE1-A

 VCCV Capabilities: None

 Remote Label: 20

 Cbit: 1, VC Type: HDLC, GroupID: 0

 MTU: 1500, Interface Desc: connected to CE2-A

 VCCV Capabilities: None
 

Final Configuration for HDLC over MPLS

Figure 11-44 shows the relevant device configuration for HDLC over MPLS. PE1 and PE2 are PE routers in the MPLS provider network.

Frame Relay over MPLS

Frame Relay over MPLS can work in either data-link connection identifier (DLCI)-to-DLCI mode or port-to-port mode. Frame Relay frames are received by the PE1 router from CE1-A, encapsulated into an MPLS, and forwarded across the backbone to PE2, where they are decapsulated and reproduced on the interface to CE2-A.

The main difference between DLCI-to-DLCI mode and port-to-port mode is the devices on which the Local Management Interface (LMI) procedures run. In port-to-port mode, the CE routers run the LMI between themselves, and the PE routers do not participate in the LMI. In port-to-port mode, the PE routers use the HDLC as a transport mode on the interface facing the CE router. In DLCI-to-DLCI mode, the PE routers actively participate in the LMI procedures, so the LMI runs between the PE and CE routers. Figure 11-45 shows the network used to depict implementation of Frame Relay over MPLS.

Figure 11-45. Network Providing Frame Relay over MPLS Service

 

Configuration Steps for Frame Relay over MPLS – DLCI Mode

Figure 11-46 shows the steps to configure Frame Relay over MPLS in DLCI mode.

Figure 11-46. Network Providing Frame Relay over MPLS Service

 

Configuring Frame Relay over MPLS – DLCI Mode

In this step, you configure the VCID on each of the PE routers' interface connected to the CE routers, so that the directed LDP session can be formed to enable transportation of Frame Relay frames from end CE devices over MPLS network. See Example 11-33.

Example 11-33. Enable Transport of Ethernet over MPLS on PE Routers

PE1(config)#frame-relay switching

PE1(config)#interface Serial2/1

PE1(config-if)# encapsulation frame-relay

PE1(config-if)# frame-relay intf-type dce

PE1(config-if)#exit

PE1(config)#connect FR Serial2/1 100 l2transport

PE1(config-fr-pw-switching)# xconnect 10.10.10.102 100 encapsulation mpls

__________________________________________________________________________

PE2(config)#frame-relay switching

PE2(config)#interface Serial2/1

PE2(config-if)# encapsulation frame-relay

PE2(config-if)# frame-relay intf-type dce

PE2(config-if)#exit

PE2(config)#connect FR Serial2/1 100 l2transport

PE2(config-fr-pw-switching)# xconnect 10.10.10.101 100 encapsulation mpls

 

Verification of Frame Relay over MPLS – DLCI Mode

To verify Frame Relay over MPLS in DLCI mode, follow these steps:

Step 1.

Ensure that AToM VC is up – Example 11-34 shows the output of show MPLS l2transport vc. The output indicates that the AToM VC is functional to transport L2 packets across the MPLS backbone.
 

Example 11-34. show mpls l2transport vc on PE1

PE1#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Se2/1 FR DLCI 100 10.10.10.102 100 UP
 

Step 2.

Verify pseudo wire status – Example 11-35 shows the output of the show connection all command where the Frame Relay switched connection has two segments:
 

- Segment 1 – The local attachment circuit out of Serial 2/1 DLCI 100.
 

- Segment 2 – The remote endpoint of the pseudo wire is PE2 (10.10.10.102).
 

Example 11-35. Verification of Pseudo Wire Status – DLCI Mode

PE1#show connection all



ID Name Segment 1 Segment 2 State

============================================================================

1 FR Se2/1 100 10.10.10.102 100 UP

________________________________________________________________

PE1#show connection id 1



FR/Pseudo-Wire Connection: 1 - FR

 Status - UP

 Segment 1 - Serial2/1 DLCI 100

 Segment status: UP

 Line status: UP

 PVC status: ACTIVE

 NNI PVC status: ACTIVE

 Segment 2 - 10.10.10.102 100

 Segment status: UP

 Requested AC state: UP

 PVC status: ACTIVE

 NNI PVC status: ACTIVE
 

Step 3.

Verify MPLS and VC label – Example 11-36 shows the output of show MPLS l2transport binding. The output indicates that the VC type is Frame Relay DLCI mode as well as the local and remote-label bindings.
 

Example 11-36. Verification of MPLS and VC Label Bindings

PE1#show mpls l2transport binding

 Destination Address: 10.10.10.102, VC ID: 100

 Local Label: 16

 Cbit: 1, VC Type: FR DLCI, GroupID: 0

 MTU: 1500, Interface Desc: connected to CE1-A

 VCCV Capabilities: None

 Remote Label: 20

 Cbit: 1, VC Type: FR DLCI, GroupID: 0

 MTU: 1500, Interface Desc: connected to CE2-A

 VCCV Capabilities: None
 

Final Configuration for Frame Relay over MPLS (DLCI Mode)

Figure 11-47 shows the final configurations for the devices to implement Frame Relay over MPLS (DLCI mode).

Figure 11-47. Configurations for Frame Relay over MPLS (DLCI Mode)






MPLS Configuration on Cisco IOS Software
MPLS Configuration on Cisco IOS Software
ISBN: 1587051990
EAN: 2147483647
Year: 2006
Pages: 130
Simiral book on Amazon

Flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net