Modifying and Creating an nPartition


Now that we know the basics of some HP-UX commands for working with nPartitions, let's put a few of these commands to use by modifying and creating some nPartitions. We're kind of getting ahead of ourselves in this section. There are a lot of basics related to working with nPartitions in upcoming sections, but most of the commands used in this section are at the HP-UX command line or parmgr interface, so we won't be using any information in upcoming sections. Let's go ahead and perform some modification on an nPartition and create a new nPartition.

We'll start our work on a 32-way Superdome that has one nPartition. In the following listing we'll issue parstatus with the -P option to see what partitions exist, of which there is only one on our Superdome, then issue parstatus with no options to get an overall rundown on the partitions, and finally, run parstatus -I to see the I/O that exists in the Superdome complex:

 #  parstatus -P  [Partition] Par              # of  # of I/O Num Status       Cells Chassis  Core cell  Partition Name (first 30 chars) === ============ ===== ======== ========== ===============================  0  active         6      3     cab0,cell0 P1 #  parstatus  [Partition] Partition Number       : 0 Partition Name         : P1 Status                 : active IP address             : 0.0.0.0 Primary Boot Path      : 0/0/1/0/0.0.0 Alternate Boot Path    : 0/0/6/0/0.1.0 HA Alternate Boot Path : 0/0/1/0/0.6.0 PDC Revision           : 32.5 IODCH Version          : 5E70 CPU Speed              : 750 MHz Core Cell              : cab0,cell0 [Cell]                         CPU     Memory                                Use                         OK/     (GB)                          Core    On Hardware   Actual       Deconf/ OK/                           Cell    Next Par Location   Usage        Max     Deconf    Connected To        Capable Boot Num ========== ============ ======= ========= =================== ======= ==== === cab0,cell0 active core  4/0/4    4.0/12.0 cab0,bay1,chassis3  yes     yes  0 cab0,cell1 active base  4/0/4    4.0/12.0 cab0,bay1,chassis1  yes     yes  0 cab0,cell2 active base  4/0/4    4.0/12.0 -                   no      yes  0 cab0,cell3 active base  4/0/4    4.0/12.0 -                   no      yes  0 cab0,cell4 active base  4/0/4    4.0/12.0 cab0,bay0,chassis1  yes     yes  0 cab0,cell7 active base  4/0/4    4.0/12.0 -                   no      yes  0 [Chassis]                                  Core Connected  Par Hardware Location   Usage        IO   To         Num =================== ============ ==== ========== === cab0,bay1,chassis3  active       yes  cab0,cell0 0 cab0,bay1,chassis1  active       yes  cab0,cell1 0 cab0,bay0,chassis1  active       yes  cab0,cell4 0 #  parstatus -I  [Chassis]                                  Core Connected  Par Hardware Location   Usage        IO   To         Num =================== ============ ==== ========== === cab0,bay0,chassis0  absent       -    -          - cab0,bay0,chassis1  active       yes  cab0,cell4 0 cab0,bay0,chassis2  absent       -    -          - cab0,bay0,chassis3  active       yes  cab0,cell5 0 cab0,bay1,chassis0  absent       -    -          - cab0,bay1,chassis1  active       yes  cab0,cell1 0 cab0,bay1,chassis2  absent       -    -          - cab0,bay1,chassis3  active       yes  cab0,cell0 0 

Our one nPartition, with a name of P1 and a number of , has in it cell boards cell0-4 and cell7. cell0 is the core cell in nPartition p0 .

Next we'll remove cell7 from this nPartition with parmodify . Notice in the following listing that after we run parmodify on p0 , shutdown -R is required to make the removal of cell7 from p0 :

 #  parmodify -p0 -d7 -B  Cell 7 is active. Use shutdown -R to shutdown the system to ready for reconfig state. Command succeeded. # 

After having issued the parmodify and shutdown -R , cell7 is indeed removed from p0 . This is confirmed on reboot with the following verbose listing of p0 :

 #  parstatus -V -p0  [Partition] Partition Number       : 0 Partition Name         : P1 Status                 : active IP address             : 0.0.0.0 Primary Boot Path      : 0/0/1/0/0.0.0 Alternate Boot Path    : 0/0/6/0/0.1.0 HA Alternate Boot Path : 0/0/1/0/0.6.0 PDC Revision           : 32.5 IODCH Version          : 5E70 CPU Speed              : 750 MHz Core Cell              : cab0,cell0 [Cell]                         CPU     Memory                                Use                         OK/     (GB)                          Core    On Hardware   Actual       Deconf/ OK/                           Cell    Next Par Location   Usage        Max     Deconf    Connected To        Capable Boot Num ========== ============ ======= ========= =================== ======= ==== === cab0,cell0 active core  4/0/4    4.0/12.0 cab0,bay1,chassis3  yes     yes  0 cab0,cell1 active base  4/0/4    4.0/12.0 cab0,bay1,chassis1  yes     yes  0 cab0,cell2 active base  4/0/4    4.0/12.0 -                   no      yes  0 cab0,cell3 active base  4/0/4    4.0/12.0 -                   no      yes  0 cab0,cell4 active base  4/0/4    4.0/12.0 cab0,bay0,chassis1  yes     yes  0 [Chassis]                                  Core Connected  Par Hardware Location   Usage        IO   To         Num =================== ============ ==== ========== === cab0,bay1,chassis3  active       yes  cab0,cell0 0 cab0,bay1,chassis1  active       yes  cab0,cell1 0 cab0,bay0,chassis1  active       yes  cab0,cell4 0 

This listing shows that cell0-4 are part of p0 and that cell7 has been successfully removed from p0 . Let's now take a look at the list of available cell components in our Superdome complex with parstatus -A -C :

 #  parstatus -A -C  [Cell]                         CPU     Memory                                Use                         OK/     (GB)                          Core    On Hardware   Actual       Deconf/ OK/                           Cell    Next Par Location   Usage        Max     Deconf    Connected To        Capable Boot Num ========== ============ ======= ========= =================== ======= ==== === cab0,cell5 inactive     4/0/4   4.0/12.0  cab0,bay0,chassis3  yes     -    - cab0,cell6 inactive     4/0/4   4.0/12.0 -                    no      -    - cab0,cell7 inactive     4/0/4   4.0/12.0 -                    no      -    - 

This listing shows that cell5-7 are free. We just removed cell7 from nPartition p0, which resulted in it being shown in the available cell board listing.

Next let's create a new nPartition. We're going to add many components to the nPartition, so we'll first figure out what disks are used and available since one will be required as a boot device. The following listing of strings /etc/lvmtab shows only one disk in use:

 #  strings /etc/lvmtab  /dev/vg00 S*,%=A /dev/dsk/c0t0d0 

Only c0t0d0 is in use at this time. We know that we can't use this disk, and we can see all disks on the system with the following ioscan command:

 #  ioscan -funC disk  Class     I  H/W Path       Driver S/W State    H/W Type     Description ======================================================================= disk      0  0/0/1/0/0.0.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c0t0d0    /dev/rdsk/c0t0d0 disk      1  0/0/1/0/0.1.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c0t1d0    /dev/rdsk/c0t1d0 disk      2  0/0/1/0/0.2.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c0t2d0    /dev/rdsk/c0t2d0 disk      3  0/0/1/0/0.3.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c0t3d0    /dev/rdsk/c0t3d0 disk      4  0/0/6/0/0.1.0  sdisk CLAIMED      DEVICE       HP      DVD-ROM 305                            /dev/dsk/c1t1d0    /dev/rdsk/c1t1d0 disk      8  1/0/1/0/0.0.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c4t0d0    /dev/rdsk/c4t0d0 disk      9  1/0/1/0/0.1.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c4t1d0    /dev/rdsk/c4t1d0 disk     10  1/0/1/0/0.2.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c4t2d0    /dev/rdsk/c4t2d0 disk     11  1/0/1/0/0.3.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c4t3d0    /dev/rdsk/c4t3d0 disk     15  4/0/1/0/0.0.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c8t0d0    /dev/rdsk/c8t0d0 disk     16  4/0/1/0/0.1.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c8t1d0    /dev/rdsk/c8t1d0 disk     17  4/0/1/0/0.2.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c8t2d0    /dev/rdsk/c8t2d0 disk     18  4/0/1/0/0.3.0  sdisk CLAIMED      DEVICE       SEAGATE ST173404LC                            /dev/dsk/c8t3d0    /dev/rdsk/c8t3d0 disk     19  4/0/6/0/0.1.0  sdisk CLAIMED      DEVICE       HP      DVD-ROM 305                            /dev/dsk/c9t1d0    /dev/rdsk/c9t1d0 

Many disks are connected to the Superdome complex that we could use as a boot device. We'll create a new nPartition, called sddev ,using cell5-6 and a boot device of the second disk in our earlier ioscan listing. The following parcreate commands create a new nPartition:

 #  parcreate -P sddev -c5:base:y:ri -c6:base:y:ri -b 0/0/1/0/0.1  Partition Created. The partition number is: 1 # 

The two cell boards are added with base ( base cell is the only valid type at this time,) y (which means that the cell will participate in the reboot), and ri (which is reactive with interleave which is the only valid value at this time). We left cell7 unused by not including it in sddev .

The second partition has now been created. All of our work has been done at the command line. cell7 was removed from the first partition and we created a second partition.



HP-UX 11i Systems Administration Handbook and Toolkit
HP-UX 11i Systems Administration Handbook and Toolkit (2nd Edition)
ISBN: 0131018833
EAN: 2147483647
Year: 2003
Pages: 301

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net