Static Routing and the RIP Redistribution Environment


Consider Figure 12.4, which depicts a routing environment in which some static routing and RIP routing is involved. Routers B1 and B2 and routers B1 and B3 are connected by WAN links over which no dynamic routing protocol is enabled. Routing for networks connected to routers B2 and B3, respectively, at router B1 is configured statically. B1, B4, and B5 are part of the RIP routing domain. B1 redistributes static routes to RIP for these routes to be visible throughout the RIP domain.

click to expand
Figure 12.4: Routing environment with no dynamic routing protocol enabled.

Table 12.4 : Router Configuration

Router

Relevant Part of Configuration

B1

interface Serial0

ip address 10.10.1.2 255.255.255.252

!

interface Serial1

ip address 10.10.2.1 255.255.255.252

!

interface Serial2

ip address 10.10.3.1 255.255.255.252

!

ip route 192.168.2.0 255.255.255.0 10.10.3.2

ip route 172.16.1.0 255.255.255.128 10.10.1.1

!

router rip

network 10.10.1.0

network 10.10.2.0

network 10.10.3.0

redistribute static metric 1

distribute-list 3 out Serial1

!

access-list 3 deny 172.16.1.0 0.0.0.255

access-list 3 deny 10.10.1.0 0.0.0.255

access-list 3 permit any

B2

interface Serial1

ip address 10.10.1.1 255.255.255.252

!

interface Ethernet0

ip address 172.16.1.1 255.255.255.128

!

ip route 0.0.0.0 0.0.0.0 Serial1

B3

interface Serial1

ip address 10.10.3.2 255.255.255.252

!

interface Ethernet0

ip address 192.168.2.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 Serial1

B4

interface Serial0

ip address 10.10.2.2 255.255.255.252

!

interface Ethernet1

ip address 192.168.4.2 255.255.255.0

!

interface Ethernet2

ip address 172.16.2.1 255.255.255.0

!

router rip

network 10.10.2.0

network 192.168.4.0

network 172.16.2.1

!

B5

interface Ethernet0

ip address 192.168.3.1 255.255.255.0

!

interface Ethernet1

ip address 192.168.4.1 255.255.255.0

!

router rip

network 192.168.4.0

network 192.168.3.0

!

In Figure 12.4, the users of the Accounts department at location A, which is connected to B5, are not able to connect to the ERP server at location B, which is connected to B2. The Accounts department LAN is 192.168.3.0/24 and the ERP server LAN is 172.16.1.0/25. To isolate and resolve this problem:

  1. Check if Layer-3 connectivity exists between two network segments by using the ping command, which confirms that connectivity is absent. This is shown in the output as:

    B5#ping 172.16.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)

  2. Check if the respective interfaces at B2 and B5 are up. The commands to check this are:

    B2#show ip interface brief B5#show ip interface brief

    This command output shows that both the interfaces are up.

  3. Check the presence of route 172.16.1.0/25 in the routing table of B5. The route is not available. This confirms the absence of the route in the RIP domain as shown:

    B5#show ip route 172.16.1.1 % Network not in table  
  4. Check the presence of the route in B1 where redistribution between static routes into RIP is configured. The commands for this are shown in Listing 12.14.

    Listing 12.14 Output of the show ip route 172.16.1.1 Command

    start example
    B1#show ip route 172.16.1.1 Routing entry for 203.200.177.96/28   Known via "static", distance 1, metric 0   Redistributing via rip   Routing Descriptor Blocks:   10.10.1.1       Route metric is 0, traffic share count is 1          
    end example

    Listing 12.14 proves the existence of a static route pointing to B2.

  5. Check the redistribution configuration for the presence of any route maps or filters, which might be preventing availability of the mentioned route in the RIP domain. The relevant part of the configuration is shown in Listing 12.15.

    Listing 12.15 Part of the Configuration to Check Route Maps

    start example
    router rip network 10.10.1.0 network 10.10.2.0 network 10.10.3.0 redistribute static metric 1 distribute-list 3 out Serial1 ! access-list 3 deny 172.16.1.0 0.0.0.255 access-list 3 deny 10.10.1.0 0.0.0.255 access-list 3 permit any
    end example

    In Listing 12.15, the bold code shows that there is an access list-based filter that is preventing redistribution of the static route corresponding to 172.16.1.0/25. Suitable modification of access list 3 should solve the problem. The access list is modified by issuing the command:

    B1(config)#no access-list 3 B1(config)#access-list 3 deny 10.10.1.0 0.0.0.255 B1(config)#access-list 3 permit any 

    The matching of subnet masks of major networks can also be a cause of the problem, because this is a case of redistribution into RIP, which is a classful routing protocol. The network that is not advertised in an RIP domain after getting redistributed is originally a Class B network.

  6. Check if RIP knows any other subnet mask of this network by using the show ip route | inc 172.16 command. The output of the command shows that there is another network available in the major network 172.16.0.0/16, that is, 172.16.2.0/24. This information is available with RIP. Therefore, it is not recognizing the network 171.16.1.0/25, which has a different subnet mask.

  7. Configure a static route of the network 172.16.1.0/24 at B1 instead of 172.16.1.0/25. The route will be propagated in the RIP domain. The commands issued are:

    B1(config)#no ip route 172.16.1.0 255.255.255.128 10.10.1.1 B1(config)#ip route 172.16.1.0 255.255.255.0 10.10.1.1




Cisco IP Routing Protocols(c) Trouble Shooting Techniques
Cisco IP Routing Protocols: Trouble Shooting Techniques (Charles River Media Networking/Security)
ISBN: 1584503416
EAN: 2147483647
Year: 2006
Pages: 130

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net