Configuration Example: Frame Relay


Note:

For more examples of Frame Relay configurations, I highly recommend Wendell Odom's book CCNA Self Study: CCNA ICND Exam Certification Guide, Cisco Press, ISBN 1-58720-083-x. In that book Odom has several different configurations setting up Frame Relay.


Figure 27-1 shows the network topology for the Frame Relay configuration that follows using the commands covered in this chapter.

Figure 27-1. Frame Relay Network


Note:

For this diagram I am using an Adtran Atlas 550 Device to simulate my Frame Relay cloud. I am using three physical ports (1/1, 2/1, and 2/2) to interconnect my three cities.


Edmonton Router

router>en

 

router#config t

 

router(config)#host Edmonton

Sets the host name

Edmonton(config)#no ip domain-lookup

Turns off DNS queries so that spelling mistakes will not slow you down

Edmonton(config)#enable secret cisco

Sets the encrypted password

Edmonton(config)#line con 0

 

Edmonton(config-line)#login

 

Edmonton(config-line)#password class

Sets console line password to class

Edmonton(config-line)#logging synchronous

Command being entered will be appended to a new line

Edmonton(config-line)#exit

 

Edmonton(config)#int fa 0/0

 

Edmonton(config-if)#ip address 192.168.20.1 255.255.255.0

Assigns IP address

Edmonton(config-if)#no shut

 

Edmonton(config-if)#int s 0/0

 

Edmonton(config-if)#encapsulation frame-relay

Turns on Frame Relay encapsulation

Edmonton(config-if)#no shut

 

Edmonton(config-if)#int s0/0.20 point-to-point

Creates subinterface 20

Edmonton(config-subif)#desc link to Winnipeg router DLCI 20

 

Edmonton(config-subif)#ip address 192.168.1.1 255.255.255.0

Assigns an IP address

Edmonton(config-subif)#frame-relay interface-dlci 20

Assigns a DLCI number

Edmonton(config-subif)#interface s 0/0.22

Creates subinterface 22

Edmonton(config-subif)#desc link to Calgary router DLCI 22

 

Edmonton(config-subif)#ip address 192.168.3.1 255.255.255.0

Assigns an IP address

Edmonton(config-subif)#frame-relay interface dlci 22

Assigns a DLCI number

Edmonton(config-subif)#exit

 

Edmonton(config-if)#exit

 

Edmonton(config)#router eigrp 100

Turns on the EIGRP routing process 100

Edmonton(config-router)#network 192.168.1.0

Advertises network 192.168.1.0, which connects to Winnipeg

Edmonton(config-router)#network 192.168.3.0

Advertises network 192.168.3.0, which connects to Calgary

Edmonton(config-router)#network 192.168.20.0

Advertises network 192.168.20.0, which is directly connected to local FA 0/interface

Edmonton(config-router)#

 

Edmonton#copy run start

Saves the configuration to NVRAM


Winnipeg Router

router>en

 

router#config t

 

router(config)#host Winnipeg

Sets the host name

Winnipeg(config)#no ip domain-lookup

Turns off DNS queries so that spelling mistakes will not slow you down

Winnipeg(config)#enable secret cisco

Sets the encrypted password to cisco

Winnipeg(config)#line con 0

 

Winnipeg(config-line)#login

 

Winnipeg(config-line)#password class

Sets the console line password to class

Winnipeg(config-line)#logging synchronous

Command being entered will be appended to a new line

Winnipeg(config-line)#exit

 

Winnipeg(config)#int fa 0/0

 

Winnipeg(config-if)#ip address 192.168.30.1 255.255.255.0

Assigns an IP address

Winnipeg(config-if)#no shut

 

Winnipeg(config-if)#int s 0/0

 

Winnipeg(config-if)#encapsulation frame-relay

Turns on Frame Relay encapsulation

Winnipeg(config-if)#no shut

 

Winnipeg(config-if)#int s0/0.30 point-to-point

Creates subinterface 30

Winnipeg(config-subif)#desc link to Edmonton router DLCI 30

 

Winnipeg(config-subif)#ip address 192.168.1.2 255.255.255.0

Assigns an IP address

Winnipeg(config-subif)#frame-relay interface-dlci 30

Assigns a DLCI number

Winnipeg(config-subif)#interface s 0/0.31

Creates subinterface 31

Winnipeg(config-subif)#desc link to Calgary router DLCI 31

 

Winnipeg(config-subif)#ip address 192.168.4.2 255.255.255.0

Assigns an IP address

Winnipeg(config-subif)#frame-relay interface-dlci 31

Assigns a DLCI number

Winnipeg(config-subif)#exit

 

Winnipeg(config-if)#exit

 

Winnipeg(config)#router eigrp 100

Turns on EIGRP routing process 100

Winnipeg(config-router)#network 192.168.1.0

Advertises network 192.168.1.0 (to Winnipeg)

Winnipeg(config-router)#network 192.168.4.0

Advertises network 192.168.4.0 (to Calgary)

Winnipeg(config-router)#network 192.168.30.0

Advertises network 192.168.30.0 directly connected to FA 0/0

Winnipeg(config-router)#

 

Winnipeg#copy run start

Saves the configuration to NVRAM


Calgary Router

router>en

 

router#config t

 

router(config)#host Calgary

Sets the host name

Calgary(config)#no ip domain-lookup

Turns off DNS queries so that spelling mistakes will not slow you down

Calgary(config)#enable secret cisco

Sets the encrypted password to cisco

Calgary(config)#line con 0

 

Calgary(config-line)#login

 

Calgary(config-line)#password class

Sets the console line password to class

Calgary(config-line)#logging synchronous

Command being entered will be appended to a new line

Calgary(config-line)#exit

 

Calgary(config)#int fa 0/0

 

Calgary(config-if)#ip address 192.168.40.1 255.255.255.0

Assigns an IP address

Calgary(config-if)#no shut

 

Calgary(config-if)#int s 0/0

 

Calgary(config-if)#encapsulation frame-relay

Turns on Frame Relay encapsulation

Calgary(config-if)#no shut

 

Calgary(config-if)#int s0/0.40 point-to-point

Creates subinterface 40

Calgary(config-subif)#desc link to Edmonton router DLCI 40

 

Calgary(config-subif)#ip address 192.168.3.2 255.255.255.0

Assigns an IP address

Calgary(config-subif)#frame-relay interface-dlci 40

Assigns a DLCI number

Calgary(config-subif)#interface s 0/0.41

Creates subinterface 41

Calgary(config-subif)#desc link to Winnipeg router DLCI 41

 

Calgary(config-subif)#ip address 192.168.4.1 255.255.255.0

Assigns an IP address

Calgary(config-subif)#frame-relay interface-dlci 41

Assigns a DLCI number

Calgary(config-subif)#exit

 

Calgary(config-if)#exit

 

Calgary(config)#router eigrp 100

Turns on EIGRP routing process 100

Calgary(config-router)#network 192.168.3.0

Advertises the network to Winnipeg

Calgary(config-router)#network 192.168.4.0

Advertises the network to Calgary

Calgary(config-router)#network 192.168.40.0

Advertises the local FA 0/0 network

Calgary(config-router)#

 

Calgary#copy run start

Saves the configuration to NVRAM





CCNA Self-Study(c) CCNA Portable Command Guide
CCNA Portable Command Guide
ISBN: 1587201585
EAN: 2147483647
Year: 2006
Pages: 261
Authors: Scott Empson

Similar book on Amazon

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net