Appendix A. Complete Configuration Example


Figure A-1 shows the network topology for the complete configuration that follows.

Figure A-1. Network Topology for Configuration Example


Rama Switch

 

switch>en

Enters privileged mode

switch#config t

Enters global config mode

switch(config)#no ip domain-lookup

Turns off DNS queries so that spelling mistakes won't slow you down

switch(config)#hostname 2950-Rama

Sets hostname

2950-Rama(config)#enable secret cisco

Sets encrypted secret password

2950-Rama(config)#line con 0

Enters line console mode

2950-Rama(config-line)#logging synchronous

Appends commands to new line so that router information won't interrupt

2950-Rama(config-line)#login

User must log in to console before use

2950-Rama(config-line)#password rooster

Sets password to rooster

2950-Rama(config-line)#exec-timeout 0 0

Console will never log out. Note that this is a security risk in a production environment

2950-Rama(config-line)#exit

Moves back to global config mode

2950-Rama(config)#line aux 0

Moves to line auxiliary mode

2950-Rama(config-line)#login

User must log in to auxiliary port before use

2950-Rama(config-line)#password crows

Sets password to crows

2950-Rama(config-line)#exit

Moves back to global config mode

2950-Rama(config)#line vty 0 15

Moves to configure all 16 vty ports at same time

2950-Rama(config-line)#login

User must log in to vty port before use

2950-Rama(config-line)#password midnight

Sets password to midnight

2950-Rama(config-line)#exit

Exits back to global config mode

2950-Rama(config)#ip default-gateway 10.10.10.1

Sets default gateway

2950-Rama(config)#int vlan 1

Moves to virtual interface VLAN1

2950-Rama(config-if)#ip add 10.10.10.2 255.255.255.0

Sets IP address for switch

2950-Rama(config-if)#no shut

Turns virtual interface on

2950-Rama(config-if)#int fa 0/1

Moves to interface fa 0/1

2950-Rama(config-if)#desc Link to Router

Sets local description

2950-Rama(config-if)#int fa 0/6

Moves to interface fa 0/6

2950-Rama(config-if)#desc Access Link to Client Workstation

Sets local description

2950-Rama(config-if)#switchport port-security

Activates port security

2950-Rama(config-if)#switchport port-security maximum 1

Specifies that only one MAC address will be allowed in the MAC table

2950-Rama(config-if)#switchport port-security violation shutdown

Sets port to be turned off if more than one MAC address is reported

2950-Rama(config-if)#exit

Exits back to global config mode

2950-Rama(config)#exit

Returns to privileged mode

2950-Rama#copy run start

Saves config to NVRAM

  

Rama Router

 
  

Router>en

Enters privileged mode

Router#clock set 10:30:00 15 Nov 2005

Sets local time on router

Router#config t

Enters global config mode

Router(config)#hostname Rama

Sets router name to Rama

Rama(config)#no ip domain-lookup

Turns off DNS queries on unrecognized commands (spelling mistakes)

Rama(config)#banner motd # This is the Rama Router. Authorized Access Only #

Creates an MOTD banner

Rama(config)#clock timezone CST 6

Sets time zone to Central Standard Time (6 hours behind UTC)

Rama(config)#enable secret cisco

Enable secret password set to cisco

Rama(config)#service password-encryption

Sets passwords to have weak encryption

Rama(config)#line con 0

Enters line console mode

Rama(config-line)#logging sync

Commands won't be interrupted by unsolicited messages

Rama(config-line)#password rooster

Sets password to rooster

Rama(config-line)#login

Enables password checking at login

Rama(config-line)#exec-timeout 0 0

Console will never log out. Note that this is a security risk in a production environment

Rama(config-line)#line aux 0

Moves to line auxiliary mode

Rama(config-line)#password crows

Sets password to crows

Rama(config-line)#login

Enables password checking at login

Rama(config-line)#line vty 0 4

Moves to virtual lines zero through four

Rama(config-line)#password midnight

Sets password to midnight

Rama(config-line)#login

Enables password checking at login

Rama(config-line)#exit

Moves back to global config mode

Rama(config)#int fa0/0

Moves to FastEthernet 0/0

Rama(config-if)#desc Local LAN

Sets locally significant description of the interface

Rama(config-if)#ip address 10.10.10.1 255.255.255.0

Assigns IP address and subnet mask to interface

Rama(config-if)#ip nat inside

Sets location of private inside addresses

Rama(config-if)#no shut

Turns on interface

Rama(config-if)#int s0/1

Moves directly to Serial 0/1

Rama(config-if)#desc Primary Link to Buchanan Router

Sets locally significant description of the interface

Rama(config-if)#ip address 192.168.100.2 255.255.255.252

Assigns IP address and subnet mask to interface

Rama(config-if)#encapsulation frame-relay

Turns on Frame Relay encapsulation

Rama(config-if)#frame-relay map ip 192.168.100.1 301 broadcast

Maps remote IP to local DLCI number, and carries broadcast traffic

Rama(config-if)#ip nat outside

Sets location of public outside addresses

Rama(config-if)#backup interface bri0/0

Makes ISDN a backup to Frame Relay in event of failure

Rama(config-if)#backup delay 6 8

Sets ISDN to take over 6 seconds after S0/0 failure and go down 8 seconds after S0/0 comes back up

Rama(config-if)#no shut

Turns on interface

Rama(config-if)#exit

Moves back to global config mode

Rama(config)#isdn switch-type basic-ni

Sets ISDN switch-type

Rama(config)#username Buchanan password talktome

Sets the local username and password for authentication of a PPP peer

Rama(config)#dialer-list 1 protocol ip permit

Defines interesting traffic that will trigger an ISDN call

Rama(config)#interface bri0/0

Moves to BRI Interface mode

Rama(config-if)#desc Backup Link to Buchanan Router

Sets locally significant description of the interface

Rama(config-if)#ip address 192.168.100.6 255.255.255.252

Assigns IP address and subnet mask to interface

Rama(config-if)#encapsulation ppp

Turns on PPP encapsulation

Rama(config-if)#ppp authentication chap

Turns on CHAP authentication

Rama(config-if)#isdn spid1 30655550000001 5555000

Assigns SPID for channel B1

Rama(config-if)#isdn spid 2 30655550010001 5555001

Assigns SPID for channel B2

Rama(config-if)#dialer map ip 192.168.100.5 name Buchanan broadcast 5554000

Sets map to find remote router

Rama(config-if)#dialer idle-timeout 60

Sets interface to disconnect after 60 seconds of no traffic

Rama(config-if)#dialer-group 1

Assigns traffic filtered by dialer-list 1 to this group

Rama(config-if)#ip nat outside

Sets location of public outside addresses

Rama(config-if)#exit

Returns to global config mode

Rama(config)#access-list 1 permit 10.10.10.0 0.0.0.255

Defines which addresses will be allowed to be translated with NAT

Rama(config)#ip nat pool rama 199.85.32.1 199.85.32.14 netmask 255.255.255.240

Creates a pool of public addresses that will be used for NAT

Rama(config)#ip nat inside source list 1 pool rama overload

Creates NAT by combining Access List 1 with pool of public addresses called rama. PAT (Overloading) will take place

Rama(config)#service dhcp

Verifies that router can use DHCP services and that DHCP is enabled

Rama(config)#ip dhcp pool 10network

Creates a DHCP pool called 10network for the 10.10.10.0 network

Rama(dhcp-config)#network 10.10.10.0 255.255.255.0

Defines range of addresses to be leased

Rama(dhcp-config)#default-router 10.0.0.1

Defines address of default router for clients

Rama(dhcp-config)#netbios-name-server 10.0.0.5

Defines address of NetBIOS server for clients

Rama(dhcp-config)#dns-server 10.0.0.6

Defines address of DNS server for clients

Rama(dhcp-config)#domain-name example.com

Defines domain name for clients

Rama(dhcp-config)#lease 12 14 30

Sets lease time to be 12 days, 14 hours, 30 minutes

Rama(dhcp-config)#exit

Returns to global config mode

Rama(config)#ip dhcp excluded addresses 10.0.0.1 10.0.0.10

Specifies range of addresses not to be leased out to clients

Rama(config)#ip host Buchanan 192.168.100.1 192.168.100.5

Sets a local host name resolution to IP address 192.168.100.1 or 192.168.100.5

Rama(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.1

Defines that all traffic not in local table will be routed to address 192.168.100.1 (across Frame Relay Link)

Rama(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.5 225

Creates a floating static route to send traffic across ISDN link if Frame Relay network goes down

Rama(config)#exit

Moves back to privileged mode

Rama#copy run start

Saves config to NVRAM

  

Buchanan Router

 
  

Router>en

Enters privileged mode

Router#clock set 10:45:00 15 Nov 2005

Sets local time on router

Router#config t

Enters global config mode

Router(config)#hostname Buchanan

Sets router name to Buchanan

Buchanan(config)#no ip domain-lookup

Turns off DNS queries on unrecognized commands (spelling mistakes)

Buchanan(config)#banner motd # This is the Buchanan Router. Authorized Access Only #

Creates an MOTD banner

Buchanan(config)#clock timezone CST 6

Sets time zone to Central Standard Time (6 hours behind UTC)

Buchanan(config)#enable secret cisco

Enables secret password set to cisco

Buchanan(config)#service password-encryption

Sets passwords to have weak encryption

Buchanan(config)#line con 0

Enters line console mode

Buchanan(config-line)#logging sync

Sets commands to be appended to a new line

Buchanan(config-line)#password rooster

Sets password to rooster

Buchanan(config-line)#login

Enables password checking at login

Buchanan(config-line)#exec-timeout 0 0

Console will never log out. Note that this is a security risk in a production environment

Buchanan(config-line)#line aux 0

Moves to line auxiliary mode

Buchanan(config-line)#password crows

Sets password to crows

Buchanan(config-line)#login

Enables password checking at login

Buchanan(config-line)#line vty 0 4

Moves to vty zero through four

Buchanan(config-line)#password midnight

Sets password to midnight

Buchanan(config-line)#login

Enables password checking at login

Buchanan(config-line)#exit

Moves back to global config mode

Buchanan(config)#int s0/1

Moves to S0/0 mode

Buchanan(config-if)#desc Primary Link to Rama Router

Sets locally significant description of the interface

Buchanan(config-if)#ip address 192.168.100.1 255.255.255.252

Assigns IP address and subnet mask to interface

Buchanan(config-if)#encapsulation frame-relay

Turns on Frame Relay encapsulation

Buchanan(config-if)#frame-relay map ip 192.168.100.2 201 broadcast

Maps remote IP to local DLCI number

Buchanan(config-if)#backup interface bri0/0

Designates ISDN as a backup interface to Frame Relay in event of failure

Buchanan(config-if)#backup delay 6 8

Sets ISDN to take over 6 seconds after S0/0 failure and goes down 8 seconds after S0/0 comes back up

Buchanan(config-if)#no shut

Turns on interface

Buchanan(config-if)#exit

Moves back to global config mode

Buchanan(config)#isdn switch-type basic-ni

Sets ISDN switch type

Buchanan(config)#username Rama password talktome

Sets the local username and password for authentication of a PPP peer

Buchanan(config)#dialer-list 1 protocol ip permit

Defines interesting traffic that will trigger an ISDN call

Buchanan(config)#interface bri0/0

Moves to BRI mode

Buchanan(config-if)#desc Backup Link to Rama Router

Sets locally significant description of the interface

Buchanan(config-if)#ip address 192.168.100.5 255.255.255.252

Assigns IP address and subnet mask to interface

Buchanan(config-if)#encapsulation ppp

Turns on PPP encapsulation

Buchanan(config-if)#ppp authentication chap

Turns on CHAP authentication

Buchanan(config-if)#isdn spid1 30655540000001 5554000

Assigns SPID for channel B1

Buchanan(config-if)#isdn spid 2 30655540010001 5554001

Assigns SPID for channel B2

Buchanan(config-if)#dialer map ip 192.168.100.6 name Rama broadcast 5555000

Sets map to find remote router

Buchanan(config-if)#dialer idle-timeout 60

Sets interface to disconnect after 60 seconds of no traffic

Buchanan(config-if)#dialer-group 1

Assigns traffic filtered by dialer-list 1 to this group

Buchanan(config-if)#exit

Returns to global config mode

Buchanan(config)#interface fa0/0

Moves to interface fa 0/0

Buchanan(config-if)#full duplex

Sets duplex to full duplex mode

Buchanan(config-if)#no shut

Turns on interface

Buchanan(config-if)#interface fa0/0.1

Creates a subinterface

Buchanan(config-subif)#description Management VLAN 1

Assigns a local description

Buchanan(config-subif)#encapsulation dot1q 1 native

Enables dot1q encapsulation with VLAN 1 as the native VLAN

Buchanan(config-subif)#ip add 172.16.1.1 255.255.255.0

Assigns IP address

Buchanan(config-if)#interface fa0/0.10

Creates a subinterface

Buchanan(config-subif)#description Accounting VLAN 10

Assigns a local description

Buchanan(config-subif)#encapsulation dot1q 10

Enables dot1q encapsulation on VLAN 10

Buchanan(config-subif)#ip add 172.16.10.1 255.255.255.0

Assigns IP address

Buchanan(config-if)#interface fa0/0.20

Creates a subinterface

Buchanan(config-subif)#description Sales VLAN 20

Assigns a local description

Buchanan(config-subif)#encapsulation dot1q 20

Enables dot1q encapsulation on VLAN 20

Buchanan(config-subif)#ip add 172.16.20.1 255.255.255.0

Assigns IP address

Buchanan(config-subif)#exit

Returns to global config mode

Buchanan(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.2

Defines that all traffic not in local table be routed to address 192.168.100.2 (across Frame Relay link)

Buchanan(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.6 225

Creates a floating static route to send traffic across ISDN Link if Frame Relay network goes down

Buchanan(config)#ip host Rama 192.168.100.2

Sets a local host name resolution to IP address 192.168.100.2

Buchanan(config)#ip host 2950Core 172.16.1.2

Sets a local host name resolution to IP address 172.16.1.2

Buchanan(config)#ip host 2950-A 172.16.1.3

Sets a local host name resolution to IP address 172.16.1.3

Buchanan(config)#ip host 2950-B 172.16.1.4

Sets a local host name resolution to IP address 172.16.1.4

Buchanan(config)#exit

Returns to privileged mode

Buchanan#copy run start

Saves config to NVRAM

  

Buchanan Core Switch

 
  

switch>en

Enters privileged mode

switch#config t

Enters global config mode

switch(config)#no ip domain-lookup

Turns off DNS queries so that spelling mistakes won't slow you down

switch(config)#hostname 2950Core

Sets hostname

2950Core(config)#enable secret cisco

Sets encrypted secret password

2950Core(config)#line con 0

Enters line console mode

2950Core(config-line)#logging synchronous

Appends commands to new line so that router information won't interrupt

2950Core(config-line)#login

Defines that the user must log in to console before use

2950Core(config-line)#password rooster

Sets password to rooster

2950Core(config-line)#exec-timeout 0 0

Console will never log out. Note that this is a security risk in a production environment

2950Core(config-line)#exit

Moves back to global config mode

2950Core(config)#line aux 0

Moves to line auxiliary mode

2950Core(config-line)#login

Defines that the user must log in to auxiliary port before use

2950Core(config-line)#password crows

Sets password to crows

2950Core(config-line)#exit

Moves back to global config mode

2950Core(config)#line vty 0 15

Moves to configure all 16 vty ports at same time

2950Core(config-line)#login

Defines that the user must log in to vty port before use

2950Core(config-line)#password midnight

Sets password to midnight

2950Core(config-line)#exit

Returns to global config mode

2950Core(config)#ip default-gateway 172.16.1.1

Sets default gateway

2950Core(config)#int vlan 1

Moves to virtual interface VLAN1

2950Core(config-if)#ip add 172.16.1.2 255.255.255.0

Sets IP address for switch

2950Core(config-if)#no shut

Turns virtual interface on

2950Core(config-if)#exit

Back to global config mode

2950Core(config)#vlan 10

Creates VLAN 10 and enters VLAN config mode for further definitions

2950Core(config-vlan)#name Accounting

Assigns name to VLAN

2950Core(config-vlan)#exit

Returns to global config mode

2950Core(config)#vlan 20

Creates VLAN 20

2950Core(config-vlan)#name Sales

Assigns name to VLAN

2950Core(config-vlan)#exit

Returns to global config mode

2950Core(config)#vtp mode server

Changes switch to VTP server mode

2950Core(config)#vtp domain simulation

Sets name of VTP management domain to simulation

2950Core(config)#interface fa0/1

Moves to fa 0/1 interface mode

2950Core(config-if)#desc Trunk link to router

Creates local description

2950Core(config-if)#switchport mode trunk

Turns port to trunking mode

2950Core(config-if)#interface fa0/24

Moves to fa 0/24 interface mode

2950Core(config-if)#desc Trunk link to 2950-B

Creates local description

2950Core(config-if)#switchport mode trunk

Turns port to trunking mode

2950Core(config-if)#interface fa0/23

Moves to fa 0/23 interface mode

2950Core(config-if)#desc Trunk link to 2950-A and member of EtherChannel Group 1

Creates local description

2950Core(config-if)#switchport mode trunk

Turns port to trunking mode

2950Core(config-if)#channel-group 1 mode on

Creates an EtherChannel group number 1. All other members of this group must have same number

2950Core(config-if)#interface fa0/22

Moves to fa 0/22 interface mode

2950Core(config-if)#desc Trunk link to 2950-A and member of EtherChannel Group 1

Creates local description

2950Core(config-if)#switchport mode trunk

Turns port to trunking mode

2950Core(config-if)#channel-group 1 mode on

Creates an EtherChannel group number 1

2950Core(config-if)#exit

Moves back to global config mode

2950Core(config)#exit

Returns to privileged mode

2950Core#spanning-tree vlan 1 root

Changes this switch to the root switch in VLAN 1

2950Core#spanning-tree vlan 10 root

Changes this switch to the root switch in VLAN 10

2950Core#spanning-tree vlan 20 root

Changes this switch to the root switch in VLAN 20

2950Core#copy run start

Saves config to NVRAM

  

Buchanan Switch 2950-A

 
  

switch>en

Enters privileged mode

switch#config t

Enters global config mode

switch(config)#no ip domain-lookup

Turns off DNS queries so that spelling mistakes won't slow you down

switch(config)#hostname 2950-A

Sets hostname

2950-A(config)#enable secret cisco

Sets encrypted secret password

2950-A(config)#line con 0

Enters line console mode

2950-A(config-line)#logging synchronous

Appends commands to new line so that router information won't interrupt

2950-A(config-line)#login

Defines that the user must log in to console before use

2950-A(config-line)#password rooster

Sets password to rooster

2950-A(config-line)#exec-timeout 0 0

Console will never log out. Note that this is a security risk in a production environment

2950-A(config-line)#exit

Moves back to global config mode

2950-A(config)#line aux 0

Moves to line auxiliary mode

2950-A(config-line)#login

Defines that the user must log in to auxiliary port before use

2950-A(config-line)#password crows

Sets password to crows

2950-A(config-line)#exit

Moves back to global config mode

2950-A(config)#line vty 0 15

Moves to configure all 16 vty ports at same time

2950-A(config-line)#login

Defines that the user must log in to vty port before use

2950-A(config-line)#password midnight

Sets password to midnight

2950-A(config-line)#exit

Returns to global config mode

2950-A(config)#ip default-gateway 172.16.1.1

Sets default gateway

2950-A(config)#int vlan 1

Moves to virtual interface VLAN1

2950-A(config-if)#ip add 172.16.1.3 255.255.255.0

Sets IP address for switch

2950-A(config-if)#no shut

Turns virtual interface on

2950-A(config-if)#exit

Returns to global config mode

2950-A(config)#vtp mode client

Changes switch to VTP client mode. VLAN information will now be copied from 2950Core switch

2950-A(config)#vtp domain simulation

Sets name of VTP management domain to simulation

2950-A(config)#int fa0/1

Moves to interface fa 0/1

2950-A(config-if)#desc Trunk Link to 2950-B

Creates local description

2950-A(config-if)#switchport mode trunk

Turns port to trunking mode

2950-A(config-if)#interface fa0/23

Moves to fa 0/23 interface mode

2950-A(config-if)#desc Trunk link to 2950Core and member of EtherChannel Group 1

Creates local description

2950-A(config-if)#switchport mode trunk

Turns port to trunking mode

2950-A(config-if)#channel-group 1 mode on

Creates an EtherChannel group number 1. All other members of this group must have same number

2950-A(config-if)#interface fa0/22

Moves to fa 0/22 interface mode

2950-A(config-if)#desc Trunk link to 2950Core and member of EtherChannel Group 1

Creates local description

2950-A(config-if)#switchport mode trunk

Turns port to trunking mode

2950-A(config-if)#channel-group 1 mode on

Creates an EtherChannel group number 1

2950-A(config-if)#exit

Moves back to global config mode

2950-A(config)#int fa0/6

Moves to fa 0/6 interface mode

2950-A(config)#desc Link to VLAN 10 Client Workstation

Creates local description

2950-A(config-if)#switchport mode access

Makes port a VLAN access port

2950-A(config-if)#switchport access vlan 10

Statically assigns this port to VLAN 10

2950-A(config-if)#spanning-tree portfast

Transitions the port directly to Forwarding state in Spanning Tree Protocol (STP)

2950-A(config)#int fa0/13

Moves to fa 0/13 interface mode

2950-A(config)#desc Link to VLAN 20 Client Workstation

Creates local description

2950-A(config-if)#switchport mode access

Makes port a VLAN access port

2950-A(config-if)#switchport access vlan 20

Statically assigns this port to VLAN 20

2950-A(config-if)#spanning-tree portfast

Transitions the port directly to Forwarding state in STP

2950-A(config-if)#

Moves directly to privileged mode

2950-A#copy run start

Saves config into NVRAM

  

Buchanan Switch 2950-B

 
  

switch>en

Enters privileged mode

switch#config t

Enters global config mode

switch(config)#no ip domain-lookup

Turns off DNS queries so that spelling mistakes won't slow you down

switch(config)#hostname 2950-B

Sets hostname

2950-B(config)#enable secret cisco

Sets encrypted secret password

2950-B(config)#line con 0

Enters line console mode

2950-B(config-line)#logging synchronous

Appends commands to new line so that router information won't interrupt

2950-B(config-line)#login

Defines that the user must log in to console before use

2950-B(config-line)#password rooster

Sets password to rooster

2950-B(config-line)#exec-timeout 0 0

Console will never log out. Note that this is a security risk in a production environment

2950-B(config-line)#exit

Moves back to global config mode

2950-B(config)#line aux 0

Moves to line auxiliary mode

2950-B(config-line)#login

Defines that the user must log in to auxiliary port before use

2950-B(config-line)#password crows

Sets password to crows

2950-B(config-line)#exit

Moves back to global config mode

2950-B(config)#line vty 0 15

Moves to configure all 16 vty ports at same time

2950-B(config-line)#login

Defines that the user must log in to vty port before use

2950-B(config-line)#password midnight

Sets password to midnight

2950-B(config-line)#exit

Returns to global config mode

2950-B(config)#ip default-gateway 172.16.1.1

Sets default gateway

2950-B(config)#int vlan 1

Moves to virtual interface VLAN 1

2950-B(config-if)#ip add 172.16.1.4 255.255.255.0

Sets IP address for switch

2950-B(config-if)#no shut

Turns virtual interface on

2950-B(config-if)#exit

Returns to global config mode

2950-B(config)#vtp mode client

Changes switch to VTP client mode. VLAN information will now be copied from 2950Core switch

2950-B(config)#vtp domain simulation

Sets name of VTP management domain to simulation

2950-B(config)#int fa0/1

Moves to interface fa 0/1

2950-B(config-if)#desc Trunk Link to 2950-A

Creates local description

2950-B(config-if)#switchport mode trunk

Turns port to trunking mode

2950-B(config-if)#interface fa0/24

Moves to fa 0/23 interface mode

2950-B(config-if)#desc Trunk link to 2950Core

Creates local description

2950-B(config-if)#switchport mode trunk

Turns port to trunking mode

2950-B(config-if)#exit

Moves back to global config mode

2950-B(config)#int fa0/6

Moves to fa 0/6 interface mode

2950-B(config)#desc Link to VLAN 10 Client Workstation

Creates local description

2950-B(config-if)#switchport mode access

Makes port a VLAN access port

2950-B(config-if)#switchport access vlan 10

Statically assigns this port to VLAN 10

2950-B(config-if)#spanning-tree portfast

Transitions the port directly to Forwarding state in STP

2950-B(config)#int fa0/13

Moves to fa 0/13 interface mode

2950-B(config)#desc Link to VLAN 20 Client Workstation

Creates local description

2950-B(config-if)#switchport mode access

Makes port a VLAN access port

2950-B(config-if)#switchport access vlan 20

Statically assigns this port to VLAN 20

2950-B(config-if)#spanning-tree portfast

Transitions the port directly to Forwarding state in STP

2950-B(config-if)#end

Moves directly to privileged mode

2950-B#copy run start

Saves config into NVRAM





CCNA Self-Study(c) CCNA Portable Command Guide
CCNA Portable Command Guide
ISBN: 1587201585
EAN: 2147483647
Year: 2006
Pages: 261
Authors: Scott Empson

Similar book on Amazon

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net