Configuration Example: DHCP


Figure 24-1. DHCP Configuration


Edmonton Router

 

router>en

 

router#config t

 

router(config)#host Edmonton

Sets hostname

Edmonton(config)#no ip domain-lookup

Turns off DNS resolution to avoid wait time due to DNS lookup of spelling errors

Edmonton(config)#enable secret peace

Sets encrypted password to peace

Edmonton(config)#line con 0

 

Edmonton(config-line)#login

 

Edmonton(config-line)#password class

Sets console line password to class

Edmonton(config-line)#logging synchronous

Sets commands to be appended to a new line

Edmonton(config-line)#exit

 

Edmonton(config)#int fa 0/0

 

Edmonton(config-if)#desc LAN Interface

Sets local description of interface

Edmonton(config-if)#ip address 10.0.0.1 255.0.0.0

Assigns IP address

Edmonton(config-if)#no shut

Turns on interface

Edmonton(config-if)#int serial 0/0

 

Edmonton(config-if)#desc Link to Gibbons Router

Sets local description of interface

Edmonton(config-if)#ip address 192.168.1.2 255.255.255.0

Assigns IP address

Edmonton(config-if)#clockrate 56000

Assigns clock rate to DCE cable on this side of link

Edmonton(config-if)#no shut

Turns on interface

Edmonton(config-if)#exit

 

Edmonton(config)#router rip

Enables RIP routing process

Edmonton(config-router)#version 2

Turns on Version 2

Edmonton(config-router)#network 10.0.0.0

Advertises 10.0.0.0 network

Edmonton(config-router)#network 192.168.1.0

Advertises 192.168.1.0 network

Edmonton(config-router)#exit

 

Edmonton(config)#service dhcp

Verifies that router can use DHCP services and that DHCP is enabled

Edmonton(config)#ip dhcp pool 10network

Creates a DHCP pool called 10network

Edmonton(dhcp-config)#network 10.0.0.0 255.0.0.0

Defines a range of addresses to be leased

Edmonton(dhcp-config)#default-router 10.0.0.1

Defines address of default router for clients

Edmonton(dhcp-config)#netbios-name-server 10.0.0.2

Defines address of NetBIOS WINS server for clients

Edmonton(dhcp-config)#dns-server 10.0.0.3

Defines address of DNS server for clients

Edmonton(dhcp-config)#domain-name pretenddomain.com

Defines domain name for clients

Edmonton(dhcp-config)#lease 12 14 30

Sets lease time to be 12 days, 14 hours, 30 minutes

Edmonton(dhcp-config)#exit

 

Edmonton(config)#ip dhcp excluded-addresses 10.0.0.1 10.0.0.5

Specifies range of addresses not to be leased out to clients

Edmonton(config)#ip dhcp pool 192.168.3network

Creates a DHCP pool called 192.168.3network

Edmonton(dhcp-config)#network 192.168.3.0 255.255.255.0

Defines a range of addresses to be leased

Edmonton(dhcp-config)#default-router 192.168.3.1

Defines address of default router for clients

Edmonton(dhcp-config)#netbios-name-server 10.0.0.2

Defines address of NetBIOS server for clients

Edmonton(dhcp-config)#dns-server 10.0.0.3

Defines address of DNS server for clients

Edmonton(dhcp-config)#domain-name pretenddomain.com

Defines domain name for clients

Edmonton(dhcp-config)#lease 12 14 30

Sets lease time to be 12 days, 14 hours, 30 minutes

Edmonton(dhcp-config)#exit

 

Edmonton(config)#exit

 

Edmonton#copy run start

Saves config to NVRAM

  

Gibbons Router

 

router>en

 

router#config t

 

router(config)#host Gibbons

Sets hostname

Gibbons(config)#no ip domain-lookup

Turns off DNS resolution to avoid wait time due to DNS lookup of spelling errors

Gibbons(config)#enable secret love

Sets encrypted password to love

Gibbons(config)#line con 0

 

Gibbons(config-line)#login

 

Gibbons(config-line)#password class

Sets console line password to class

Gibbons(config-line)#logging synchronous

Sets commands to be appended to a new line

Gibbons(config-line)#exit

 

Gibbons(config)#int fa 0/0

 

Gibbons(config-if)#desc LAN Interface

Sets local description of interface

Gibbons(config-if)#ip address 192.168.3.1 255.255.255.0

Assigns IP address

Gibbons(config-if)#ip helper-address 192.168.1.2

Defines that UDP broadcasts will be forwarded to this address rather than be dropped

Gibbons(config-if)#no shut

Turns on interface

Gibbons(config-if)#int serial 0/1

 

Gibbons(config-if)#desc Link to Edmonton Router

Sets local description of interface

Gibbons(config-if)#ip address 192.168.1.1 255.255.255.0

Assigns IP address

Gibbons(config-if)#no shut

Turns on interface

Gibbons(config-if)#exit

 

Gibbons(config)#router rip

Enables RIP routing process

Gibbons(config-router)#version 2

Turns on Version 2

Gibbons(config-router)#network 192.168.3.0

Advertises 192.168.3.0 network

Gibbons(config-router)#network 192.168.1.0

Advertises 192.168.1.0 network

Gibbons(config-router)#exit

 

Gibbons(config)#exit

 

Gibbons#copy run start

Saves config to NVRAM





CCNA Self-Study(c) CCNA Portable Command Guide
CCNA Portable Command Guide
ISBN: 1587201585
EAN: 2147483647
Year: 2006
Pages: 261
Authors: Scott Empson

Similar book on Amazon

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net