EIGRP and OSPF Redistribution Environment


Consider Figure 12.1, which shows a redistribution environment. Here, part of a network is shown that has both EIGRP and OSPF routing protocols. Routers B2, B3, and B4 are running EIGRP exclusively. Routers B5, B6, and B7 are running OSPF only. Router A1 is running both routing protocols, OSPF and EIGRP, and is redistributing between these protocols.

click to expand
Figure 12.1: Redistribution scenario with routing protocols EIGRP and OSPF.

Table 12.1: Router Configurations

Router

Relevant Part of Configuration

B1

interface Serial0

ip address 10.10.2.1 255.255.255.252

!

interface Serial1

ip address 10.10.3.2 255.255.255.252

!

interface Serial2

ip address 10.10.4.1 255.255.255.252

!

router eigrp 100

network 10.10.2.0

network 10.10.3.0

redistribute ospf 1 route-map redis-1

!

router ospf 1

network 10.10.4.0 0.0.0.255 area

redistribute eigrp 100 metric 1000

!

route-map redis 10 permit 10

match ip address 15

set metric 10000 100 255 1 1000

!

access-list 15 permit 192.168.40.0

access-list 15 permit 10.10.0.0 0.0.0.255

!

B2

interface Serial0

ip address 10.10.1.1 255.255.255.252

!

interface Serial1

ip address 10.10.3.1 255.255.255.252

!

interface Ethernet1

ip address 192.168.30.1 255.255.255.224

!

router eigrp 100

network 10.10.1.0

network 10.10.3.0

network 192.168.30.0

!

B3

interface Serial0

ip address 10.10.1.2 255.255.255.252

!

router eigrp 100

network 10.10.1.0

!

B4

interface Serial0

ip address 10.10.2.2 255.255.255.252

!

interface Ethernet1

ip address 192.168.20.1 255.255.255.252

!

router eigrp 100

network 10.10.2.0

network 192.168.20.0

!

B5

interface Serial0

ip address 10.10.4.2 255.255.255.252

!

interface Ethernet1

ip address 192.168.45.1 255.255.255.0

!

router ospf 1

network 10.10.4.0 0.0.0.255 area 0

network 192.168.45.0 0.0.0.255 area 0

!

B6

interface Serial0

ip address 10.10.5.1 255.255.255.252

!

interface Ethernet1

ip address 192.168.45.2 255.255.255.0

!

interface Ethernet2

ip address 192.168.50.1 255.255.255.0

!

router ospf 1

network 10.10.5.0 0.0.0.255 area 0

network 192.168.45.0 0.0.0.255 area 0

network 192.168.50.0 0.0.0.255 area 0

!

B7

interface Serial0

ip address 10.10.5.2 255.255.255.252

!

interface Ethernet1

ip address 192.168.40.1 255.255.255.252

!

router ospf 1

network 10.10.5.0 0.0.0.255 area 0

network 192.168.40.0 0.0.0.255 area 0

!

In Figure 12.1, consider these problems:

  1. Network 192.168.30.0/27 is unavailable in the routing table of B7, as shown in the output.

    B7#show ip route 192.168.30.0 %Network not in table
  2. Network 192.168.50.0/24 is unavailable in the routing table of B3, as shown in the output.

    B3#show ip route 192.168.50.0 %Network not in table

Network 192.168.30.0/27 Unavailable at B7

To isolate and resolve this problem:

  1. Check B2 to see if interface 192.168.30.1/27 is up, because this is the only interface corresponding to network 192.168.30.0/27. Listing 12.1 displays output of the show ip interface brief command for B2.

    Listing 12.1 Output of the show ip interface brief Command

    start example
    B2#show ip interface brief Interface        IP-Address       OK? Method    Status     Protocol Ethernet1        192.168.30.1     YES NVRAM     up         up Serial0          10.10.1.1        YES NVRAM     up         up Serial1          10.10.3.1        YES NVRAM     up         up
    end example

    Listing 12.1 Shows that the interface is up.

  2. Check if routing for this interface is taking place in EIGRP. Listing 12.2 displays output of the show ip protocols command for B2.

    Listing 12.2 Output of the show ip protocols Command

    start example
    B2#show ip protocols Routing Protocol is "eigrp 100"   Outgoing update filter list for all interfaces is not set   Incoming update filter list for all interfaces is not set   Default networks flagged in outgoing updates   Default networks accepted from incoming updates   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0   EIGRP maximum hopcount 100   EIGRP maximum metric variance 1   Redistributing:    Automatic network summarization is in effect   Maximum path: 4   Routing for Networks:    10.10.1.0    10.10.3.0    192.168.30.0   Passive Interface(s):     Routing Information Sources:     Gateway         Distance      Last Update     10.10.3.2           90        00:05:35     10.10.1.2           90        00:05:20    Distance: internal 90 external 170           
    end example

    The output shows that routing is happening for the EIGRP network.

  3. Check if route 192.168.30.0/27 is available in the routing table of B1, where redistribution is occurring. Listing 12.3 displays output of the show ip route command for B1.

    Listing 12.3 Output of the show ip route Command

    start example
      B1#show ip route 192.168.30.0/27   Routing entry for 192.168.30.0/27   Known via "eigrp 100", distance 90, metric 41075200, type internal   Last update from 10.10.3.1 on Serial0, 01:01:05 ago   Routing Descriptor Blocks:   *10.10.3.1, from 10.10.3.1, 01:01:05 ago, via Ethernet1       Route metric is 41075200, traffic share count is 1       Total delay is 42000 microseconds, minimum bandwidth is 64 Kbit       Reliability 255/255, minimum MTU 1500 bytes       Loading 3/255, Hops 3             
    end example

    Listing 12.3 shows that the route is available in the routing table of B1. The route is being propagated all over the EIGRP domain and is unavailable only in the OSPF domain.

  4. Check the redistribution configuration of EIGRP routes into OSPF at B1. The relevant part of the configuration is shown in Listing 12.4.

    Listing 12.4 Part of Configuration to Check Redistribution

    start example
    ! router ospf 1 network 10.10.4.0 0.0.0.255 area 0 redistribute eigrp 100 metric 1000 !
    end example

In Listing 12.4, no mention is made of the subnets of the primary classful networks. The address 192.168.30.0/27 is a subnet of 192.168.30.0/24 and is not getting redistributed, because the subnets keyword is not mentioned in redistribution. The corrected configuration commands are shown in Listing 12.5.

Listing 12.5 Corrected Configuration for Redistribution of 192.168.30.0/27

start example
! router ospf 1 network 10.10.4.0 0.0.0.255 area 0 redistribute eigrp 100 metric 1000 subnets !
end example

Now, the route will be available as shown in Listing 12.6.

Listing 12.6 Output of the show ip route Command for B7

start example
  B7#show ip route 192.168.30.0   Routing entry for 192.168.30.0/27   Known via "ospf 1", distance 110, metric 3, type extern 1   Last update from 10.10.5.1 on Serial0, 01:12:50 ago   * Routing Descriptor Blocks:     10.10.5.1, from 192.168.45.1, 01:12:50 ago, via Ethernet1      Route metric is 3, traffic share count is 1   
end example

Network 192.168.50.0/24 Unavailable at B3

To isolate and resolve this problem:

  1. Check B6 to see if interface 192.168.50.1/24 is up, which is the only interface corresponding to network 192.168.50.0/24. Listing 12.7 displays output of the show ip interface brief command for B6.

    Listing 12.7 Output of the show ip interface brief Command

    start example
    B6#show ip interface brief | inc Ethernet2 Ethernet2            192.168.50.1     YES NVRAM  up              up
    end example

    This output shows that the interface is up.

  2. Check if routing for this interface is taking place in OSPF. Listing 12.8 displays output of the show ip protocols command for B6.

    Listing 12.8 Output of the show ip protocols Command

    start example
      B6#show ip protocols   Routing Protocol is "ospf 1"   Outgoing update filter list for all interfaces is not set   Incoming update filter list for all interfaces is not set   Router ID 192.168.50.1   Number of areas in this router is 1. 1 normal 0 stub 0 nssa   Maximum path: 6   Routing for Networks:     192.168.50.0 0.0.0.255 area 0     192.168.45.0 0.0.0.255 area 0     10.10.5.0 0.0.0.255 area 0     Passive Interface(s):     Routing Information Sources:     Gateway         Distance      Last Update     192.168.45.1            110      00:00:00     10.10.5.2            110      00:00:00   Distance: (default is 110)
    end example

    Listing 12.8 shows that routing is happening for the OSPF network.

  3. Check if the route is available in the routing table of B1, where redistribution is happening. Listing 12.9 displays output of the show ip route command for B1.

    Listing 12.9 Output of the show ip route Command

    start example
    B1#show ip route 192.168.50.1 Routing entry for 192.168.50.0/24   Known via "ospf 1", distance 110, metric 3, type internal   Last update from 192.168.45.2 on Ethernet1, 01:12:50 ago   Routing Descriptor Blocks:     192.168.45.2, from 192.168.45.2, 01:12:50 ago, via Ethernet1      *Route metric is 3, traffic share count is 1 
    end example

    The output shows that the route is available in the routing table of R1. The route is being propagated all over the OSPF domain and is unavailable only in the EIGRP domain.

  4. Check the redistribution configuration of OSPF routes into EIGRP configured at B1. The relevant part of the configuration is displayed in Listing 12.10.

    Listing 12.10 Redistribution Configuration

    start example
    router eigrp 100 network 10.10.2.0 network 10.10.3.0 redistribute ospf 1 route-map redis-1 ! route-map redis 10 permit 10 match ip address 15 set metric 10000 100 255 1 1000 ! access-list 15 permit 192.168.40.0 0.0.7.255 access-list 15 permit 10.10.0.0 0.0.255.255
    end example

    In Listing 12.10, we see that some restriction has been applied to redistribution of routes from OSPF to EIGRP using route-map redis-1. The route map matches routes against access list 15. The access list 15 is not redistributed, because it does not match route 192.168.50.0/24.

  5. Modify the access list using these commands:

    access-list 15 permit 192.168.0.0 0.0.255.255 access-list 15 permit 10.10.0.0 0.0.255.255

    This will ensure redistribution of all available OSPF routes into EIGRP. The route will be available as shown in Listing 12.11.

    Listing 12.11 Available Route After Access List Modification

    start example
    B3#show ip route 192.168.50.0 Routing entry for 192.168.50.0/24 Known via "eigrp 100", distance 90, metric 41075200, type internal Last update from 10.10.1.1 on Serial0, 01:01:05 ago Routing Descriptor Blocks:  *10.10.1.1, from 10.10.3.2, 01:01:05 ago, via Serial0       Route metric is 41075200, traffic share count is 1       Total delay is 42000 microseconds, minimum bandwidth is 64 Kbit       Reliability 255/255, minimum MTU 1500 bytes       Loading 3/255, Hops 3                     
    end example




Cisco IP Routing Protocols(c) Trouble Shooting Techniques
Cisco IP Routing Protocols: Trouble Shooting Techniques (Charles River Media Networking/Security)
ISBN: 1584503416
EAN: 2147483647
Year: 2006
Pages: 130

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net