Misconfiguration in EIGRP


Misconfiguration is one of the root causes of problems in any network. Misconfiguration can be caused either by manual or system errors. You need to take extreme care while configuring an EIGRP routing protocol in a router, because even a small configuration error can affect the network traffic. Consider the scenario depicted in Figure 8.3. There are three routers, B1, B2, and B3, in an EIGRP network.

click to expand
Figure 8.3: An EIGRP network with possibility for misconfigurations.

In Figure 8.3, simulate a few possible misconfigurations and define methods to solve them. The misconfigurations could be due to:

  • Network not declared in EIGRP

  • Same Autonomous System (AS) not defined in all routers in EIGRP domain

    Network Not Declared in EIGRP

Consider a network segment 192.168.1.0/24 containing the secondary DNS server of the company with IP 192.168.1.10. The misconfiguration is caused by not declaring the network 192.168.1.0/24 in the EIGRP configurations. Table 8.4 shows the configurations of the three routers, B1, B2, and B3.

Table 8.4 : Configurations of EIGRP Routers

Router

Configuration

B1

interface Ethernet 0

ip address 192.168.15.1 255.255.255.0

!

interface Ethernet 1

ip address 192.168.1.1 255.255.255.0

!

router eigrp 10

network 192.168.15.0

!

B2

interface Ethernet 0

ip address 192.168.15.2 255.255.255.0

!

interface Ethernet 1

ip address 192.168.2.1 255.255.255.0

!

router eigrp 10

network 192.168.2.0

network 192.168.15.0

!

Observation

The end users connected to the LAN segments 192.168.2.0/24 and 192.168.3.0/24 are not able to browse the Internet because of the misconfiguration.

Problem Isolation

The steps to isolating the problem caused due to not declaring a network in the EIGRP domain are:

  1. Note if the problem occurs when the primary DNS server, 192.168.2.4, is down.

  2. Require users to contact the secondary DNS server, 192.168.1.1.

  3. Issue a ping command to 192.168.1.1 from B2 and B3 to check connectivity to this server. A 100% failure is noted. The ping command is executed as shown in Listings 8.9 and 8.10.

Listing 8.9 Ping Command at B2

start example
B2#ping 192.168.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)
end example

Listing 8.10 Ping Command at B3

start example
B3#ping 192.168.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)
end example

  1. Issue the commands:

    B2#show ip route 192.168.1.0 % Network not in table     B3#show ip route 192.168.1.0 % Network not in table
  2. Check if B1 is an EIGRP neighbor of B3 and B2 using the show ip eigrp neighbors command. The output for the show ip eigrp neighbors command is shown in Listing 8.11 and Listing 8.12. This output confirms that B1, B2, and B3 are EIGRP neighbors.

Listing 8.11 Output of show ip eigrp neighbors Command at B2

start example
B2#show ip eigrp neighbors IP-EIGRP neighbors for process 10 H   Address          Interface   Hold Uptime   SRTT   RTO   Q     Seq                                  (sec)                (ms)  Cnt   Num 1   192.168.15.3     Se0         14 1w6d       48     288   0     3471 0   192.168.15.1     Et0         14 1w6d       3      200   0     8558
end example

Listing 8.12 Output of show ip eigrp neighbors Command at B3

start example
B3#show ip eigrp neighbors IP-EIGRP neighbors for process 10 H   Address          Interface   Hold Uptime   SRTT   RTO   Q     Seq                                  (sec)                (ms)  Cnt   Num 1   192.168.15.2     Se0         14 1w6d       48     288   0     3471 0   192.168.15.1     Et0         14 1w6d       3      200   0     8558
end example

  1. Check the availability of route to network 192.168.1.0 at B1 using the show ip route 192.168.1.0 command. The output for the show ip route 192.168.1.0 command showing that 192.168.1.0 is a connected network is shown in Listing 8.13.

Listing 8.13 Output for show ip route 192.168.1.0 Command at B2

start example
B2#show ip route 192.168.1.0 Routing entry for 192.168.1.0/24 Known via "connected", distance 0, metric 0 (connected, via interface)   Routing Descriptor Blocks:   * directly connected, via Ethernet1   Route metric is 0, traffic share count is 1
end example

  1. Check if EIGRP is enabled for this network in B1 using the show ip protocols command. The output for the show ip protocols command is shown in Listing 8.14.

Listing 8.14 Output for show ip protocols Command at B1

start example
B1#show ip protocols Routing Protocol is "eigrp 10"   Outgoing update filter list for all interfaces is not set   Incoming update filter list for all interfaces is not set   Default networks flagged in outgoing updates   Default networks accepted from incoming updates   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0   EIGRP maximum hopcount 100   EIGRP maximum metric variance 1   Redistributing: static, eigrp 300   Automatic network summarization is in effect   Maximum path: 4   Routing for Networks:    192.168.15.0   Passive Interface(s):     Routing Information Sources:     Gateway         Distance   Last Update     192.168.15.2    90         00:05:35     192.168.15.3    90         00:05:20    Distance: internal 90 external 170      
end example

Listing 8.14 shows the networks for which EIGRP routing takes place. EIGRP routing does not occur for network 192.168.1.0. The corrected configuration of B1 should be as shown in Listing 8.15.

Listing 8.15 Correct Configuration of B1

start example
! interface Ethernet 0 ip address 192.168.15.1 255.255.255.0 ! interface Ethernet 1 ip address 192.168.1.1 255.255.255.0 ! router eigrp 10 network 192.168.15.0 network 192.168.1.0 !
end example

Same AS Not Defined in EIGRP Routers

Consider the same example depicted in Figure 8.3. Table 8.5 lists the configuration of the routers in the EIGRP network.

Table 8.5 : Configuration of Routers

Router

Configuration

B1

interface Ethernet 0

ip address 192.168.15.1 255.255.255.0

!

interface Ethernet 1

ip address 192.168.1.1 255.255.255.0

!

router eigrp 10

network 192.168.15.0

!

B2

interface Ethernet 0

ip address 192.168.15.2 255.255.255.0

!

interface Ethernet 1

ip address 192.168.2.1 255.255.255.0

!

router eigrp 20

network 192.168.2.0

network 192.168.15.0

!

B3

interface Ethernet 0

ip address 192.168.15.3 255.255.255.0

!

interface Ethernet 1

ip address 192.168.3.1 255.255.255.0

!

router eigrp 10

network 192.168.3.0

network 192.168.15.0

!

Observation

The users connected to the LAN segments 192.168.1.0/24 and 192.168.3.0/24 are not able to connect to the internal Web server, 192.168.2.5. This problem occurs because the same AS is not defined in all the routers in the EIGRP routing domain.

Problem Isolation

The steps to isolate the problem are:

  1. Issue a ping command to network 192.168.2.5 from B1 and B3 to check connectivity using the ping 192.168.2.5 command. The output of the ping 192.168.2.5 command is shown in Listings 8.16 and 8.17.

Listing 8.16 Output of ping 192.168.2.5 Command at B1

start example
B1#ping 192.168.2.5 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.2.5, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)
end example

Listing 8.17 Output of ping 192.168.2.5 Command at B3

start example
B3#ping 192.168.2.5 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.2.5, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)
end example

The listings show a 100% failure of the ping command.

  1. Issue the commands:

    B1#show ip route 192.168.2.0 % Network not in table     B3#show ip route 192.168.2.0 % Network not in table

    The output of these commands shows there is no route available to the network.

  2. Check if B2 is an EIGRP neighbor of B1 and B3 using the show ip eigrp neighbors command. Listings 8.18 and 8.19 show the output for the show ip eigrp neighbors command.

Listing 8.18 Output of show ip eigrp neighbors Command at B1

start example
B1#show ip eigrp neighbors IP-EIGRP neighbors for process 10 H   Address          Interface   Hold Uptime  SRTT   RTO   Q    Seq                                  (sec)               (ms)  Cnt  Num 1   192.168.15.3     Se0         14 1w6d      48     288   0    3471
end example

Listing 8.19 Output of show ip eigrp neighbors Command at B3

start example
B3#show ip eigrp neighbors IP-EIGRP neighbors for process 10 H   Address          Interface   Hold Uptime  SRTT   RTO   Q     Seq                                  (sec)               (ms)  Cnt   Num 1   192.168.15.1     Et0         14 1w6d      3      200   0     8558
end example

The listings show that B2 is not a neighbor of B1 and B3.

  1. Check the availability of route to network 192.168.2.0 at B2 using the show ip route 192.168.1.0 command at B2. The output shows that 192.168.2.0 is a connected network

  2. .Check if EIGRP is enabled for this network in B2 using the show ip protocols command. The output for the command is shown in Listing 8.20.

Listing 8.20 Output for show ip protocols Command at B2

start example
B2#show ip protocols Routing Protocol is "eigrp 20"   Outgoing update filter list for all interfaces is not set   Incoming update filter list for all interfaces is not set   Default networks flagged in outgoing updates   Default networks accepted from incoming updates   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0   EIGRP maximum hopcount 100   EIGRP maximum metric variance 1   Redistributing: static, eigrp 300   Automatic network summarization is in effect   Maximum path: 4   Routing for Networks:    192.168.2.0    192.168.15.0   Passive Interface(s):     Routing Information Sources:     Gateway         Distance      Last Update    Distance: internal 90 external 170           
end example

Listing 8.20 shows that the Autonomous System Number (ASN) in B2 is 20 and is 10 in B1 and B3. The corrected configuration of B2 is shown in Listing 8.21.

Listing 8.21 Correct Configuration of B2

start example
interface Ethernet 0 ip address 192.168.15.2 255.255.255.0 ! interface Ethernet 1 ip address 192.168.2.1 255.255.255.0 ! router eigrp 20 network 192.168.2.0 network 192.168.15.0 !
end example




Cisco IP Routing Protocols(c) Trouble Shooting Techniques
Cisco IP Routing Protocols: Trouble Shooting Techniques (Charles River Media Networking/Security)
ISBN: 1584503416
EAN: 2147483647
Year: 2006
Pages: 130

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net