Summary

 

In this chapter, we have examined the basic configuration of some of the most common elements of the TCP/IP network protocol with the example ZIP network. As with all features of the Cisco IOS software, there are hundreds of additional subfeatures and knobs that the network administrator can configure to enhance the operation of the network and the router. Through investigating the various documentation resources and experimenting in the lab, the network administrator can begin to more thoroughly understand and appreciate the power of the IOS software to create a robust and powerful networking environment. The following are the key concepts of this chapter:

  • IP addresses are decimal representations of 32-bit binary numbers . IP addresses are grouped as network address blocks and are categorized into particular network classes. Network administrators can subdivide network address space among multiple LAN and WAN segments via subnetting.

  • Configuring IP addresses involves assigning IP addresses to interfaces of the router. IP addresses are assigned out of either public or private network address space. Public addresses are provided by either an ISP or a regional address registry. Configuring IP addresses on WAN interfaces requires additional commands to manually map data-link addresses to IP addresses.

  • IP routing configuration enables the router to perform the IP switching function. Static routes can be used to build the table of destination network addresses, which is called a routing table. Summary and default routes provide reachability information while minimizing the amount of information that must be maintained in the routing table. Classless routing allows routers to send packets destined to network addresses that do not fall on traditional classful network boundaries.

  • Dynamic IP routing protocols enable routers to exchange reachability information about the networks that are locally attached to them. Dynamic routing protocols are grouped into two major categories, Interior Gateway Protocols and Exterior Gateway Protocols. The two major types of Interior Gateway Protocols are distance vector and link-state protocols. The IOS software provides tools to control the propagation of network routing information and the interaction of routers exchanging dynamic routing information.

  • IP access lists provide the capability to filter the flow of packets in an IP network for security and privacy purposes. Access lists are enabled in two steps-defining the filtering criteria and then applying it. Access lists serve as the tool to enable other types of filtering, such as dynamic routing information.

  • Basic IP dialup services permit remote users to access the network via modem and ISDN dialup as if they were attached via a LAN medium.

  • IP connectivity can be verified with commands such as show ip route and ping . The diagnostic capabilities of the trace and debug commands enable the network administrator to detect misconfigurations and troubles within his router and network.

  • IP features such as domain name service ease the support burden on the network administrator. Broadcast forwarding permits broadcast-based services, such as DHCP, to work in a routed network. IOS DHCP Server provides a router- or access server-based dynamic address assignment service for small and medium- sized networks. Hot Standby Router Protocol provides fault tolerance and redundancy for IP stations that cannot support dynamic routing protocols.

Table 4-8. Summary of EXEC Commands for IP
Command Description
clear host Removes temporary entries from the IP host table.
clear ip access-list counters Clears the count of the number of times that each line of an IP access list has been matched.
clear ip route Clears the entire routing table or, if specified, a particular route.
ping ip-address Tests the indicated IP address to determine whether it is reachable and responsive .
show { frame-relay atm x25 dialer } map Shows mappings of IP addresses to data-link addresses on the specified WAN media type.
show access-lists Shows all access lists defined on the router.
show host Verifies the DNS configuration on a router and displays a list of hosts that have had their names resolved to IP addresses.
show interface interface Provides general information about an interface, including the IP address and network mask.
show ip access-lists Shows all IP access lists defined on the router.
show ip arp Displays all IP addresses that the router has been capable of resolving to MAC addresses.
show ip dhcp binding Displays information about the IOS DHCP server address assignments.
show ip dhcp conflictu Displays information about IP address conflicts detected by the IOS DHCP server during the allocation process.
show ip dhcp database Displays information about the location and status of the database used by the IOS DHCP server for logging DHCP bindings and conflicts.
show ip dhcp server statistics Displays status information and counters relating to the operation of the IOS DHCP server.
show ip interface brief Shows a brief summary of IP address information and interface statuses for all available interfaces on the device.
show ip interface interface Shows all the parameters associated with the IP configuration of an interface.
show ip masks network-address Lists the network masks that have been applied to the designated network and the number of routes that use each mask.
show ip protocols Shows which routing protocols are running and various attributes of those protocols. When used with the keyword summary , it shows only protocol names and process-id numbers.
show ip route Outputs the IP routing table of the router.
show ip route connected Shows the routes associated with the operational, directly connected interfaces of the router.
show ip route ip-address Shows routing information for the specified route.
show ip route static Shows the routes that are derived from manually configured network route commands.
show ip traffic Outputs overall statistics about the operation of the IP on the router.
show standby Displays information on the operation of HSRP.
Terminal ip netmask -format { decimal bit-count hexidecimal } Specifies the display format of network masks to be used during the existing virtual terminal or console session.
trace ip-address Displays each step of the network path that a packet travels to reach the indicated IP address.
Table 4-9. Summary of Configuration Commands for IP
Command Description
aaa authentication ppp list method Specifies that PPP should be authenticated via the listed AAA method.
aaa authorization network method Specifies that network services should be authenticated via the listed AAA method.
access-list Creates a numbered access list and its associated filtering criteria.
arp-server Identifies the ATM ARP server that can resolve IP addresses to ATM NSAP addresses.
async-bootp dns-server ip-address Specifies the IP address(es) of a DNS server supplied to dialup clients during call establishment on a global basis.
async-bootp nbns-server ip-address Specifies the IP address(es) of a NetBIOS/WINS nameserver supplied to dialup clients during call establishment on a global basis.
async mode { interactive dedicated } Specifies the user interaction method on an async interface for dialup users.
autoselect during-login Specifies that the autoselection process should be performed during the authentication process.
autoselect ppp Specifies that autodetection of PPP should be performed on an async line that is configured in interactive mode.
compress Specifies that a compression algorithm should attempt to be negotiated during PPP dialup negotiation.
default-metric Assigns default routing metric values to be used during route redistribution between dynamic routing protocols.
default-router address Defines one or more default router IP addresses that are supplied to DHCP clients by the IOS DHCP server.
dialer- group integer Specifies the dialer group to which an interface belongs and specifies which dialer list is used to define interesting traffic.
dialer-list list-number protocol type method Defines a dialer list that specifies which network protocols and which methods are used to define traffic as interesting for dialup sessions.
dialer map ip Maps an IP address to the system name and the phone number for ISDN calls.
dialer rotary -group integer Assigns an ISDN interface to the dialer interface group structure.
distribute-list Applies an access list to the task of filtering the receipt and advertisement of network routes.
dns-server address Defines one or more DNS server IP addresses that are supplied to DHCP clients by the IOS DHCP server.
domain-name domain Defines a DNS domain name that is supplied to DHCP clients by the IOS DHCP server.
flowcontrol { hardware software } Specifies the flow control method on an async line.
frame-relay map ip Maps an IP address to a Frame Relay DLCI.
group-range start end Specifies which async interfaces are included in the group-async interface structure.
ip access-group list { in out } Applies the indicated access list to the task of filtering incoming or outgoing packets on an interface.
ip access-list { extended standard } name Creates a named IP access list and its associated filtering criteria.
ip address ip-address network-mask Assigns an IP address and network mask to LAN and WAN interfaces.
ip classless Enables the router to operate in classless mode, in which destination IP addresses match supernet and CIDR block routes.
ip default-information originate Causes OSPF to generate the default route from the autonomous system boundary router into the rest of the OSPF domain.
ip default-network network-address Configures the specified network address as a summary or default network.
{ no } ip dhcp conflict logging Enables or disables the logging of address conflict information by the IOS DHCP server.
ip dhcp database url Defines the location and method for logging the IOS DHCP server bindings and conflict information.
ip dhcp excluded-address Specifies one or more IP addresses that should be excluded from DHCP offers to DHCP clients by the IOS DHCP server.
ip dhcp pool name Creates a DHCP address pool that can be configured with additional DHCP configuration subcommands.
ip dhcp-server ip-address Specifies the IP address of a DHCP server that can dynamically assign IP addresses to dialup clients.
ip domain-list name Establishes a list of domain names to append to unqualified host names.
ip domain-lookup Enables DNS.
ip domain-name name Configures the primary domain name to append to unqualified host names.
ip forward-protocol udp type Controls which type of UDP broadcasts get forwarded.
ip helper-address ip-address Forwards UDP broadcasts to the specified IP address.
ip host Configures static mapping of a host name to the IP address(es).
ip local pool { default pool-name } start-ip-address end-ip-address Creates an IP address pool for dynamically assigning IP addresses to dialup clients.
ip name-server ip-address Configures DNS nameserver(s).
ip netmask-format { decimal bit-count hexidecimal } Configures the display format of network masks to be used during virtual terminal or console sessions.
ip ospf network { broadcast non-broadcast point-to-multipoint } Configures the network typebroadcast, non-broadcast, or point-to-multipointthat OSPF believes is connected to the interface.
ip rip { send receive } version Specifies which RIP version to send and receive on a specific interface.
ip route 0.0.0.0 0.0.0.0 destination-ip-address Configures a default route of 0.0.0.0.
ip route network-address network-mask destination-ip-address Configures a static route.
ip route network-address network-mask ip-subnet-address Configures a summary route, taking as parameters the summary route, the network mask, and the nonconnected subnet.
ip routing Enables IP routing on the router.
ip subnet-zero Allows the first subnet in a network address range (subnet zero) to be assigned to an interface.
ip unnumbered interface Configures an unnumbered IP point-to-point WAN interface.
map-group Assigns a named map group to an interface for use in mapping IP addresses to ATM data link addresses on an interface.
map-list Creates a named map list to configure the mapping of IP addresses to PVCs or SVCs in ATM addressing.
modem autoconfigure { discover type modemtype } Specifies that a modem attached to an async line should be automatically configured by discovery or by using the settings of the named modem type.
modem { dialin inout } Specifies the allowed direction of async calls.
neighbor ip-address Specifies the IP address of a neighbor router with which to exchange dynamic routing information.
neighbor ip-address description Allows for comments to be added to the BGP neighbor command.
neighbor ip-address distribute-list Allows for route filtering on a per-BGP peer basis.
neighbor ip-address remote-as asn Configures the neighbor router with the indicated address in the indicated autonomous system as a BGP peer.
neighbor ip-address update-source interface Specifies that the source IP address for establishing the BGP peer session should be derived from the named interface.
netbios-name-server address Defines one or more NetBIOS/WINS server IP addresses to supply to DHCP clients by the IOS DHCP server.
netbios-node-type type Defines the NetBIOS behavior mode that is supplied to DHCP clients by the IOS DHCP server.
network network-address Specifies that connected interfaces matching the indicated network address should be included in routing advertisements.
network network-address area area# Specifies that connected interfaces matching the indicated address should be included in OSPF routing advertisements and that the interfaces should be assigned to the specified area.
network network-number [ mask prefix-length ] Specifies the range of IP addresses that will be offered to DHCP clients for a given DHCP address pool by the IOS DHCP server.
no auto-summary Prevents automatic address summarization at classful network boundaries and allows for the propagation of subnet information.
no inverse-arp Disables the dynamic IP-address-to-DLCI mapping function of Frame Relay.
passive-interface interface Configures the router to listen to but not to advertise routing information on the indicated interface.
peer default ip address { pool dhcp ip-address } Specifies the method used to assign an IP address to a dialup client workstation.
ppp authentication method Specifies that PPP authentication should be performed before allowing network services to begin. The named authentication protocol is used between the access server and the dialup client.
ppp ipcp { dns wins } Specifies the IP address(es) of DNS or NetBIOS/WINS servers to be supplied to dialup clients during PPP session establishment on a per-interface basis.
ppp multilink Specifies that software-based channel multiplexing should be enabled on an interface.
redistribute protocol Enables route redistribution from the indicated protocol.
router { rip igrp ospf eigrp bgp} Enables the router to run the specified dynamic routing protocol.
speed bits-per-second Specifies the transmission speed on an async line.
standby ip ip-address Configures the indicated IP address as the virtual IP address for an HSRP group.
standby preempt Causes a higher-priority HSRP router to resume active forwarding when it becomes available again.
standby priority priority Assigns a priority value to an HSRP router to control the selection of the primary forwarding router.
standby track interface Enables the dynamic adjustment of the HSRP priority of an HSRP router based on the operational status of the specified interface.
standby use-bia Forces the HSRP virtual IP address to be associated with the hardware burned-in MAC address of an interface.
{ no } synchronization Enables or disables the requirement for routes to be learned via the IGP routing process before advertising to EBGP neighbors.
username name password word Defines a local username/password pair to use for authenticating dialup users.
version rip-version Specifies which version of RIP is used on a RIP-enabled router.
x25 map ip Maps an IP address to an X.121 address.


Cisco Router Configuration
Cisco Router Configuration (2nd Edition)
ISBN: 1578702410
EAN: 2147483647
Year: 1999
Pages: 116

flylib.com © 2008-2017.
If you may any questions please contact us: flylib@qtcs.net